Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Installing 'wget' on 10.1 UNIX
Apple has removed 'wget' from OS X 10.1, apparently due to GPL (the Gnu Public License) issues. This is a most handy command, as it can download files and web pages from the command line over an SSH connection. I use it regularly to start large downloads at home while I'm at work.

To replace 'wget', you can download it from one of the GNU software mirror sites (it's in the 'wget' directory) and compile it yourself (this will require the Developer Tools to be installed). Once you've downloaded and expanded the archive, simply "cd" to that directory and type "sudo make install" to install the new 'wget'.

Once I've received my Dev Tools CD, I'll make a pre-compiled version available on my mac.com home page.
  Post a comment  •  Comments (12)  
  • Currently 3.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[5,962 views]  View Printable Version
renice functional in 10.1 UNIX
Readers will appreciate that the 'renice' command [Editor: This command changes the default CPU allocation of currently running tasks] appears to be fully functional in 10.1. I started two instances of the distributed.net client and then used 'top' to examine the CPU usage of each. Read the rest of the article if you'd like to see the results (and they're notably changed from what would be seen under 10.0.4!).
read more (114 words)   Post a comment  •  Comments (0)  
  • Currently 2.00 / 5
  You rated: 1 / 5 (2 votes cast)
 
[4,827 views]  View Printable Version
GUI-based SSH1/2 client for OSX UNIX
For a while now I've been hoping someone would come out with a GUI-based SSH terminal app for OSX. MacSSH and NiftyTerm actually seem to work just fine under Classic, but I was hoping for a native solution to turn up. Naturally one can always open shell and start the default OpenSSH client. It's slightly cumbersome but I guess if you're doing remote terminal logins in the first place, you're not exactly adverse to extra typing. =-) Additionally, someone here posted a great hint about making Finder-launchable SSH shell login scripts.

Anyway, there's been a Java-based SSH app out there called Mindterm. I never thought to give it a try until now. The company's webpage states that it's free for non-commercial use and while they don't explicitly say so, I found it runs fine under Mac OSX.

The only hitch is that after you uncompress the archive, you have to launch it from the shell with:
java -jar mindterm.jar
If someone who knows more about Java could figure out a way to launch it from the Finder, that would be great. (The Applet Launcher didn't seem to work)

The program is a bit flaky here and there (the built-in SFTP client stalled whenever I attempted a transfer) but it is useable and seems support the full range of ciphers and authentications usually associated with SSH1&2.
  Post a comment  •  Comments (5)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[17,575 views]  View Printable Version
Help with mod_mp3 streaming server UNIX
I have recently tried setting up a MP3 server using mod_mp3, but so far have had trouble streaming my files.

If anyone who has had experience setting this up could please share there experiences and httpd.conf directives, that would be great.
  Post a comment  •  Comments (3)  
  • Currently 4.33 / 5
  You rated: 5 / 5 (3 votes cast)
 
[3,598 views]  View Printable Version
How to uninstall UNIX packages UNIX
I was having problems with XFree86, where a window manager i installed caused the whole thing to go kablooey and I wanted to un-install it. After reading this site, I found that the standard way of uninstalling doesnt work because of a bug in the installer. Well, I got the installer to list the files that the .pkg included, and I saved it to a text file. I then opened it up and found that besides the first line of the document, every line contained the name of one file and its path.

Now, while I dont know UNIX or scripting, I do know that there are enough smart people out there to figure out how to write something that will take this file listing and delete them all....Maybe a piped rm thing or something? Any thoughts?

swammifool
  Post a comment  •  Comments (4)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[9,737 views]  View Printable Version
Compiling snort for OS X UNIX
It may just be paranoia, but I've ahd a rash of anon FTP and other attempts on my systems here after the attack. I've got Brickhouse installed (still new to the use of it) but I wanted to add in some alert security.

SNORT (www.snort.org) is highly recommended from what I hear, but I'm having some trouble getting it to work. I've installed the devTools have tried to compile it (after chaninging the HOST info to "localhost" in the configure file) but I'm getting a make error after the compile...

Read the rest of the article for the error output if you think you can help debug this issue...
read more (132 words)   Post a comment  •  Comments (6)  
  • Currently 2.25 / 5
  You rated: 3 / 5 (4 votes cast)
 
[13,266 views]  View Printable Version
Another method of changing your hostname UNIX
We all know you can change the host name in OS X through /etc/hostconfig, but that can have problems, such as Apache not working right.

In the Terminal type:
% sudo open -a /Applications/TextEdit.app /usr/share/init/tcsh/rc
In TextEdit look for a line:
set host = `hostname`
change `hostname` to anything you like:
set host = "Big Papa"
There you go, new host name without the hassle of hostconfig.

[Editor: I have not tested this myself, but the rc file does contain the hostname reference. I don't know the implications of changing it here versus editing hostconfig or using NetInfo Manager...anyone have any thoughts?]
  Post a comment  •  Comments (10)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[6,877 views]  View Printable Version
Help with CVS on new machine UNIX
I've just bought my new PowerBook G4, throwing away the corporate Intel machine. Working with CVS on my old machine I wanted to continue doing so with my Mac, but... CVS isn't there?

And even if it is there, is it possible to use my old keys, since I use ssh to authenticate, in an easy way?

Or would I have to go back to my Wintel§ on which everything works just fine?

Thankful for any responses.

  Post a comment  •  Comments (5)  
  • Currently 3.00 / 5
  You rated: 3 / 5 (1 vote cast)
 
[2,754 views]  View Printable Version
Unlock locked files from the terminal UNIX
In response to a newsgroup request for a way to unlock files from the command line I wrote this script. Note that it uses developer tools SetFile and GetFileInfo (so you'll need the Dev Tools installed for this to work).

Read the rest of the article for the cut-and-paste script and instructions.
read more (148 words)   Post a comment  •  Comments (4)  
  • Currently 1.50 / 5
  You rated: 3 / 5 (4 votes cast)
 
[31,523 views]  View Printable Version
Listserv for X or X server UNIX
Does anyone know of a listserv (mailing list) program that will work under MacOS X, X Server 10.0, or Darwin? If there's not one with a GUI, I'm more than willing to configure and install one under the terminal if necessary, but I want to stay out of Classic for this.
  Post a comment  •  Comments (2)  
  • Currently 3.50 / 5
  You rated: 5 / 5 (6 votes cast)
 
[2,708 views]  View Printable Version