Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.7: A solution for MacBook Air and Mac mini lack of install media System 10.7
I'm not happy with not having restore media and I'm not patient enough to wait for a 3.5 GB download, so I sought another solution.

The new MacBook Air and Mac mini use a build of 10.7 different from the regular installer from the App Store. If the hard drive is replaced or wiped it's necessary to download the installer from Apple's servers using Lion Recovery from either the Restore Partition or using Lion Internet Recovery.

Firewire or Thunderbolt Target Disk Mode (T key at boot) makes creating a copy of the contents of the drive using another machine an easy matter, but what about the Recovery Partition? For that, first enable the DeBug Menu in Disk Utility on your second machine. Once that has been enabled choose the 'Show every partition' option and the Recovery Partition is visible and the contents can be copied.

At this point it's possible to restore the image that originally came with the MB Air, but if it's a new or wiped drive the restore would lack the Recovery Partition. Adding the recovery partition needs to be done at the command line because Disk Utility at the GUI won't permit creating a partition as small as the Recovery Partition, nor will it hide the partition properly.

The process is fairly clear; reduce the size of the main partition, create the Recovery Partition, then because diskutil is a little confused, correct the size, copy the contents of the Recovery Partition and then designate the type of partition.

Detailed instructions (Use 10.7.x for all of this):
  • Using Thunderbolt Target Disk Mode from MacBook Air to other machine, image Apple install from the MacBook Air drive to the destination.
  • Enable the Disk Utility DeBug menu using this command:

    defaults write com.apple.DiskUtility DUDebugMenuEnabled -bool true

  • With the DeBug Menu now visible, enable the 'Show every partition' option, then use the Mount menu command to show the Recovery Partition on Desktop, and image it as well.
  • Next, establish a 650MB partition on HD. It should be this size: 681574400. Use diskutil info to find the Total Size of main partition = X, then subtract 650MB from that size to get the new size of main partition; i.e., X - 681574400 = NewSize.
  • This command will resize main partition and create the new Recovery Partition:

    diskutil resizeVolume /dev/disk0s2 NewSizeB jhfs+ "Recovery HD" 650002432B

    (Note that's a 'B' at the end of the number.)
  • Results likely will show that Disk Utility didn't quite make it 650MB so that can be fixed:

    diskutil resizeVolume disk0s3 650002432B

  • Restore the data previously copied out of the original Recovery partition.
  • This command will make the Recovery partition invisible and set it's type correctly:

    asr adjust --target /dev/disk0s3 -settype "Apple_Boot"
The source for much of this hint is here though it's modified it for ease and a better understanding of what takes place.

[crarko adds: I haven't tested this one.]
  Post a comment  •  Comments (6)  
  • Currently 2.43 / 5
  You rated: 1 / 5 (7 votes cast)
 
[8,772 views] Email Article To a Friend View Printable Version
10.7: Restore secondary Click on MBP 4.1 Trackpad System 10.7
After installing the 10.7 upgrade on my MBP 4.1, along with the Trackpad's scroll direction re-orientation, I noticed that the two-finger touch+click was no longer invoking the Secondary Click (Ctrl+click) function. After digging around, I found the solution in an Apple Discussions Forum.

Here's the bit from user Maxym's Apple Discussion Forum reply that worked for me:

'To workaround this problem on older MacBooks, open Terminal.app and run the following command:

defaults -currentHost write -g com.apple.trackpad.enableSecondaryClick -bool YES

Then log out and log back in (to disable secondary click pass NO instead of YES as the last argument).'

As an aside: Along with the missing function, I also noticed that the example video for the two-finger Secondary Click in the System Preferences » Trackpad was also missing.

[crarko adds: I haven't tested this one. It's possible this has also been fixed in one of the Lion updates. If you have experienced this issue post about it in the comments.]
  Post a comment  •  Comments (0)  
  • Currently 3.75 / 5
  You rated: 4 / 5 (4 votes cast)
 
[4,691 views] Email Article To a Friend View Printable Version
10.7: Move Spaces in Mission Control in 10.7.2 System 10.7
The Lion 10.7.2 update adds the ability to move Spaces and full screen apps.

[crarko adds: When I tried this it looked like Desktop 1 and Dashboard were fixed but I could switch the other Desktops and full screen app Spaces around at will by dragging them in Mission Control. I don't have a 10.7.1 system any more, so I'll trust this is new.]
  Post a comment  •  Comments (3)  
  • Currently 4.00 / 5
  You rated: 4 / 5 (7 votes cast)
 
[5,060 views] Email Article To a Friend View Printable Version
10.7: Hold Option in Launchpad to quickly delete or move an App System 10.7
Holding down the Option key in Launchpad lets you quickly delete or move an App. Makes things a little bit quicker for anyone used to click and holding on an app instead. Also brings up the 'X' for all the apps at once.

[crarko adds: When I tried this the app screen went into 'wiggle mode' so I could move the icons around, but the only ones that had the 'X' for deletion show up on were those that I had downloaded and installed via the Mac App Store. I assume this is a permissions-related effect. Please post your observations about how this works for you in the comments.]
  Post a comment  •  Comments (6)  
  • Currently 2.67 / 5
  You rated: 2 / 5 (6 votes cast)
 
[4,304 views] Email Article To a Friend View Printable Version
10.7: Adding entries to the Cisco AnyConnect hosts file System 10.7
I have been having problem adding entries into the OSX Lion's /etc/hosts file. I found that my entries into the /etc/hosts file only stuck around until I rebooted, then the /etc/hosts file would revert back to the default entries. My changes to the file were lost.

[crarko adds: This hint has been found to be specific to users of Cisco AnyConnect VPN client, and does not affect you otherwise. ]

In order to add your entries and make it stick in the /etc/hosts file, what you need to do is:
  • Launch Terminal.
  • Type sudo nano /etc/hosts.ac or sudo vi /etc/hosts.ac
  • Enter your admin password.
  • Add in your entries at the end of the file.
  • Save and exit.
If you make edits to the /etc/hosts file (like you do for Unix/Linux) your entries will not stick around after a reboot. You need to edit the /etc/hosts.ac file instead.

[crarko adds: I'm not sure about this one. I looked, and didn't see any /etc/hosts.ac file, and a search didn't reveal much of anything. Any of you folks out there who make modifications to hosts; when you've made changes under Lion do they stick or do you see the same kind of thing as this hint's author? And have any of you observed the hosts.ac file? I'd like to know where that comes from.]
  Post a comment  •  Comments (15)  
  • Currently 2.00 / 5
  You rated: 1 / 5 (9 votes cast)
 
[12,647 views] Email Article To a Friend View Printable Version
10.7: Migrating Time Machine data to Lion System 10.7
I recently upgraded to Lion and tried to migrate my Time Machine backup. Then I couldn't find my files.

I recently upgraded to Lion, then bought a new Mac which had Snow Leopard installed by default. I tried to migrate my Time Machine backup to the new Mac. First I had to upgrade the OS to Lion since the TM backup was created using Lion. Once the upgrade was complete and I tried to migrate my data from TM, I couldn't find my files.

I looked in System Profiler which said I had 95gigs of movies, 48gigs of music and so on. But none of these files could be found in my system. I discovered that when migrating TM data, Lion creates a new user account.

Then when you first log in, the account is fresh and clean with no data. If you go up to the menu bar and look for your mac account name on the right, click it. You'll notice another account along with the 'Guest' user account. Click on the other admin account and log in. There is your Mac just as you left it before upgrading.

[crarko adds: I don't have a setup to try this, but in the past I remember Time Machine prompting about what to do if an account with the same user shortname already exists on the target machine. Maybe that's why the new account is now created? Anyway, if someone else has had to do this please post how it worked for you in the comments.]
  Post a comment  •  Comments (7)  
  • Currently 4.20 / 5
  You rated: 4 / 5 (5 votes cast)
 
[10,932 views] Email Article To a Friend View Printable Version
10.7: Mission Control with older keyboards System 10.7
No matter what Mission Control key combination settings exist and what type of keyboard is in use, Esc activates the selected Desktop (Space) in Mission Control.

When using my MacBook Pro's internal keyboard, I can use F3 to activate Mission Control, select a Desktop with Control+left or right arrow, then press F3 again to activate the selected Desktop. Sometimes I use an older Apple Extended Keyboard which doesn't support that use of F3, so default settings allow me to use Control+up arrow to activate Mission Control.

In that situation I can leave the Control key down during the process of activating Mission Control and selecting a Desktop (requiring Control+left or right arrow), but I have to release and press it again to use the Control+up arrow shortcut to activate the selected Desktop.

Although I might have expected the Esc key to cancel the selection of a different Desktop in Mission Control and activate the Desktop previously in use, I discovered that it instead activates the selected Desktop as well, regardless of other Mission Control key combination settings.

[crarko adds: This is more confusing to read than it is to do. The main point is that the Escape key will activate the selected Space.]
  Post a comment  •  Comments (3)  
  • Currently 2.80 / 5
  You rated: 3 / 5 (5 votes cast)
 
[4,271 views] Email Article To a Friend View Printable Version
10.7: Software Update now logs all Apple Updates System 10.7
The Software Update preference pane has always kept a list of Apple updates installed through the Software Update system. The list of updates are shown in the Installed Updates tab. Under 10.7, this list now contains Apple installs done manually or through Software Update. So a user could update print drivers through Software Update, grab the latest iTunes from a site like MacUpdate, and install the iWork trial from the Apple site, and all of these would be listed.

[crarko adds: I wonder if this is due to changes made in the first-run scripts of the packages because of the App Store distribution system.]
  Post a comment  •  Comments (1)  
  • Currently 3.17 / 5
  You rated: 2 / 5 (6 votes cast)
 
[4,796 views] Email Article To a Friend View Printable Version
10.7: Update to Command+Return with Spotlight results System 10.7
Since Spotlight was introduced in 10.4, users could press Command+Return when selecting a Spotlight menu result to reveal the file in the Finder.

The exceptions to this behavior were things like contacts, iCal events, and Mail messages (as noted in this hint from 2006). For those types of items, the corresponding application would open and display the content. This behavior has changed in 10.7 and the files are now revealed in the Finder when invoking this shortcut.

[crarko adds: You may of course also get the Quick Look preview of the item first, or select it and open it as before.]
  Post a comment  •  Comments (3)  
  • Currently 3.00 / 5
  You rated: 4 / 5 (5 votes cast)
 
[2,998 views] Email Article To a Friend View Printable Version
10.7: Restoring hidden Finder Windows System 10.7
After 5 Lion upgrades, I ran across 2 machines that would not show any Finder windows, I could not see any open folders or the hard drives. They showed up under the windows list, under the Finder icon, and as large thumbnails, after a Show all Windows. But would not show up as a window despite selecting them, or 'Bring all to Front.'

Other user accounts on the same machines worked, just not the main upgraded accounts. Rebooting did not help.

The solution for me was to Control+Click on the Finder Icon and Relauch it.

[crarko adds: This sounds a lot like corruption of the user's Finder preferences (~/Library/Preferences/com.apple.finder.plist) or cache (~/Library/Caches/com.apple.finder). If you have this problem and the simple fix of the hint doesn't solve it you may want to move these to the Trash, logout/login and let Finder create a fresh set. At times in the past, iCal windows were also susceptible to this problem and trashing the iCal prefs and caches was the fix.

Changed Option-click back to Control-click. My fault.]
  Post a comment  •  Comments (7)  
  • Currently 2.80 / 5
  You rated: 2 / 5 (5 votes cast)
 
[8,261 views] Email Article To a Friend View Printable Version