Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.4: Reduce launch times for AppleScript apps on Intel System 10.4
If you use AppleScripts that you save as applications and are on an Intel Mac, you should like this hint.

In Script Editor, if you save as Application, this will create a PowerPC-only application -- it will launch on an Intel mac, but under Rosetta. However, if you save it as an Application Bundle instead, this will create a Universal binary. The Application Bundle behaves the same in the GUI as an Application -- it is a double-clickable application.

Note that the actual script itself is not compiled in either case, it is interpreted at run-time. What is changed is the wrapper around the script. This means that saving as an Application Bundle on an Intel Mac will not improve the execution time of the actual script, but you should notice a significant improvement in launch time, as Rosetta does not have to be invoked. If you saved any scripts as Applications on a PowerPC Mac and have since upgraded to an Intel Mac, you can always open them in Script Editor and re-save them as Application Bundles.
  Post a comment  •  Comments (9)  
  • Currently 2.83 / 5
  You rated: 5 / 5 (6 votes cast)
 
[14,302 views] Email Article To a Friend View Printable Version
10.4: Modify hot corners to prevent accidental activation System 10.4
This older hint describes one way of preventing accidental activations of Exposè.

As of 10.4, however, it is also possible to add modifier keys to the hot corners in the Dashboard and Exposè panel of System Preferences. Just hold down Shift, Control, Option, Command (or some combination thereof) while selecting an option from the list.

This may be useful if you find yourself accidentally activating Dashboard, Exposè or even the screen saver when you flick the mouse to a screen corner.

Note that when a modifer key is set, you must have the key pressed before you put the pointer in the corner; it is not enough to hit the modifier key as an afterthought.
  Post a comment  •  Comments (16)  
  • Currently 4.00 / 5
  You rated: 4 / 5 (6 votes cast)
 
[15,712 views] Email Article To a Friend View Printable Version
10.4: Flatten directory structure using Spotlight System 10.4
In the Finder, if you want to see all the files in the current folder, including all sub folders, then just type a full stop (the period key) in the search field. This will show you all files which have extensions, such as .jpg, .html, .txt, .doc, etc. If you know you have some files without extensions, then you can use a size search instead -- just look for all files with a size greater than 0kb.

After you have your results, you can switch to another view such as list view (View -> As List), and order your results by modification date, for example. If you work on web sites with lots of directories, this is an easy way to see all the files you've modified recently and need to upload to your web server, regardless of how deeply buried they may be.

This also works really well in Adobe GoLive. Search for a full stop, order the results by modification date, and it's easy to select the latest files for GoLive to upload to your web server.
  Post a comment  •  Comments (1)  
  • Currently 3.20 / 5
  You rated: 3 / 5 (5 votes cast)
 
[9,842 views] Email Article To a Friend View Printable Version
10.4: Work around a non-functional screensaver lock System 10.4
Several people on the Apple forums have reported that the 'Lock Screen' function of Keychain Access doesn't work, despite having "Require password to wake this computer from sleep or screensaver" toggled on in the Security System Preferences panel.

I discovered that if I log out and then log in again, the screensaver lock works as expected, and remains functional until the next restart. FYI, my machine is started from cold every day, and Automatic Login is disabled. This abberant behaviour happens on my Quicksilver Dual 800, but not on my old and venerable B&W G3, both running 10.4.7.

Of course, YMMV ... hope this helps a few folks.
  Post a comment  •  Comments (4)  
  • Currently 3.00 / 5
  You rated: 2 / 5 (5 votes cast)
 
[8,864 views] Email Article To a Friend View Printable Version
10.4: Keep third-party-trapped Mail spam out of Spotlight System 10.4
While Spotlight doesn't index Mail's Junk folder, if you use third-party anti-spam software that sorts spam into its own Spam folder -- such as Intego Personal Antispam, which is what I use -- your spam may get indexed. Once indexed, Spotlight will return some of your spam messages when searching for seemingly banal words, since so many spam messages have blocks of "normal" text in them. (Also, since I get about 500 spams per day, that's a lot of indexing time when mail arrives.)

So, to prevent Spotlight from indexing spam, open the Spotlight preferences, click the Privacy tab, then drag ~/Library -> Mail -> Mailboxes -> (name of your spam folder) to the list of items that Spotlight won't index.

[robg adds: There's a general hint in the system about using the Privacy tab to block some mailboxes. However, for those using third party anti-spam tools, this more specific version should cut down on the amount of cruft visible in your Spotlight search results.]
  Post a comment  •  Comments (3)  
  • Currently 2.33 / 5
  You rated: 5 / 5 (9 votes cast)
 
[6,690 views] Email Article To a Friend View Printable Version
10.4: Force a volume to mount on an Intel Mac System 10.4
I have a 300GB USB 2.0 hard drive that I've been using with my Intel iMac since I got it last April. It had been working flawlessly until just a couple of days ago. All of a sudden, the drive would no longer mount, and a dialog box came up asking if I wanted to ignore, eject, or initialize the disk. If I tried to initialize the disk, or do anything at all with the Disk Utility, the command would time out with an input/output error.

I was unable to find anything regarding this issue on the web, but I did come across a great open source program called rEFIt. With rEFIt installed, I was able to boot into an EFI shell. When you boot into the shell, it lists all of the available partitions, but it lists them as blk1, blk2, blk3, etc.

After figuring out which partition it was that I was trying to work with -- in my case it ended up being blk5 -- I typed in the command mount blk5 in the shell, and it forced the volume to mount. Then when I exited the shell and booted into the Mac OS, the volume appeared as it should, and I was even able to manipulate it again in Disk Utility without any errors.

I still don't understand why this happened in the first place, but here's a little workaround.
  Post a comment  •  Comments (4)  
  • Currently 3.17 / 5
  You rated: 4 / 5 (6 votes cast)
 
[53,395 views] Email Article To a Friend View Printable Version
10.4: Stagger startup items for less system impact System 10.4
I don't know about you, but whenever I start/restart my Mac, I hate the way that when it's reached the Desktop, it tries to launch all the start-up items at the same time. Then the hard drive starts whirring like mad, hopping back and forth and splitting its time between each app. Some of my menu bar items that launch at start-up are standard apps, i.e. non-system stuff, so I tried altering the way they launch by delaying them for a certain amount of time to allow other stuff to start first.

Read on for my solutions, one using Automator and the other using AppleScript.
read more (472 words)   Post a comment  •  Comments (15)  
  • Currently 2.67 / 5
  You rated: 4 / 5 (6 votes cast)
 
[34,079 views] Email Article To a Friend View Printable Version
10.4: A FileVault/wake from sleep password issue System 10.4
Beware sleeping your Mac from a FileVault account! I have a FileVault-enabled non-admin on my PowerBook G4, and I have it set to require a password to wake the computer from sleep or screensaver.

If I close or sleep my PB under this account (or choose Lock Screen from the Keychain menu), then wake it, the system asks for password authentication. However, if I then type the name and password of an admin account (instead of the FileVault account), voila! I get full access to the encrypted account and all FileVault contents.

The screensaver authentication is apparently significantly different (and less secure) than the loginwindow authentication.

[robg adds: I haven't tested this one, so if someone who uses FileVault could confirm it, please post your results in the comments.]
  Post a comment  •  Comments (13)  
  • Currently 2.40 / 5
  You rated: 4 / 5 (5 votes cast)
 
[11,798 views] Email Article To a Friend View Printable Version
10.4: Fix a Bluetooth/SideTrack issue in 10.4.7 System 10.4
After upgrading to 10.4.7 here this week, I found that my Bluetooth connectivity had dropped off entirely. When opening System Preferences and navigating to the Bluetooth panel, the app would hang and I'd have to force quit. Also, no previously-paired Bluetooth device was able to be discovered by my PowerBook G4. Very unnerving to say the least.

As it turns out, following a bit of digging, I discovered that my (much out of date) version of SideTrack was somehow conflicting with the new updates. Once I grabbed the latest version (1.4.1 as of this morning) and installed it, the conflict has been resolved!

Hopefully this helps those out there who have an older version of SideTrack and are experiencing this hard-to-resolve problem.

[robg adds: SideTrack is one of my laptop must-haves, but it's a replacement driver for the default trackpad driver in the OS. As such, system updates can occasionally break it, and remaining current is quite important -- much more so than with an application that would probably just fail to launch if it was affected by an OS update.]
  Post a comment  •  Comments (1)  
  • Currently 2.60 / 5
  You rated: 5 / 5 (5 votes cast)
 
[5,110 views] Email Article To a Friend View Printable Version
10.4: Use an auto-generated plist file with AppleScript System 10.4
While helping out in this thread on the AppleScript.net site, wheerin the original poster wanted to store some prefs in an AppleScript application, I discovered that when I ran the app which would write to a homemade .plist file, I noticed a second file in the user's Preferences folder.

This second .plist file turned out to be an automatically-created plist file, generated by the system. It had entries for recent items and some more odds and ends.

So now when you need to write out to a plist from an AppleScript application, you can use this prefs file to write to. This example from the thread shows how it works.

[robg adds: The test script seems to work, but this is probably of the most use to the dedicated AppleScript programmers out there, as opposed to the occasional muddlers like myself.]
  Post a comment  •  Comments (3)  
  • Currently 3.20 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (5 votes cast)
 
[8,519 views] Email Article To a Friend View Printable Version