Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.4: Change the Tile Game widget's image System 10.4
You know the Tile Game widget, with the picture of the tiger? I got tired of the tiger picture, so I attempted to change it to another picture. Turns out it was pretty easy.

[robg aside: Temporarily changing the Tile Game's image is quite simple -- make sure the Tile Game widget is open, then start dragging an image in the Finder, activate Dashboard, and drop it on the Tile Game widget. Your image will replace the tiger, at least until the next time you close the widget. This hint explains how to permanently change the image on the widget.]

First, create (if you don't have one already) a folder named Widgets in your user's Library folder. Now navigate to the top-level /Library » Widgets folder, and copy the Tile Game file to your user's Library » Widgets folder. OS X will first look for widgets in your user's folder, so we'll modify the copy of the widget, not the original.

Control-click on the Tile Game file in your user's Library » Widgets folder. (Make sure you're in your user's Widgets folder, not the top-level Library » Widgets folder.) Select Show Package Contents from the pop-up menu, and navigate into the Images folder. You'll find the familiar tiger image in the file game.png. Rename this file to game_old.png.

Now, to choose a replacement image. I looked through my iPhoto pictures and found an image I liked -- a turtle I saw on the beach in Hawaii. In iPhoto, I cropped the image with a square constraint. Then I exported the image as a PNG to my desktop using the "small" setting. I think small is sufficient -- if the image is 200x200 pix that's probably fine (the actual size of the game.png image is 144x144). Of course, I named the file game.png.

Lastly, I copied the new game.png to the Images folder. All done! When relaunching the widget, my new turtle image is the puzzle's image.
read more (187 words)   Post a comment  •  Comments (2)  
  • Currently 4.00 / 5
  You rated: 4 / 5 (5 votes cast)
 
[22,080 views] Email Article To a Friend View Printable Version
10.4: Recover from a dragging issue in Disk Utility System 10.4
I think this is an issue with Intel Macs, but it may be all Macs with a 10.4 Installer DVD. Apple has a support document, Unable to drag and drop in Disk Utility while started from install DVD, that explains a bug in Disk Utility found on some 10.4 Install DVDs (including my MacBook Pro's). I ran into this when my hard drive failed, and I needed to clone it to send it off to Apple for replacment -- and now again that I want to upgrade to a new 200Gb 7200/16Mb internal hard drive.

There is a workaround beyond those provided by Apple, assuming your internal hard drive has Disk Utility on it, it's in the normal place, and you are willing to use Terminal. After you boot from the Installer DVD, and are on the first installer screen (just past the language screen), go to the Utilities menu and choose Terminal. In Terminal, type:
cd "/Volumes/YourInternalHD/Applications/Utilities/
Disk Utility.app/Contents/MacOS/"
Replace YourInternalHD with the actual name of your internal hard drive. Press Return, then type:
./Disk Utility
That's it. Disk Utility will launch off of your internal hard drive, and now you can drag within the Restore portion of the program.

[robg adds: I broke the cd line into two for a narrower display. One easy way to get to that directory is to type cd "/Vol[Tab], then type a few letters of your hard drive's name, hit Tab again, type App and hit Tab, etc. Terminal will auto-complete and add the slashes for each directory.]
  Post a comment  •  Comments (8)  
  • Currently 2.20 / 5
  You rated: 5 / 5 (5 votes cast)
 
[14,917 views] Email Article To a Friend View Printable Version
10.4: A detailed look at MacFUSE and the SSH file system System 10.4
Have you ever been been at work or somewhere else and wished you could access the files on your home computer remotely and safely? (Or maybe the other way around?) I've just helped someone set up a remote connection through a router to their work machine so they can access the files from home. (Of course this only will work if it's your computer and you have authorization to modify the router settings and remotely access the computer.)

Google provides MacFUSE (File System in User Space) that provides this ability via a secure (SSH) connection, and it's fairly easy to do. Basically, with MacFUSE installed, it's like having the remote computer's hard drive mounted on your desktop (remember it'll be a little slow via the internet), but you can do anything on the remote machine that you need to (providing you have the related applications on the local machine to access the remote files). The real advantage here is it's a much more secure method and passwords do not get sent in the clear.

For the setup I just did, the hardest part was getting the LinkSys router to set a static IP address for the remote machine, which is necessary for this project. I ended up doing a firmware upgrade to the router (definitely NOT for the faint-of-heart) but the resulting router system was far superior to the standard Linksys software -- but that's a whole other subject.

[robg adds: What follows is a more detailed version of this hint, and it contains a bit of updated information. If you found the original hint detailed enough, then you'll probably find this one redundant.]
read more (601 words)   Post a comment  •  Comments (17)  
  • Currently 3.50 / 5
  You rated: 4 / 5 (6 votes cast)
 
[31,402 views] Email Article To a Friend View Printable Version
10.4: Merge modified dictionaries from two different Macs System 10.4
As with many users, I use both a laptop and a desktop Mac. On both systems, I use the check spelling feature, and often add words to the dictionaries. The problem is that the two dictionaries are different on both Macs. Here is a shell script [Original source | macosxhints mirror] to synchronize these spelling files using a web site. Each time the script is launched, the remote spelling file is dowloded, synchronised with the local spelling file, then sent to the the remote web site.

Open the script using TextWrangler or your favorite text editor, and fill in the Configure section:
  • LANG allows you to choose which language file to use.
  • REMOTESPELLING is the path of the dictionary on the web site : http://somewhere/folder/$LANG
  • The four variables are for uploding to the web. FTPHOST is the FTP site URL; FTPUSER is the admin user; FTPPASSWORD is your password; and FTPSPELLING is the path of the spelling file on FTP server (www/somewhere/spelling/$LANG).
The script can be used with a crontab file to automate the synch process.

[robg adds: I haven't tested this one.]
  Post a comment  •  Comments (3)  
  • Currently 2.40 / 5
  You rated: 3 / 5 (5 votes cast)
 
[7,347 views] Email Article To a Friend View Printable Version
10.4: A fix for the modem GUI not showing completed jobs System 10.4
I recently had the experience that my internal modem did not show my sent faxes anymore. As soon as I clicked on Completed Jobs within the internal modem.app, the window became sluggish and did not react anymore. I finally found out that it had something to do with one of the earlier jobs that was not sent properly. These jobs are stored in /var » spool » cups and begin with somewhat like c0*.

In addition to that, there is a wonderful CUPS administrative view that you access with your browser via http://localhost:631 that I hadn´t seen before. There you'll find your printers, but also your internal modem and all the jobs that have ever been faxed with it. One of these jobs had to be my "killer." Note that this job list is generated dynamically at startup of the cups daemon. If you mangle around with the job files (moving or deleting), you won´t see a result until you restart the daemon with sudo killall -1 cupsd.

So I moved the jobs according to the number within the job list shown within the browser GUI (easy: the job named printer-1136 would be found as c01136 in /var/spool/cups), one by one. After each move, I restarted the cups daemon and -- bingo -- problem solved when I finally found the broken file and could see my sent faxes again.

To move or delete files within /var/spool/cups, you must have admin rights. I like to provide myself with full rights by opening the shell via sudo (sudo csh then enter password). There's no more need to authenticate, but be very careful, as the system is now completely in your hands!

[robg adds: We've covered the CUPS admin web interface before, and for something like this, I'd probably just use sudo on the file(s) to be deleted, instead of using a full-on root shell -- because I don't trust myself!]
  Post a comment  •  Comments (0)  
  • Currently 2.20 / 5
  You rated: 2 / 5 (5 votes cast)
 
[7,761 views] Email Article To a Friend View Printable Version
10.4: Create an 'active files' view using Smart Folders System 10.4
I often find I'm working with several files nested deep within client project folders. Rather than clutter my screen with a pile of open Finder windows, I've instead created a Smart Folder that focuses on the active files I'm working on.

Create and save a smart folder with the following options:
  • Select Others... at the top of the Smart Folder and add the folder or folders you want included, making sure to uncheck other items like Macintosh HD, etc.
  • Kind = Any
  • Last Modified = Since Yesterday
You can change Kind to focus on specific files, or Last Modified if you are a little less active. I now have a Smart Folder in the sidebar which allows me to easily jump to the project files and folders I'm actively working on.

[robg adds: This is a pretty basic Spotlight/Smart Folders tip, but might be useful to those who are just starting to work with Smart Folders. This hint explained how to create a similar list of recent applications.]
  Post a comment  •  Comments (2)  
  • Currently 2.60 / 5
  You rated: 3 / 5 (5 votes cast)
 
[10,151 views] Email Article To a Friend View Printable Version
10.4: Fix a muted Plantronics USB microphone on 10.4.10 System 10.4
After one of the recent 10.4.10 updates on an Intel iMac, the microphone on my Plantronics USB headset appeared to be disabled. The solution that worked for me was to use Applications » Utilities » Apple MIDI Setup, and access Properties For » Plantronics Headset under Audio Devices. At the bottom of the panel, there is a Mute checkbox, and unchecking this restored the microphone's operation.

I can't take credit for the fix; I found it via Google on macspeech.com. However, I thought this might be worth passing on to macosxhints.

The 10.4.10 update did not cause this problem on a G4 PowerBook, so I believe this is related to the recent Intel audio fix that Apple released. However, after launching Apple MIDI Setup on the G4, the microphone was disabled and the checkbox was not accessible. The only solution there was to unplug and re-plug the headset's USB cable.
  Post a comment  •  Comments (6)  
  • Currently 3.00 / 5
  You rated: 1 / 5 (6 votes cast)
 
[13,835 views] Email Article To a Friend View Printable Version
10.4: Make the Spotlight menu bar icon invisible System 10.4
So, you don't want Spotlight's ugly blue lens present in the menu bar, right? How about concealing it? As an administrator, navigate to /System » Library » CoreServices » Search.bundle. Control-click on Search.bundle and choose Show Package Contents. In the new window that opens, navigate into /Contents » Resources. Copy MDSearchWidget_Normal-1.tiff to the desktop. Open this file in Photoshop or your editor of choice, and wipe the Spotlight lens and then save. (The file will get bigger -- from some 2.5k to 52k or so; it's OK.)

Now, check the permissions of original file and match it on our copied file by unlocking it. Lock it again and put it back inside the Resources folder, after removing the original and storing it in a safe place. Run Disk Utility and repair permissions and restart. Voila. The Spotlight lens is gone from the menu. However, there are two things that remain:
  1. The space occupied by the Spotlight lens remains. The date is that much offset to the left.
  2. By clicking on the place where the Spotlight icon was, you can still use Spotlight, just without looking at the icon.
[robg adds: I haven't tested this one; I actually like the Spotlight icon. This earlier hint touched on modifying the various Spotlight resources, while this hint explained how to completely disable the Spotlight menu.]
  Post a comment  •  Comments (7)  
  • Currently 3.00 / 5
  You rated: 5 / 5 (5 votes cast)
 
[16,162 views] Email Article To a Friend View Printable Version
10.4: More convenient filename searches System 10.4
Leopard will have a better file name search capability, but while we wait, searching for file names with wildcards and boolean AND/ORs can be fairly convenient with this hint. First, some setup. Go to your home folder and choose FIle » New Smart Folder from the menu. Click on the minus signs to remove all the search terms, and then click on the plus sign to add one. Click on Kind and choose "Other...". After a short delay, a list will appear. Scroll down and select Raw Query, then press OK. Now copy and paste the following lines (including the blank lines) into the query text box:

(i==' Scroll forward and replace "xxx" with filename, use "||" for OR,  "&&" for AND, "*" for wildcard, "cwd" for case insensitive/any word ')||((kMDItemDisplayName= '*xxx*'cwd) || (kMDItemDisplayName= '*xxx*'cwd))&&(kMDItemContentType!=com.apple.mail.emlx)&&(kMDItemContentType!=public.vcard)&&(kMDItemContentType!=com.apple.safari.bookmark))

Click the Save button and save the search with the name File Name Search. Select it in your home directory, choose File » Get Info, and change the permissions to "Read only." Then drag the smart folder to the sidebar of a Finder window.
read more (137 words)   Post a comment  •  Comments (10)  
  • Currently 1.40 / 5
  You rated: 1 / 5 (5 votes cast)
 
[11,711 views] Email Article To a Friend View Printable Version
10.4: A fix for non-mounting USB drives in 10.4.10 System 10.4
After updating my Mac to OS X 10.4.10, my external FireWire/USB2 drive didn't mount any more (if plugged in via the USB2 port). I thought about an interface failure specific to my enclosure, but searching on the web, I saw that it was a common problem for 10.4.10 users with Intel Macs and external enclosures. Moreover, I tested the drive on another Mac with 10.4.9 and it worked flawlessly. So it was a problem with the 10.4.10 update.

The only solution found until now was downgrading to 10.4.9 again, but this is a real pain. I was ready to use Pacifist to replace the new USB kernel extensions with the older 10.4.9 ones. But before doing this, I wanted to check if I could force the drive to mount in some way, and accidentally found the workaround.

I used System Profiler to list USB devices and get the VendorID/ProductID of the drive; it was listed amongst my other devices. As I needed some more device information, I launched USB Prober (included with Apple's Xcode Developer Tools) and ... the drive mounted on desktop! Apparently the polling that USB Prober does on USB devices causes OS X to realize that the device is a USB Storage Class product and finally mounts it. I tried several times and it always worked: USB Prober makes the drive mount.

So, if you have the same problem with your external USB device, here's a workaround until Apple fixes it:
  1. Plug your drive in
  2. Launch USB Prober (/Developer » Applications » Utilities » USB Prober)
  3. After the drive mounts, quit USB Prober
That's it! The only drawback is that you must have the Developer Tools installed (as USB Prober comes with them). If you don't want to install all of the developer tools, you can simply extract the application from the installer package using Pacifist. Hope this helps!
  Post a comment  •  Comments (26)  
  • Currently 3.00 / 5
  You rated: 2 / 5 (6 votes cast)
 
[96,987 views] Email Article To a Friend View Printable Version