Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.4: Create simple backups with SSH and Spotlight System 10.4
Tiger only hintThis only works in 10.4, and requires that you have adequate space on an accessible SSH-capable machine (Linux, Unix or OS X, maybe Windows if you know how to set up SSH on it ... but I don't).

This script will use passwordless ssh and Spotlight to create backups of your key files. There are several things done here that seem clunky, especially with Spotlight. There are some great metadata tags that would be useful -- except that I have seen states in my own system where metadata are not properly generated at file creation time. I therefore went with the most basic tags possible (the ones that will be created).

No ".*" files are backed up, by the way -- Spotlight does not index them, and they are not, therefore, noticed. For help with the passwordless ssh, see the following: [robg adds: I haven't tested this one. The script is well documented, so read the comments in there for the detailed how-to. Remember to make the script executable with chmod a+x script_name, too.]
  Post a comment  •  Comments (6)  
  • Currently 2.40 / 5
  You rated: 3 / 5 (5 votes cast)
 
[8,167 views] Email Article To a Friend View Printable Version
10.4: FileVault breaks some Automator Actions System 10.4
Tiger only hintI recently solved a problem I have been having with Automator for a while. When I run certain Automator actions (for example, when trying to rename Finder items) I get the following error:

AppleScript Error: Finder got an error: Can't get properties of alias "user:path:to:file". (error -1728)

It turns out that if you have FileVault enabled, many Automator actions break when you run them. My hunch is that this bug has to do with the way the system handles paths to your home directory when it is mounted through FileVault.

The solution is to either disable FileVault, or to simply copy the file(s) out of your home directory before running the Automator action on them, and then copy them back when you are done. What I don't understand is why the same Automator action worked when I created it months ago, but stopped working somewhere along the way.
  Post a comment  •  Comments (7)  
  • Currently 3.00 / 5
  You rated: 2 / 5 (5 votes cast)
 
[8,766 views] Email Article To a Friend View Printable Version
10.4: Finder selections and Automator action targets System 10.4
Tiger only hintIf you use the Automator action 'Get Selected Finder Items' in your workflow, when you actually use the workflow, make sure the item you wish to affect is actually highlighted before you run the action!

I innocently opened a folder in column view and then right-clicked on an item within it and selected an Automator workflow, believing it would function on the item I right-clicked on. Well, it wasn't so much a folder I had selected as a hard-drive. I was attempting to run the tar Automator script on a folder. I noticed, however that it was taking a very long time to compress the item I thought I had selected. I stopped the workflow and checked my /Volumes folder, and found out that the workflow had been operating on my hard drive, as opposed to the item I had selected.

With so many cool Automator workflows showing up here and elsewhere, I thought it should be made known exact what a "Selected Finder Item" was.

[robg adds: This also bit me when I first started using Automator -- to the Finder, there's a difference between the currently selected item and the item you just control-clicked. To make sure things work as expected, click the item first, then control-click on that same object and choose your Automator action.]
  Post a comment  •  Comments (3)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[6,098 views] Email Article To a Friend View Printable Version
10.4: Some info on iChatAgent 'not responding' System 10.4
Tiger only hintWell, this isn't really a hint or a solution to a problem, but just for those of you who were concerned by seeing the iChatAgent in red ("Not Responding") in your Activity Monitor. Did you even occasionally try to fix the issue by force quitting the process? If so, well, you can sleep better now after reading this Knowledge Base article:
Even though the red text may give the impression that something is amiss, you can safely ignore the message unless you can't log in. Activity Monitor can display this message even when iChatAgent is responding.
Don't panic!
  Post a comment  •  Comments (3)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[9,674 views] Email Article To a Friend View Printable Version
Restore logging of SSH logins System 10.4
Tiger only hintWith the release of 10.4, Apple has changed logging for ssh. I used to keep an eye on break-in attempts to my home computer (see this hint), which has SSH login enabled so I can log in from work.

After I installed Tiger, I didn't see any more attacks, which was quite odd. After some digging, I found that Apple is changing the logfile system, and plans for further changes in the future (see man syslogd for a bit more detail). The upshot of all this is that to get a service to log correctly, an entry is needed in the file /etc/syslog.conf, which is documented in the syslog.conf help file (man syslog.conf). The short of it is that you need to look at the file /etc/sshd_config, and find the logging section. There you should see this:
# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO
This shows you sshd's log settings, which you need for the next step. Edit the file /etc/syslog.conf with some text editor (and sudo) and change this line (the second line in the file):
*.notice;authpriv,remoteauth,ftp,install.none;kern.debug;mail.crit
  /var/log/system.log
You need to add ;auth.info immediately after mail.crit (before the Tab that preceeds the /var/log... bit). Save the file and either reboot (ugly) or restart the syslog daemon with this command: sudo kill -HUP `cat /var/run/syslog.pid` What you have done is added a directive to syslog.conf to inform syslogd that log requests from auth at level info and above should be logged in the system log file. Then you signaled syslogd to reload the configurations (those are back ticks (the key just under the esc key)). Presto, login attempts are now back in the system log.

[robg adds: I wrapped the long code line above for a narrower display. In the original file, the /var/log bit appears after a Tab at the end of the line. Do not add a line break if you edit this file! I tested this, and it worked -- as soon as I made the change and restarted the daemon, the login attempts started showing up again.]
  Post a comment  •  Comments (8)  
  • Currently 4.00 / 5
  You rated: 4 / 5 (6 votes cast)
 
[24,821 views] Email Article To a Friend View Printable Version
10.4: A fix for Motorola wireless cards under 10.4.2 System 10.4
Tiger only hintI have a Dual PowerMac G4; it's from before the time of AirPort Extreme Card slots. It does has an AirPort slot, but only for wireless-b AirPort cards ... which you can no longer get from Apple, and other place charge a premium. Macwireless.com does have WiFi-G card that work for this unit, but once again, they charge a premium ($150 was the cheapest I found).

But you can use a cheap Motorola card, WPC1810G, which I found for 35$ at a local Radio Shack on clearance. I found that this card was confirmed to work based off a website I found using google.com. Unfortunately, I lost the reference to that site; sorry. Sadly, this card stops working once you upgrade Tiger to 10.4.2. There is an update to the AirPort kernel extensions, from version 3.5 to 4.0. I don't know if Apple did it on purpose, or just doesn't care to make sure it doesn't break third-party wireless cards. But this update does.
read more (226 words)   Post a comment  •  Comments (5)  
  • Currently 2.75 / 5
  You rated: 5 / 5 (4 votes cast)
 
[8,449 views] Email Article To a Friend View Printable Version
10.4: Demystify Spotlight's saved search syntax System 10.4
Tiger only hintSpotlight is terrible. But at the same time, very useful. Let's hope Apple cleans it up a bit in a future release. But until then, here is some more help - to go along with the tons of Spotlight hints we already have here.

Spotlight saved searches, or "Smart Folders," are simply XML files with a .savedSearch extension. Within that XML file, which you can open using any text editor, there is a tag called RawQuery; immediately following that is another called (ambiguously) string. The string tag right after the RawQuery tag is the "code" for your search.

Since Spotlight limits what you can put in the query in various ways, sometimes it is hard to get what you want out of it. Boolean searches are well documented both on this site and others -- but they prove problematic and inconsistent. So this hint is intended to share some info about how to modify the "code" in the saved search to get what you want.
read more (491 words)   Post a comment  •  Comments (21)  
  • Currently 3.00 / 5
  You rated: 3 / 5 (5 votes cast)
 
[20,020 views] Email Article To a Friend View Printable Version
10.4: Avoid a fax sending bug with Brother MFCs System 10.4
Brother updated their drivers for a number of their MFC devices early in 2005 for Tiger. Unfortunately, they included a bug that removes the ability to fax to a manually-entered number. Instead, you are forced to use Apple's Address Book to drag a contact over to the Fax/Print dialog. If you use Entourage, for example, you're out of luck.

There is a workaround, however. Delete the printer from Printer Setup, then delete all of the Brother printer related items in your /Library/Printers directory. Download the 10.3 driver from Brother's website. It still works quite well. There's a patch available for Tiger, but it does not appear to be necessary for printing or faxing. (I don't use the scanner and have not installed the software, so I can't comment about whether the Tiger driver is necessary or if the Panther driver still works.)

Two final notes about the Brother driver. It uses CUPS 1.1, but the print dialog still shows v1.0.0 (whether using the 10.3 or 10.4 installer). I've also noticed that when printing gets goofy (failure to print), it's always a permissions issue, so be prepared to repair permissions instead of looking for other reasons.
  Post a comment  •  Comments (0)  
  • Currently 3.33 / 5
  You rated: 1 / 5 (6 votes cast)
 
[7,110 views] Email Article To a Friend View Printable Version
10.4: Find Address Book names by initials in Spotlight System 10.4
Tiger only hintI haven't seen this hint elsewhere; there is something similar in Mail, but not exactly. If you type in someone's initials in Spotlight, it will return their contact info.

[robg adds: This works, but it's not necessarily the most efficient way to find a contact (I prefer using Butler to do so by typing part of their name). In my case, there are 125,649 matches for 'rg' on my machine, only one of which is my contact card ... and it took quite a few seconds before the Address Book entry showed up in the results list.]
  Post a comment  •  Comments (4)  
  • Currently 2.00 / 5
  You rated: 2 / 5 (3 votes cast)
 
[8,651 views] Email Article To a Friend View Printable Version
10.4: Upgrade Diskwarrior 3 to repair 10.4 disks System 10.4
Tiger only hintThis morning I booted from my original Diskwarrior 3 CD. Immediatly after the directory rebuild began, a window popped up saying the directory was damaged beyond the ability of Diskwarrior to repair. I ran Apple's Disk Utility and it found no problems. I downloaded the 3.0.3 update from Alsoft, burned a new disk (which took seemingly forever!), and the update worked fine, no problems.
  Post a comment  •  Comments (8)  
  • Currently 1.00 / 5
  You rated: 1 / 5 (3 votes cast)
 
[11,884 views] Email Article To a Friend View Printable Version