Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.4: An AppleScript to do a 'find by name' search System 10.4
Tiger only hintIf you're like me, you love Spotlight, but can't imagine what Apple was thinking when they chose to provide Kind and Last Opened as unchangeable default criteria in every new Finder search window. Most of the time, I want to search by file name only, or I get many more hits than I need.

The following AppleScript opens a new Find window and changes the search criteria to Name, and then puts the cursor in the name field. To set it up, launch the AppleScript Utility in /Applications/Applescript, and check both 'Enable GUI Scripting' and 'Show Script Menu in menu bar.' You can set 'Show Library Scripts' to your preference.

Then paste the AppleScript code below into Script Editor, and save it as a new compiled script called "Find By Name." If you want all users on the system to be able to use the script, put it into into /Library/Scripts. If you want it to be available to your user only, put it in the Scripts folder (which you may need to create) in the Library Folder of your home folder. Then, whenever you want to Find By Name, just choose the script from the Script Menu, which is among the icons on the right side of your menu bar.
read more (283 words)   Post a comment  •  Comments (9)  
  • Currently 2.25 / 5
  You rated: 3 / 5 (4 votes cast)
 
[18,221 views] Email Article To a Friend View Printable Version
Another way to control CPU napping System 10.4
The hint titled Possibly eliminate 'chirping' sounds from G5 CPUs describes the use of CHUD to disable CPU napping, in an attempt to suppress 'chirping' sounds when the system is idle. One drawback to this method is that it's not persistent, requiring an AppleScript startup item to turn off the CPU nap flag.

Apple recently released a new version of the CHUD Tools (described near the bottom of the page; or just download from the CHUD FTP server), which provides a command-line tool called hwprefs that, among other things, allows the root user to enable or disable CPU napping.

I won't enter a debate as to whether it's better to create a StartupItem or add a line toward the end of /etc/rc to handle this, (or enter a debate as to whether or not it's a good idea to disable napping in general), but using this command...
hwprefs -v cpu_nap=false
...in either a StartupItem or /etc/rc will disable CPU napping at startup.
  Post a comment  •  Comments (14)  
  • Currently 3.00 / 5
  You rated: 3 / 5 (4 votes cast)
 
[14,930 views] Email Article To a Friend View Printable Version
10.4: Make the Dictionary safer and easier to use System 10.4
Tiger only hintWe all know the Dictionary pop-up built into Tiger is excellent. I use it throughout the day, whether to define a word while browsing the web, or to find a synonym in the Thesaurus while writing an email -- which brings me to the cause of this hint. Why did Apple make the keyboard shortcut for accessing the Dictionary (Control-Command-D) so similar to the keyboard shortcut for sending an email in Mail (Shift-Command-D)? After the second time I sent an unfinished (and unedited, i.e. potentially embarrassing) email, I had the idea that changing the keyboard shortcut might be a good idea.

Just go to the Keyboard & Mouse System Preferences panel, and click on the Keyboard Shortcuts tab. Scroll down until you see "Look up in Dictionary," and double-click the existing shortcut for that command. Change the shortcut to something you prefer; I happened to pick F7. Now when I need to look up a word, it's just a quick tap of the F7 key away.

There's an unexpected bonus to this change, too. Previously, if you wanted to look up multiple words with the pop-up panel, you'd press and hold Control and Command, then hit D, then move the mouse around (while still holding Control and Command). With this reassignment, there's no need to hold the key down, which makes looking up multiple words easy. F7 seems to toggle "look up mode' on, and then hit F7 again to toggle the Dictionary off when you're done.

[robg adds: I wouldn't normally run a 'redefine a keyboard shortcut' hint, as it's somewhat generic. But the change in behavior when looking up multiple words was worth noting. I thought that I'd still have to hold F7 down to remain in lookup mode, but nope, it's a toggle key now. This is a big timesaver -- I love being able to just pop into a lookup mode, and then back out again. Easier on the fingers, and much faster, too!]
  Post a comment  •  Comments (34)  
  • Currently 3.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[17,585 views] Email Article To a Friend View Printable Version
10.4: Remove arrows from aliases System 10.4
Tiger only hintI dislike the Windows-like arrows in the lower left corner of alias icons. Ever since Panther came out, I'd been using the technique described in this hint to get rid of them. When the 10.4.3 Update restored the pesky arrows, I had a little trouble locating the tip, because it is categorized for 10.3, and updated information for Tiger users is only presented at the end of the comments. Hence, this 10.4-only version summarizes (and slightly elaborates on) the Tiger-specific instructions from the original submission.

This procedure, which renames the arrow-image file (AliasBadgeIcon.icns) so that the System won't find it, affects all users and accounts and requires administrator privileges. Open Terminal and type:
cd /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources
Press Return and then type:
sudo mv AliasBadgeIcon.icns AliasBadgeIcon_off.icns
Press Return again, type your administrator's password at the prompt, and you're done. The arrows will be gone after your next restart.

To undo this, repeat the steps above, but swap the positions of the filenames on the second command line:
sudo mv AliasBadgeIcon_off.icns AliasBadgeIcon.icns
All thanks and credit to the original posters who figured this out.
  Post a comment  •  Comments (7)  
  • Currently 3.25 / 5
  You rated: 5 / 5 (8 votes cast)
 
[28,378 views] Email Article To a Friend View Printable Version
10.4: Eliminate excess fan noise under 10.4.3 on G5s System 10.4
Tiger only hintAfter installing 10.4.3, I was dismayed to find that it had sent my G5 (a first-generation Dual 2.0GHz model) into the land of eternally cycling fans. Every few minutes, for seemingly no reason at all, the fan noise would ramp to near-max for a few seconds, then spool back down to idle. Watching with top, there was seemingly no cause for this activity -- no process was sucking up the CPUs, and everything looked completely normal. Needless to say, this was extremely irritating -- if you've ever heard a G5's fans at maximum speed, you know how loud they can be. It was so annoying I was contemplating downgrading to 10.4.2, just to get things back to a quieter noise level.

I tried the basics -- a simple restart, a SMU reset, and a PRAM/NVRAM reset. None did the trick. Then a friend pointed me to another possible solution he found at MacFixIt, involving (of all things) the Energy Saver preferences.

Open the Energy Saver System Preferences panel, and click the Options tab. Click the Processor Performance pop-up menu, and set it to either Highest or Lowest -- anything other than Automatic. Close the panel, and you're done. Not wanting to give up any performance, I set mine to Highest. I made this change on Friday afternoon, and since then, the fans have returned to their pre-upgrade behavior. They now only get slightly louder when I do something CPU intensive, and are at the same nice-and-quiet level the rest of the time.

Also see this hint for a possible solution if you have other noises in your G5 that you can't seem to explain or silence...
  Post a comment  •  Comments (20)  
  • Currently 3.33 / 5
  You rated: 2 / 5 (9 votes cast)
 
[71,096 views] Email Article To a Friend View Printable Version
10.4: Enable 'Open With for all' to work for certain apps System 10.4
Tiger only hintFellow Macworld employee Jonathan Seff pointed me to the following problem/fix; I haven't experienced it myself, so I can't vouch for the solution at all, though it worked for Jonathan. I thought it was worth sharing, so here it is. Have you ever had the problem where you can't make every file of a certain type open with a particular application? That is, the file type currently opens with the 'wrong' app, so you use Get Info on a file of that type, and change the Open With app setting to the preferred application and click on Change All, only to see the Open With value snap back to the previous app. To those who've been affected, it's quite frustrating. (Note that his wasn't an issue under 10.3, it seems; just in 10.4.) As covered in great detail in this thread on Apple's Discussions board, it seems this isn't Apple's fault. Instead, it appears to be the fault of application you're trying to assign. I'll try to summarize what's in the discussion, but it's worth a visit to the original for additional details if you're having this issue...
read more (270 words)   Post a comment  •  Comments (20)  
  • Currently 3.00 / 5
  You rated: 5 / 5 (5 votes cast)
 
[17,353 views] Email Article To a Friend View Printable Version
10.4: Fix a post-10.4.3-update SystemUIServer crash System 10.4
Tiger only hintWhen I updated to 10.4.3 last night, I rebooted and my Antenna, Volume, Input Menu, and Account Menu wouldn't come up in the upper right hand corner of the screen in the menu bar. I checked out the Activity Monitor and the SystemUIServer process was just hanging there -- it was highlighted in red, indicating that the process had stalled.

In the past, I had tried to disable the spotlight menu by renaming the Search.bundle file in /System -> Library -> CoreServices to Search_SAFE.bundle, as suggested in this hint. When I updated the OS, it installed a new Search.bundle, which was apparently causing the hang-up.

To fix the problem, just trash the new Search.bundle (or rename it), and restart the SystemUIServer.
  Post a comment  •  Comments (7)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[14,320 views] Email Article To a Friend View Printable Version
10.4: Add Canon EOS350D RAW support to 10.4.3 System 10.4
Tiger only hintI've been annoyed with the lack of RAW support for the Canon EOS 350D for a long time, and had high hopes that 10.4.3 would fix this, as it seemed to be the OS version that Aperture was waiting for. However, I was dismayed to find that 10.4.3 still hasn't gotten it right. After some prodding, I went and delved into the update's .pax file, and found an interesting file called Raw.plist, which has a list of all the RAW formats that the system supports.

To my astonishment, there is already support for the Canon EOS Digital Rebel XT, which is simply the US name for the 350D: looking closely at the statements showed that it was likely to be the ASCII string that the RAW importer was searching for, so after a quick strings on one of my RAW, files I simply copied the XT section and renamed the initial key to Canon-EOS 350D DIGITAL, and now both iPhoto and Preview understand my files. I've no idea if this was actually in an earlier 10.4 release (my guess is that not long after the 20D was added, the XT support would have gone in.

So if you want EOS 350D RAW support, here's what to do. Add this chunk of XML to the file Raw.plist, which is found in this directory (formatted for copy-and-paste into the Terminal):
/System/Library/Frameworks/ApplicationServices.framework/\
Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources
You will need Administrator rights to alter this file, of course.

[robg adds: I haven't tested this one, and I would recommend backing up the file before you start editing it.]
  Post a comment  •  Comments (14)  
  • Currently 2.60 / 5
  You rated: 2 / 5 (5 votes cast)
 
[29,755 views] Email Article To a Friend View Printable Version
10.4: OS X 10.4.3 update released System 10.4
Tiger only hintLong ago, when the site was but a young thing, I used to regularly cover the minor OS X releases. I haven't done that for quite a while, but I felt yesterday's release of the 10.4.3 update merited at least some mention here--it's the largest system update (in terms of number of changes, at over 500) Apple has ever released, and they snuck in some relatively interesting new features. There are also probably some new glitches introduced, though I've only run into one area of confusion so far (covered in a separate hint today).

So I thought I'd at least list a few of the minor things that I've discovered so far, none of which would really be 'hint-worthy' on their own merits.
  • If you use Mail, you can now set your own font family and size for the mailbox list. My message list and mailbox list are finally in the same font!
  • Also in Mail, when you forward or reply to a message, they got rid of some of the extra blank lines (though they left the one at the top, above the quoted text)
  • iChat now has an encrypted chat feature, as long as all participants are on .Mac. Yes, this is a ploy to sell more .Mac subscriptions, but in this case, I think it's a legit need -- Apple is using .Mac as the issuing authority for the security certificates, and each .Mac subscriber gets one automatically when they first run iChat in 10.4.3. I tested this with a couple .Mac buddies, and it seems to work well. There's a slight lag when sending and receiving messages, but it's hardly notable. File transfers go somewhat slower, and I did have problems sending pasted images -- sometimes they worked, sometimes they didn't.
  • iChat smileys can be disabled easily from the menu! Hooray! Just choose View: Hide Smileys. No more unintended smiles when trying to send lists, etc.
  • X11 windows now pop forward as they should when you activate X11 via the Dock or Command-Tab switcher.
  • Quartz 2D Extreme has been permanently disabled, meaning that these hints no longer work in 10.4.3. Apple claims there were kernel panic and window redraw issues with it, and that the feature is 'not supported' in Tiger.
Most of the above are documented on Apple's About the 10.4.3 Update page; the ones I chose to list were just those I found most interesting or useful to me. Overall, for the size of the update, I've been quite happy with it -- no major glitches (other than the one documented as a separate hint), and the improvements are quite welcomed. Please feel free to comment on your experiences with the update...
  Post a comment  •  Comments (51)  
  • Currently 2.40 / 5
  You rated: 1 / 5 (5 votes cast)
 
[31,264 views] Email Article To a Friend View Printable Version
10.4: 10.4.3 update may break Automator workflows System 10.4
Tiger only hintIf you have Automator scripts that combine Finder actions with shell scripts, you may have some problems with 10.4.3. In particular, it appears that the 'Get Selected Finder Items' action has changed its behavior under 10.4.3, and not for the better. I've also come up with a bit of a kludge solution for the problem, but at least it works.

In a nutshell, the problem is that the path returned by Get Selected Finder Items isn't usable by the Run Shell Script action. So if you have a script that first gets the selected Finder items, and then tries to run a shell script on the selection, it will fail. I ran into this with my Autmator action for this hint, which worked fine in 10.4.2, but broke in 10.4.3. Read on to see what I've figured out thus far, along with my hacky solution.
read more (330 words)   Post a comment  •  Comments (8)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[12,194 views] Email Article To a Friend View Printable Version