Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.4: A USB Printing tip for Intel-based Macs System 10.4
Tiger only hintI have been wondering if Rosetta will work with PowerPC print drivers and found the following tip on the osx86project wiki page:
OSx86 has universal binaries for all its pre-installed printer drivers. However, if your model doesn't have a pre-installed driver, you might be in a bit of a sticky situation. The problem is, even if you download your printers driver, it won't be listed in the driver list! That's because chances are the newly added driver is in PowerPC architecture. To fix this, right click "Printer Setup Utility" in Utilities, select "Get Info" and click "Open using Rosetta." Now, when you restart the setup utility, it will load PowerPC drivers in the driver list, and your newly added printer driver should now be visibly listed! Enjoy! - By Takuro
For HP printers, follow above and just pick any HP printer even if yours is not listed. All of them use the same driver. HP has a unified deskjet driver for Linux, BSD and OS/2 so it is reasonable to try this with any HP deskjet. Specifically tried and worked with HP PSC 1610.
I have not tried this solution, as my new Intel Mac is still on order.

[robg adds: I believe this is the first Intel Mac tip in the system. I don't yet have an Intel box on order, so I obviously haven't tested this one yet, either!]
  Post a comment  •  Comments (8)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[15,651 views] Email Article To a Friend View Printable Version
10.4: Fix the Business widget's Address Book feature System 10.4
Tiger only hintBusiness widgetThe OS X 10.4.4 update breaks the Business widget, a.k.a. the Yellow Pages search widget that's included with Tiger. Specifically, the little plus sign that should appear next to each search result, as seen at right, is missing. When you click the plus sign, you're asked if you'd like to add the selected entry to your Address Book, which is quite useful.

The bad news is that a few key files are missing from the Business widget's package contents. The good news is that you can copy these same files from the "People" widget's package contents.

First, quit the People and Business widgets if they're running. Then in the Finder, simply navigate to the People widget in /Library/Widgets, control-click on it and choose Show Package Contents from the pop-up menu. Open the Images folder, and copy these files (hit Command-C with all of them selected):
  • add_onclick.png
  • add_onmouseover.png
  • add.png
Then navigate to the Business widget in the same /Library/Widgets directory, control-click and choose Show Package Contents, open the Image folder, and paste (Command-V) the files.

Voila! When you open the Business widget the next time, you'll find that the plus sign is back, making it easy to once again add found businesses to your Address Book.

[robg adds: I confirmed this problem on two separate machines. I tested this solution by making a copy of the Business widget in my user's Library/Widgets folder, and then modifying the copy. This way, the original wasn't modified -- just in case something went wrong (even though this is a very simple fix).]
  Post a comment  •  Comments (8)  
  • Currently 3.20 / 5
  You rated: 5 / 5 (5 votes cast)
 
[10,741 views] Email Article To a Friend View Printable Version
10.4: Recover missing menubar icons in 10.4.4 System 10.4
Tiger only hintAfter upgrading to 10.4.4, my menu bar icons (clock, volume, displays, etc.) disappeared.

It turns out that if you have disabled Spotlight, when the updater replaces Search.bundle (located in System -> Library -> Core Services), it causes SystemUIServer (which controls the menu bar, among other things) to crash.

To fix the problem and get your menu bar icons back, just delete Search.bundle and restart.

[robg adds: We've noted similar issues when upgrading modified systems in the past, and it speaks strongly to the need to upgrade a 'standard' system. In my case, I have a simple note in Stickies listing the handful of non-standard things I've done to my machine. I also have a folder containing the original versions of modified files, and I put everything back to normal before upgrading.

I then reboot on the 'restored' machine, so that the original system is once again active prior to the upgrade. It's a bit of work, but I've never had an issue with a system update...]
  Post a comment  •  Comments (10)  
  • Currently 3.00 / 5
  You rated: 4 / 5 (4 votes cast)
 
[22,891 views] Email Article To a Friend View Printable Version
10.4: Fix full-speed fan issue with 10.4.4 on iMac G5s System 10.4
Tiger only hintI ran the 10.4.4 update, and my fans then went flat out. Sounded like 1800nm of thrust out the rear of my machine. Several reboots did not fix the problem. So, irst I played with pmset, and as advised in another hint here, the processor performance settings (set to highest) in the Options section of the Energy Saver System Preferences panel.

Still nothing. Another hint suggested that you zap the pram. So, I did the Command-Alt-P-R, and waited through three "Booooong!" noises. Still my fans went nuts. Then I booted a 'Linux Live' CD, and the fans were normal. Back to OS X, and it was fans-flat-out again. Okay, I then:
  1. Unplugged my machine to move it closer to the phone to call Apple support.
  2. Threatened it with advice from an annoying call centre.
  3. Booted it up.
It then worked fine. I suspect it was the unplugging that reset whatever was causing it grief. A couple of people on a European chat server had the same problem. Unplugging their machines then starting them up once it was plugged in again gave the same solution. Weird.
  Post a comment  •  Comments (13)  
  • Currently 3.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[20,427 views] Email Article To a Friend View Printable Version
10.4: Use Orange Micro SCSI adapters with 10.4.4 System 10.4
Tiger only hintIf you have an Orange Micro Grappler SCSI adapter that went dead when you upgraded to Tiger, and you can't find a firmware update anywhere, you can download and install one of the Advantsys drivers (1.2MB download). Find the drivers in the 'Mac OS X Drivers' folder after the archive expands.

I used the Asc3050 driver, and it worked fine with my Orange Micro 906F; your mileage will certainly vary. Hooray, my scanner works again!
  Post a comment  •  Comments (3)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[9,117 views] Email Article To a Friend View Printable Version
10.4: Repair PHP/MySQL connections in 10.4.4 System 10.4
Tiger only hintAfter updating to Mac OS X 10.4.4, you may find that the connection between PHP and MySQL running on your local webserver is broken.

Apparently the socket file got moved in the update. You can make it start working again by entering the following commands in a Terminal window:
$ sudo mkdir /var/mysql
$ sudo ln -s /tmp/mysql.sock /var/mysql/mysql.sock
[robg adds: I haven't yet update my PowerBook to 10.4.4 (since I'm using it at Expo for presentations and it's working well, I decided the 'let sleeping dogs lie' rule should be followed), so I can't confirm this one.]
  Post a comment  •  Comments (25)  
  • Currently 2.67 / 5
  You rated: 3 / 5 (6 votes cast)
 
[60,697 views] Email Article To a Friend View Printable Version
10.4: Hide frontmost application using Mighty Mouse System 10.4
Tiger only hintUsing Mighty Mouse (requires 10.4.2), you can set any of the actions to open a file, script, application, etc. So I set about making the squeeze action hide the frontmost application.

The AppleScript for this is fairly simple (though, like any AppleScript, I needed to start from similar code online).
tell application "System Events"
  set app_name to name of the second process whose frontmost is true
  set visible of process app_name to false
end tell
(In case you're curious, the reason why I use the second process is because that when the script is running, the first process is the script itself.)

Save the script as an 'application bundle' in ~/Library > Scripts. Open the application bundle that was created and open the Info.plist file in Property List Editor (Developer Tools required). Add an element LSUIElement with a string value of 1. This means that when we run the script, it won't pop up in the Dock.

Now open System Preferences > Keyboard & Mouse > Mouse, and set the squeeze action to Other... and navigate to the application bundle you just created.

Alternatively, you can just download the completed application from my website.
  Post a comment  •  Comments (7)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[11,841 views] Email Article To a Friend View Printable Version
10.4: Hide certain Mail mailboxes from Spotlight System 10.4
I don't know about you, but I quite like to keep all my old email archived, rather than just trashing it. However, since most of it is Paypal receipts and forum-joining notifications, having these messages pop-up whenever I search for mail using Spotlight (whether it be via Command-Space or using Mail.app's own search box) can be very annoying.

To hide a mailox from Spotlight (and ergo Mail.app's own search), simply go to the Spotlight panel in System Preferences, click on the Privacy tab, and add a folder. Then navigate to your user's Library -> Mail -> Mailboxes folder, and select the mailbox you want hidden (/Archive in my case) and you're done.

I know, this is a simple hint, but not everyone might have thought of it.
  Post a comment  •  Comments (5)  
  • Currently 3.00 / 5
  You rated: 5 / 5 (2 votes cast)
 
[10,002 views] Email Article To a Friend View Printable Version
10.4: Use an IOGear Serial to USB converter cable System 10.4
Tiger only hintThe IOGear GUC232A USB to Serial/PDA converter cable, which can be found at most larger Walmarts, uses Prolific Technology's PL-2303H/X/HX chipset for USB to Serial (RS232) communication. It appears the ATEN UC232A and the IOGear GUC232A are the same product. So these instructions should work for the ATEN UC232A, too, but have not been tested.

The drivers that come with the GUC232A did not work for me. Use the following instructions if you cannot get your GUC232A to work.
read more (260 words)   Post a comment  •  Comments (18)  
  • Currently 2.83 / 5
  You rated: 4 / 5 (6 votes cast)
 
[70,980 views] Email Article To a Friend View Printable Version
10.4: Avoid a fast user switching color profile bug System 10.4
Tiger only hintThere is a nasty bug in Tiger related to custom color profiles. Specifically, when you have a custom profile assigned to your display and use fast user switching, the profile will get reset and a "Generic RGB Profile" assigned instead. As a result, the display looks blindingly bright, colors get shifted, and it's practically impossible to work with the computer after that. Display settings don't work either -- when you try to return the old profile, the system just beeps and doesn't do anything. If you press the Calibrate button, it will return an error about a lost profile and exit. A reboot, however, will return everything to normal -- at least until you use fast user switching again.

This bug is old -- it's been known since 10.4.1 at least. It doesn't look like Apple cares to fix it at all in the short term, even though it's 100% reproducible and a lot of people are reporting it on different forums. Because of this bug, I stopped using fast user switching at all. Howevever, I recently absolutely needed the feature, so I started to dig deeper and after some investigation, I found that an application named "DMProxy" is the culprit.

I have no idea what this thing does, but it's obviously related to the CoreGraphics framework, as it resides here: /System -> Library -> Frameworks -> ApplicationServices.framework -> Versions -> A -> Frameworks -> CoreGraphics.framework -> Versions -> A -> Resources.

To make a long story short, just launch DMProxy from the Terminal without any parameters when you get "the blinding screen of death," and everything immediately returns to normal. Probably the simplest way to call it is just to drag-and-drop it to each of your accounts' Login Items (in System Preferences: Accounts, Login Items tab), and it will be called automatically every time when you log in. It will fix the problem completely -- the display profiles panel will work again, and the Calibrate button will call the built in display calibration utility. So far no side effects noted, but if you find something, let us know here!

[robg adds: I can't duplicate this problem on my PowerBook; switching between two users, both of whom have distinct color profiles, didn't cause the problem to occur. I'm posting the hint, though, as I have seen it reported in a number of places, so it does seem somewhat widespread. Please comment if you can provide additional details...]
  Post a comment  •  Comments (56)  
  • Currently 3.17 / 5
  You rated: 3 / 5 (6 votes cast)
 
[63,575 views] Email Article To a Friend View Printable Version