Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Unlock a Mac stuck at the 'Master Password' login screen System
This is a non-rebooting workaround for the situation where your login screen gets locked up because you mis-entered your login password three times while trying to log into an account on a Mac that has set a master password for FileVault (it does not matter if the account uses FileVault or not). The login box displays the error 'Type the master password to reset this user's password and to unlock FileVault. Master Password hint: ...', with no ability to log in as the correct user with the correct password, or to log in as another user or back out of the FileVault password.

Requirements:
  1. ssh enabled on the locked-up Mac.
  2. Administrator user name and password known for the locked-out computer.
  3. Both computers on the network.
Read on for the how-to...
read more (293 words)   Post a comment  •  Comments (3)  
  • Currently 1.83 / 5
  You rated: 4 / 5 (6 votes cast)
 
[66,390 views]  View Printable Version
Create double-clickable movie bundles System
Someone noted earlier that Apple DVD Player now accepts ripped VIDEO_TS folders. But you have to drag the folder to the application to play the movie. You can't just double-click it, because that would only show the contents of the folder in the Finder.

Solution: Display the folder containing the VIDEO_TS folder (the one you probably named after the movie title). Click on the name to change it, and add .bundle to the end. The movie is now displayed as a generic bundle file. Press Command-I, then Open With, Other, and select Apple DVD Player -- uncheck the 'recommended applications' option to be able to select it). Finally, select Always Open With this Application, and click Add.

Now if you double-click this bundle, Apple DVD player will launch and play the movie. You can, of course, choose to hide the extension, and paste a movie frame onto the icon (both in the Finder's Get Info window). The only problem: it does not work with Front Row. Front Row does recognize ripped folders, but not bundles. So the bundled movies will not show up in the Front Row menu.

[robg adds: Queue user fds notes that you should probably use the .dvdmedia extension instead of .bundle. This will automatically associate the folder with DVD Player, and add a nice DVD icon as well.]
  Post a comment  •  Comments (7)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[15,473 views]  View Printable Version
Completely disable trackpad touches while typing System
Have you been frustrated with how the slightest touch on the trackpad causes the text cursor to jump to a different line when you're typing away, especially when you're in mid-thought and wanted to capture everything? (This only applies, of course, if you've enabled trackpad clicking.) Have you been even more frustrated when the Ignore accidental trackpad input setting within the Keyboard & Mouse preferences still doesn't work 100% of the time?

I've been very frustrated with that, and went looking for a Mac Gem or AppleScript that would allow me to disable the trackpad with a keyboard (similar to the PC laptops that have an extra button near the trackpad). I couldn't find anything out there (yet), but as it turns out, Apple has something built-in that allows you to accomplish something very close. And surprisingly, it's actually very effective.

Just visit the Universal Access System Preferences panel, click on the Mouse & Trackpad tab, and enable the Press the Option key five times to turn Mouse Keys on or off option and the Ignore trackpad when Mouse Keys is on setting. 2br Now, whenever you press the Option key five times, you'll enable Mouse Keys, and at the same time, disable the trackpad! Type away, and have no fear of the cursor jumping around. Then when you're done, and want to use the trackpad again, just press the Option key five more times, and you've got the trackpad back.

The best part is that the enabling of Mouse Keys doesn't take over your arrow keys, so you can still use the keyboard arrows to move the cursor around your document, etc. You can move the mouse using the keyboard, but you'll have to hold down the function (fn) key, and use the "cursor" keys on the number pad. If someone has a single (or combo) keystroke (through AppleScript etc.) to enable/disable the trackpad, I'd love to know about it, too. Thanks!

[robg adds: A decent macro program, such as QuicKeys or Keyboard Maestro should be able to script the pressing of the Option key five times. This older hint includes an AppleScript to disable trackpad clicking, which should also make the problem less troublesome -- the cursor would move, but not the insertion point. The AppleScript could be easily bound to a keystroke.]
  Post a comment  •  Comments (5)  
  • Currently 2.22 / 5
  You rated: 1 / 5 (9 votes cast)
 
[22,608 views]  View Printable Version
Force Spotlight to properly index a FileVault folder System
With FileVault turned on and logged in as that user, Spotlight would not find all file matches in my search. I have two computers that hold sensitive medical information, so FileVault is a necessity if I want to use Macs.

Symptom: Files located in the Documents folder, or any other standard folder that should be getting indexed by Spotlight, are not found in a typical search. It doesn't seem to matter if you search for exact file names or for text inside the documents. I found the error with Word files, but upon further research, it also affected PDFs and GIF files, and probably others.

It seems to occur for files that were created prior to activating FileVault. Modifying files in some way will fix that particular file and allow Spotlight to index and find it. However, doing that to all your files may not make sense. In this case, you should reindex just your FileVault Home folder. Do not reindex the entire drive because this will not fix the error.

I reindexed my FileVault home folder by dragging the Home folder icon into the Privacy box of the Privacy tab of the Spotlight System Preferences panel. Once it shows up in the Privacy box, select it and hit the minus button to remove it. This will trigger the reindexing; once it finishes, Spotlight should have indexed all your files properly and return proper search results. This was tested on a Tiger and Leopard system suffering from the same error and it worked in both cases.

[robg adds: I don't use FileVault, but would be interested in knowing if others have seen this issue as well -- please comment.]
  Post a comment  •  Comments (5)  
  • Currently 2.57 / 5
  You rated: 3 / 5 (7 votes cast)
 
[12,603 views]  View Printable Version
Possible recovery of a corrupted FileVault disk image System
Somehow my FileVault image became corrupted, and I could not login. The following steps helped me get things working again.

First, login as the root user -- you'll need to enable root (Pre-10.5, 10.5). On your hard drive, find this file: /Users » username » username.sparseimage; it might instead be found in /Users » .username %raquo; .username.sparseimage, where username is the short username of the user with the corrupted image.

Make a copy of this fiel for back up purposes, in case something goes wrong. Of course you can try to mount it, repair permissions, etc., but I was not able to do this.

Next, reboot your machine from the DiskWarrior CD. In the DiskWarrior window (in the pop-up list), you should find the user's FileVault image; choose Rebuild on that image. After diagnostics, you should look at report. In my case, it saw all of the folder structure, but no files inside the folders. So I rebooted again, logged in as root, and then ran DataRescue II.

I switched to Expert mode and enabled 'Show Virtual (.dmg files) devices,' then selected my user.sparseimage file. I ran 'ThoroughScan' (Quick Scan gave no results). After quite some time (it takes about three to five minutes per GB), I saw a report showing many found files. I was extremely happy to see all my files (.doc, .xls, pictures, movies, etc). From the list, select files you need then choose Recover, and voila!

As the Data Rescue II is a bit costly, all things (except recovery) can be performed with a demo copy. If you are satisfied with the results in the report, you can then decide to purchase the program.

One more thing: DiskWarrior 4 is not fully compatible with Leopard. If you don't have a DiskWarrior boot disk, run all above steps on a Tiger system (with a copy of the sparseimage). Hope this helps someone!

[robg adds: We also have this older hint with some different things to try.]
  Post a comment  •  Comments (0)  
  • Currently 1.75 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[13,173 views]  View Printable Version
Run other apps from the installer System
I have found that having an installer DVD with me at all times can be very useful. I don't like to actually carry the DVD with me, so I made a 10GB partition on my boot disk (MacBook Pro). I restored the Leopard DVD to this partition. Now all I have to do to boot from the 'Install DVD' is to use the Option key when I boot.

That's not the tip, however; this is. I may want to launch an application other than the ones found in the Utilities menu. Since Terminal is there, I tried to use Terminal to launch (using the open command) other applications. open, however, is not on the Install DVD, but it will still work if used from another partition. For example (assuming system is my regular boot volume):
/Volumes/system/usr/bin/open /Applications/TextEdit.app
But what if the regular boot partition is shot? The answer is to copy the open command from the regular boot partition to the installer partition:
cp /usr/bin/open /Volumes/installer/usr/bin/.
Now I can use the open command from Terminal when booted from the installer partition. When DiskWarrior comes out, and the other commercial disk repair tools, I will copy them into /Volumes/installer/Applications, and be able to launch them when booted from the installer partition. Note that this may work in Tiger, but I haven't tried.
  Post a comment  •  Comments (3)  
  • Currently 1.60 / 5
  You rated: 3 / 5 (5 votes cast)
 
[5,475 views]  View Printable Version
How to capture a screen shot of a screen saver System
The new Mosaic feature screen saver in 10.5 is amazing, and I wanted to have a screen capture of it. Of course, when you try to screen capture, it exits the screen saver. The way around this is to press Command-Shift first, then hit the Test button in the Screen Saver panel of the Destkop & Screen Saver System Preferences panel.

Then wait for the shot you want (still holding Command and Shift), then press 3. For some reason, this doesn't end the screen saver until you let go of Command-Shift, so you can press 3 as many times as you want.

[robg adds: This works in 10.4 and 10.5.]
  Post a comment  •  Comments (8)  
  • Currently 2.75 / 5
  You rated: 4 / 5 (8 votes cast)
 
[11,954 views]  View Printable Version
Install just the keyboard layouts from Logitech's drivers System
Logitech's drivers have been implicated in failures to install Leopard, and certainly as a result of reading about those issues, I have no intention of installing them again on my Leopard systems. (I did a clean install, so the blue screen problem didn't actually hit me.)

However, I can't type on the standard (latest) Apple desktop keyboards, and much prefer my Unicomp buckling-springs one. But Apple's keyboard layouts don't actually match PC keyboards very well. So although I do *have* a Logitech mouse, I was only installing the drivers in order to get at the Logitech keyboard layouts.

You see, the Logitech keyboard and mouse drivers are only necessary to drive the special function keys that festoon Logitech equipment; but just to get the normal typing keys mapped correctly, you only need the basic layouts. It turns out you can just install those keyboard layouts, and quite easily.

If you're comfortable in Terminal, this single command will do everything you need to do in one shot (assuming you've downloaded the drivers):
unzip -j ~/Downloads/lcc231.zip '*LCCKCHR.rsrc' -d '~/Library/Keyboard Layouts'
For the command-line averse, keep reading for a much longer way of doing it through the Finder -- but one that doesn't require Terminal at all. By the way, this hint will work just fine on earlier versions of Mac OS X; it's just that on Leopard it's necessary to avoid installing the Logitech software; at least until Logitech updates their driver software for 10.5.

For an alternative that only caters for UK English users (like myself), you can go here and install the UK keyboard layouts supplied there. That's the posting that gave me enough clues to do the above with the Logitech layouts. As a result, I've not actually tried the UK English layouts on that posting, but if they work for you, that would be even simpler.
read more (145 words)   Post a comment  •  Comments (4)  
  • Currently 2.60 / 5
  You rated: 4 / 5 (5 votes cast)
 
[22,619 views]  View Printable Version
A table of special Apple symbols and their values System
Below is a table of symbols used in OS X menus to represent special and modifier keys; read on for how to create them in OS X, and for use in HTML and Javascript.

SymbolNameHexDec
Shift21E78679
Control23038963
Option23258997
Command23188984
Delete Right23268998
Delete Left232B9003
Escape238B9099
Eject23CF9167
Return21A98167
Left Arrow21908592
Up Arrow21918593
Right Arrow21928594
Down Arrow21938595
Page Up21DE8670
Page Down21DF8671
Home21968598
End21988600
Tab21E58677
NumLock21ED8685
Clear23278999
Enter23058965
Apple SymbolF8FF63743

Note that some of the glyphs may not render on other platforms if a Unicode font is not installed, but they should work on any Mac.
read more (141 words)   Post a comment  •  Comments (8)  
  • Currently 3.44 / 5
  You rated: 4 / 5 (9 votes cast)
 
[48,061 views]  View Printable Version
How to find and remove the OSX.RSPlug.A malware System
As reported in many places, including Macworld, there's a new OS X malware in the wild, first reported by Intego, who named it OSX.RSPlug.A (where do they get these names?).

I spent some time this morning looking at this malware, and wrote this article explaining how to find out if you've been infected, and how to remove the programs if you have. If you want all the details, you can read the article. If you just want to know how to remove the malware, here's the simple process:
  1. In the Finder, navigate to /Library -> Internet Plug-Ins, and delete the file named plugins.settings. Empty the trash. This deletes the tool that sets the rogue DNS Server information.
  2. In Terminal, type sudo crontab -r and provide your admin password when asked. This deletes the root cron job that checks the DNS Server settings. You can prove it worked by typing sudo crontab -l; you should see the message crontab: no crontab for root.
  3. Open your Network System Preferences panel, go to the DNS Server box, and copy the entries you can see to a Stickies note, TextEdit document, or memorize them. Now retype those same values in the box, then click Apply.
  4. Reboot your Mac.
The only people who should be infected today are those who have broken the number one rule of internet computing: don't download and install programs (especially those that are (a) package installers that (b) request your admin password) from untrusted sources. However, because this particular trick could be used on any sort of potentially popular site, I thought I'd share the simple how-to, as well as the links above for more details.

As OS X grows in popularity, I expect that this type of thing will become more commonplace.
  Post a comment  •  Comments (16)  
  • Currently 3.29 / 5
  You rated: 5 / 5 (7 votes cast)
 
[54,830 views]  View Printable Version