Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Printing to unsupported printers System
'Anonymous' contributed this tip...I haven't been able to test it, as my printer is connected via a USB-to-serial connector which doesn't work in Classic, of course.


"I found a nifty way to print to my supposedly "Unsupported Printer," in OS X native applications. Just press preview to save the printer output to PDF and open the PDF with a Classic application like Acrobat Reader. You can then just print as you usually would in Classic (assuming you have loaded classic with all your old printer driver extensions).

This seems to work for my Epson Photo 750 although it may not work for others."
  Post a comment  •  Comments (7)  
  • Currently 2.57 / 5
  You rated: 4 / 5 (7 votes cast)
 
[4,339 views] Email Article To a Friend View Printable Version
Applications folder ownership problem and fix System
My 'Applications' folder has a strange owner. It's simply owned by "", with no name. Every time I try to add an application (by just dragging it to the window) I get this error:

The item "pepper -3.6" could not be moved because "Applications" cannot be modified.

I can get around this by logging in as root and moving files using the command line, but I don't get who this owner "" is, and why it;s there. Any suggestions??

Thank you, Alex Colomb.
  Post a comment  •  Comments (1)  
  • Currently 1.50 / 5
  You rated: 2 / 5 (6 votes cast)
 
[7,222 views] Email Article To a Friend View Printable Version
What to do about a deleted root account System
I installed the final release of OS X today. I set up my account just as I did with the public beta, except when I am in terminal at the command line, and I try to become superuser, it doesn't let me. It says "sorry" and that is the end of it.

I tried changing the root password in the NetInfo Manager app, but that was unsuccessful. So I deleted the root account! Now I can't do anything with netinfo manager and I can't "su" at the command line, as it says, "su: unknown login root."

What can I do without wiping out my disk and starting from scratch? Is there a way to create a new root user?

Any help would be appreciated.
  Post a comment  •  Comments (8)  
  • Currently 2.00 / 5
  You rated: 3 / 5 (7 votes cast)
 
[6,601 views] Email Article To a Friend View Printable Version
ColorSync profiles won't transfer from OS 9 System
In OS 9, I used a ColorSync profile that made my screen look wonderful, but it won't work in OS X. It doesn't show up as a choice in the Monitor control panel as a display profile (in the Color tab). I've tried calibrating my monitor, but I can't get results that are as good as they were with this profile. If anyone could help me get this to work, I'd really appreciate it.

[Later that same day...] Well, I figured out my problem. Apparently, over the months that I've had the profile, it was corrupted through many moves and copies. So I just downloaded it again from xlr8yourmac, and it worked.

So if you're having trouble moving a ColorSync profile from OS 9 to OS X, make sure your profile hasn't become corrupted somehow; start with a fresh copy if you can.
  Post a comment  •  Comments (1)  
  • Currently 2.29 / 5
  You rated: 4 / 5 (7 votes cast)
 
[3,149 views] Email Article To a Friend View Printable Version
Alternate genie effects System
The "genie effect" is what happens when you click the yellow "minimize" button. You'll see your window get sucked down into the dock, as though it were being drawn into a funnel. While quite cool the first few times, some people (me!) have found it a little annoying after a while. Those with slower machines may also find it something of a CPU hog.

Luckily, Apple included a way to change the genie effect, but chose not to put it into a GUI tool at this time. I'm sure someone will have one written within a week, but for now, here's how you do it. Open a terminal session (the Terminal application is inside Applications/Utilities), and type one of the following:
defaults write com.apple.Dock mineffect genie
defaults write com.apple.Dock mineffect suck
defaults write com.apple.Dock mineffect scale
The "genie" option is normal behavior, "suck" is sort of hard to describe but it's more like a reverse twisted genie, and "scale" (my personal favorite) simply reduces the window equally from all sides while dropping it to the dock. The other nice thing about "scale" is that it's blindingly fast (on my G4/350, while the genie lags a bit), so windows vanish very quickly.

To activate any of these settings, you'll need to logout and login again.
  Post a comment  •  Comments (9)  
  • Currently 3.57 / 5
  You rated: 5 / 5 (7 votes cast)
 
[24,926 views] Email Article To a Friend View Printable Version
In case you've been sleeping... System
... Apple updated their OS X pages today, and they've added a bunch of content and some new system movies. Well worth a visit to their OS X Page if you haven't visited lately. Oh yea, they also mentioned that iTunes and iMovie (apparently it's now free?) would be available for download on Saturday!
  Post a comment  •  Comments (0)  
  • Currently 1.50 / 5
  You rated: 1 / 5 (6 votes cast)
 
[2,311 views] Email Article To a Friend View Printable Version
Changing screen size on a studio display? System
maybe i'm missing something, but is there a tool available in OS X to change the screen size (width and height of image, not resolution) of a studio display with ADC? (that funky apple display connector with power + signal in one)

this monitor (the clear 17" CRT one) has no panel controls, and there's lots of unused space on the tube's screen.

i've used macs in the past, but i'm certainly no hack. i believe this monitor ships with a display software CD which i don't have and might be strictly for 9.x?

any tips would be greatly appreciated.

[Editor's note: From the comments, it appears this has not yet made it into OS X v10.0...]
  Post a comment  •  Comments (2)  
  • Currently 1.83 / 5
  You rated: 2 / 5 (6 votes cast)
 
[2,972 views] Email Article To a Friend View Printable Version
Restarting the GUI remotely System
If your GUI ever locks up completely, and you have access to another machine, you may be able to repair it remotely. Telnet (or SSH) in, open a terminal, and do "ps -aux". Look for loginwindow.app in the list, note the PID number, and then "kill -9" that PID.

This should restart your GUI so you can use your machine again.
  Post a comment  •  Comments (2)  
  • Currently 3.00 / 5
  You rated: 5 / 5 (7 votes cast)
 
[5,896 views] Email Article To a Friend View Printable Version
Force Quit in OSX Beta System
My OSX-beta QuickTime would hang-up upon launching movie trailers on different occasions. I tried the keystrokes command-option-escape out of habit. To my surprise, up popped a panel listng current USER processes. I selected QuickTime then hit RETURN. I was then able to relaunch the movie trailer. Add this one to your 10.0 important-keys list.

DP note: OSX processes don't seem any faster than my old G3/400. Any concurrence here? I'm using a G4/450/DP/15" Flat panel monitor
  Post a comment  •  Comments (0)  
  • Currently 2.00 / 5
  You rated: 3 / 5 (6 votes cast)
 
[3,256 views] Email Article To a Friend View Printable Version
Change the boot disk from the terminal System
[Editor's note: See the comments for a discussion and link for more info on this topic.]

Does anybody know what exactly happens when I change the boot drive using the System Disk utility? Is there any way to make the same changes on the OSX command line?
  Post a comment  •  Comments (4)  
  • Currently 1.71 / 5
  You rated: 2 / 5 (7 votes cast)
 
[8,233 views] Email Article To a Friend View Printable Version