Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Drag and drop text in all Cocoa apps System
Up until tonight, I'd been disappointed with the lack of drag-and-drop support on text selections in Cocoa apps. It seemed I could make it work most of the time in OmniWeb pages (but not in forms), but never in mail.app or Stickies. The OS 9 method, which was to select the text, then click-hold and drag, didn't work. The second click simply moved the insertion point when I started to drag.

Tonight, though, the mystery has been solved! To drag and drop text chunks in any Cocoa app (supposedly; I haven't tested them all!), simply change your behavior slightly. Highlight the text, click and hold the mouse button in the highlighted area for just under a second, then move it around at will! If you've held it long enough, you'll see the text darken slightly to indicate that you're now holding the text in "float" mode.

I kept thinking this was simply another piece of OS X that wasn't quite done yet ... looks like it's done, but the implementation has changed. Thanks to Russ H. on the X4U mailing list for pointing this one out! Stickies and mail are now much more convenient to use!
  Post a comment  •  Comments (0)  
  • Currently 1.80 / 5
  You rated: 3 / 5 (5 votes cast)
 
[3,700 views]  View Printable Version
Shut down your Mac remotely System
If, for some reason (can someone think of one?) you'd like to shut down your Mac from another machine, here's how you do it.
  1. Connect to your Mac remotely via SSH or telnet.
  2. Become root ('su' and enter your root password)
  3. Type sync to clear the buffer (may not be necessary with the next command, but I'm cautious!)
  4. Type halt to shut down the machine.
This will (obviously) end your telnet/SSH connection shortly after you type it ;-).

I just tried this from my PC to my Mac, and it did exactly what it was supposed to do ... my Mac shut down cleanly. No errors of any sort on restart, but I did lose my '3 day, 4:54' uptime! I'm not quite sure why one would want to do this, but it is possible.
  Post a comment  •  Comments (7)  
  • Currently 2.57 / 5
  You rated: 3 / 5 (7 votes cast)
 
[26,292 views]  View Printable Version
Greater customization of finder toolbars System
After some frustration and concern about the small choice of folders that I could have in my finder toolbar, I eventually tried what should have been obvious. Yes, for those of us who hadn't worked this out (and I know I'm not the only one) you can just drag any folder, file or application into the finder toolbar.

You can even use this in a rather tricky manner and remove the home button from the toolbar and then drag your own home folder in, giving the button the (possibly customized) icon of your own home folder. The same goes for many of the other buttons (including using the sherlock app instead of the find button).

Read the rest of this article if you'd like to know more about customizing the customizable toolbar!

read more (133 words)   Post a comment  •  Comments (2)  
  • Currently 3.00 / 5
  You rated: 5 / 5 (5 votes cast)
 
[3,737 views]  View Printable Version
Remove some antialiasing effects System
This is apparently floating around on MacFixit, although I couldn't find it there in the forums or on the main page. The following hack will disable the anti-aliasing effect in some applications. I'm not sure which apps, as I haven't tried this myself yet (I actually like the anti-aliasing).

If you'd like to experiment, here's what you need to do.
  1. Create a folder named '.OpenStep' in your home directory (mkdir ~/.OpenStep).

  2. Create a file called 'environment' containing one line of text:
    QDTEXT_ANTIALIASING=0;QD_MINSIZE=18
    From the terminal, vi ~/.OpenStep/environment and then type the above line. Save the changes and quit. I'm guessing that QD_MINSIZE is the size below which the anti-aliasing is disabled.

  3. Logout and login again, and you should (might?) have less anti-aliasing than you did previously.
If someone tries it, post back with your observations as to where it does and doesn't work.
  Post a comment  •  Comments (4)  
  • Currently 2.57 / 5
  You rated: 1 / 5 (7 votes cast)
 
[3,396 views]  View Printable Version
Special keys on Apple Pro keyboards System
The special keys (volume up, volume down, mute, and eject) work more or less as expected in OS X. The only exception to this is the eject key. It not only ejects any inserted CD, but also all your mounted disk images. With the adoption of disk images as the primary means of OS X software distribution, I probably won't be using my keyboard eject key much more!
  Post a comment  •  Comments (3)  
  • Currently 1.83 / 5
  You rated: 2 / 5 (6 votes cast)
 
[2,541 views]  View Printable Version
Reviving a dead computer after 9.1/X install System
Hope this helps somebody?

(System Config: Performa 6400, G300 L2 Newer Tech upgrad card, 21 gb Hard drive w/10 partitions , 104mb RAM)

I just got my OS X package Today (3/31/01). Inside was OS 9.1 and X. Well, three weeks ago, I downloaded the 9.1 update from the Apple Web site and it installed easily and worked great! Well, as any good Mac user, I figured that Apple had probably included some updates with the CD. So I chose the option on the 9.1 CD to "Re-install" System 9.1. The install went well and everything seemed great! Then I hit the restart button. DIASTER!!!

My computer would not start (it ran, but nothing happened?) My monitor was blank? I could not start up from a CD..nothing? I tried everything...and still a blank screen?

Read the rest to see how George (as signed below) resolved the startup problem, and it's probably a good heads-up for those of you working with upgraded machines.
read more (117 words)   Post a comment  •  Comments (0)  
  • Currently 2.33 / 5
  You rated: 3 / 5 (6 votes cast)
 
[3,039 views]  View Printable Version
Epson printing error (-9671) in OS X System
A reader and I were exchanging emails over the inability of his Epson 740 (a supported printer) to print from OS X on his iMac. He spent quite a bit of time debugging the issue, but was making no progress. He could print fine in OS 9.04 and even Classic, but not in OS X. Every time he tried, the job ended with a "-9671 Error". Others on the web with identical machines and printers were not having the same problem.

After spending many hours on the issue, he finally tracked it down. When he originally bought his printer, the sales rep had also sold him an Epson Parallel to USB converter cable. This appears to have been (see the comments!) what was causing the OS X printing problems. As soon as he replaced it with a straight USB cable, everything worked fine.

So if your Epson won't print, check your cable -- and maybe just plug and unplug it, per the comments below. If that fails, it may be time to try a new cable.
  Post a comment  •  Comments (7)  
  • Currently 2.86 / 5
  You rated: 2 / 5 (7 votes cast)
 
[6,517 views]  View Printable Version
Launch apps from the Get Info dialog box System
The small icon in the Get Info window in OS X is useful as an application launcher, too. If you have an application selected in the Get Info window, a double-click on the icon will launch that app. A double-click on a document icon will launch that document's associated application. Finally, a double-click on a folder icon will open a Finder view of that folder.

As always, you can still single-click and cut-and-paste custom icons.
  Post a comment  •  Comments (1)  
  • Currently 2.00 / 5
  You rated: 1 / 5 (6 votes cast)
 
[2,664 views]  View Printable Version
Set the date and time automatically System
As I noticed my system time slowly drifting away from my WWV radio-clock time, I decided to re-check Date & Time settings and found that time wasn't being set automatically. Here's one way to keep your clock synchronized.

Open the Date & Time control panel, and go to the Network Time tab. Make sure Network Time synchronization is OFF (click the button to stop if necessary). Select MANUALLY, and enter an IP address for a Network Time Server (NTS) into the NTP field. There's a listing of appropriate servers at:

www.boulder.nist.gov/timefreq/service/time-servers.html

I used the actual IP address (instead of the server name) and it worked perfectly.
  Post a comment  •  Comments (7)  
  • Currently 1.33 / 5
  You rated: 1 / 5 (6 votes cast)
 
[21,715 views]  View Printable Version
Edit your shell config file System
If you'd like to change some of your command line login defaults, but don't know where to find the file, it's located here:

/Users/[name]/.tcshrc

[name] should be replaced with your username, of course. If you don't have this file, you can create it from the command line or a GUI editor.
  Post a comment  •  Comments (7)  
  • Currently 2.17 / 5
  You rated: 3 / 5 (6 votes cast)
 
[9,384 views]  View Printable Version