Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

OS X crashes on PB Lombard due to RAM expansion System
If any of you have had problems with OS X crashing a lot (perhaps even during installation) on PowerBook Lombards, you are not alone. Lots of people have had this problem. It appears to be caused by the presence of RAM modules beyond the base 64MB. If you have a RAM upgrade in your top slot, OS X should work fine after you remove it.

It is unclear what is causing this problem, at first people said it was due to tighter memory tolerances, but then reports came in about even apple RAM upgrades causing the crash. Now it seems like it may be a lingering hardware bug that wasn't revealed by previous OS's. You can read lots more about this on the MacFixIt Forums in this thread.

Apple does not have a fix for this yet, in fact they appear to be denying that it is a problem, so I encourage anyone else experiencing this bug to fill out a bug report form.

Patri Friedman (patriNOSPAM@izzy.com)
  Post a comment  •  Comments (2)  
  • Currently 4.00 / 5
  You rated: 5 / 5 (3 votes cast)
 
[3,476 views] Email Article To a Friend View Printable Version
Cocoa "optimizer" application System
I wrote a silly little Cocoa application that will optimize the system in the same fashion that installing the development tools optimizes the system.

http://www.codefab.com/unsupported/Xoptimize_v0.1.dmg
  Post a comment  •  Comments (1)  
  • Currently 3.75 / 5
  You rated: 3 / 5 (4 votes cast)
 
[2,883 views] Email Article To a Friend View Printable Version
Problems with Apple's package installer System
Scott Anguish of Stepwise has written a very good article that discusses some serious problems with Apple's package installer program. It's a bit technical at times, but a couple of key tidbits include:
  • If a package installer encounters a directory that already exists, it will set its permissions and ownership to the permissions of the version in the archive. If the installer maker wasn't very careful with the permissions settings, you may find your Applications folder has new permissions which make it impossible to use (jCalendar originally shipped with such a problem, and the author has now switched to a disk image installer as a result)

  • If you have a symbolic link that points to another directory (if you've moved your Applications directory, for example, and replaced it with a link to the new location), the installer will replace the link with a directory, and any files below that directory will be installed in place. This can also have serious side effects, including disabling your system completely.

  • If the installer package requires your password to launch, then code inside the package that's owned by root will be executed with full root privileges. This makes it very easy for malicious code to damage areas of your system which would normally be protected.
In short, until Apple resolves the problems with the installer maker, you should treat any .pkg file with extreme caution - it could easily disable key portions of your system, and it would be fairly trivial for a malicious hacker to create an installer that does a number of Very Bad Things using root privileges.

This is a tricky situation, as some products (such as mySQL and PHP) seem to require an installer, based on their need to put pieces in a number of locations. In general, avoid the package installers if you can, but if you can't, make sure you (a) have a backup of important data before proceeding, and (b) know and trust the source of the package.
  Post a comment  •  Comments (0)  
  • Currently 3.67 / 5
  You rated: 3 / 5 (3 votes cast)
 
[6,523 views] Email Article To a Friend View Printable Version
Remove extra printer drivers System
If you navigate to /Library/Printers, you'll see folders for Canon, Espon, and HP printers. There's no real need to keep the printer drivers lying around for printers you don't have, so you can remove the extra folders to free up some drive space. Since these folders are owned by root, you'll need superuser status to delete them.

Once you cd /Library/Printers, you can just type sudo rm -r [directory_name], where [directory_name] is one of EPSON, Canon, or hp (do NOT type the square brackets). Note that if you do this, future use of any of the deleted printers will (obviously) require re-installation of the drivers. Use at your own risk, but my Canon and hp driver folders have been gone for weeks with no real problems.
  Post a comment  •  Comments (2)  
  • Currently 4.13 / 5
  You rated: 5 / 5 (8 votes cast)
 
[58,600 views] Email Article To a Friend View Printable Version
Keychain locking out mail.app access System
Rob F. wrote in with an issue a few days ago:
I had been running in OS 9.1 for a couple of days. When I booted back into OSX tonight and started mail, I was asked for my keychain password. I have never opened Keychain but no problem, I thought, and typed my user password. No go. So how do I get around this issue?"
Rob F. later wrote back with the solution ... so if you're locked out of an OS X application due to a keychain you haven't used, read the rest of the article for instructions on how to fix the problem.

Thanks to Rob for submitting the solution, and my apologies for the delays in getting it published!
read more (262 words)   Post a comment  •  Comments (1)  
  • Currently 4.33 / 5
  You rated: 5 / 5 (3 votes cast)
 
[7,778 views] Email Article To a Friend View Printable Version
Moving fonts between OS 9 and Classic 9 System
Today I noticed a bug (feature?) in the manner in which Classic 9 handles fonts added to its system folder. Theoretically, this should work just as it does in OS 9 - drag the font into the Fonts folder, and any non-running application that is then launched will see the new font. In copying over a number of fonts from my 'real' OS 9 to my 'Classic' OS 9 today, I noticed that they weren't seen when I launched my Classic application. After a bit of troubleshooting, I found the answer.

To make the fonts usable, I had to restart Classic, not just the apps running within Classic. Once I restarted Classic, I had all my new fonts available. I can't decide if this is a bug, or a limitation of how Classic works. In either event, install the fonts first, then launch Classic to save yourself a Classic restart (at least, that's how my machine is working!).
  Post a comment  •  Comments (0)  
  • Currently 2.67 / 5
  You rated: 3 / 5 (3 votes cast)
 
[3,177 views] Email Article To a Friend View Printable Version
Transparent windows in any Cocoa program System
Making terminal windows transparent seems to be a popular item, and someone asked if it would work in other apps. Well, it won't work out of the box, but there's a cool little hack that will make it work, at least for Cocoa applications.

This isn't quite perfect, as it will change the transparency of the title bar, scroll bars, etc. as well as the content, but it does make them transparent.

Read the rest of this article for the step by step instructions.

[Editor's note: I have not tried this on my machine yet. You should probably back up any file you are going to modify before you start. Sounds really cool, though!]
read more (372 words)   Post a comment  •  Comments (6)  
  • Currently 2.80 / 5
  You rated: 1 / 5 (5 votes cast)
 
[22,725 views] Email Article To a Friend View Printable Version
How to view other non-European languages System
The default installation of OS X doesn't come with any other non-European language other than Japanese. Well, we all know this by now. However, there is a way to view Korean, Chineses and others by moving the respective fonts from the OS 9 fonts folder (or any other) into the fonts folder in /Library/Fonts [editor: corrected per comments] and voila!

Now go to the International setting in System Preferences in OS X and see your language displayed! Select the language and keyboard you need and now you should be able to view these foreign languages in Mail.app, Web Browsers and others.
  Post a comment  •  Comments (1)  
  • Currently 2.40 / 5
  You rated: 3 / 5 (5 votes cast)
 
[2,946 views] Email Article To a Friend View Printable Version
Single-user mode made easy System
This is a follow-up to the hint about using <Cmd>-S during boot-up to go to single-user mode.

Well, I go to single-user mode to run fsck, the UNIX disk checking tool and I noticed on my Wall Street PB that <Cmd>-s would work sometimes but not consistently.

As an old UNIX geek I was trying different, more reliable ways to get to single-user mode from the Terminal and found this one almost by accident:

1. su to root (or use sudo)
2. Run the command "shutdown now" (without the quotes, of course.)

After a bit of pondering, OS X will quietly and consistently shutdown to single-user mode. A quick 'reboot' and you're back in Aqua.

Man, I love this OS!
  Post a comment  •  Comments (2)  
  • Currently 2.57 / 5
  You rated: 5 / 5 (7 votes cast)
 
[6,765 views] Email Article To a Friend View Printable Version
Myth? Speed up OS X with Dev Tools install System
NOTE: Please see the comments for some objective evidence that the speedup does nothing of the sort, and may actually slow your machine down a bit! The Dev Tools do have some useful utilities on them, and you need them if you want to compile UNIX source code, but don't install them for the sheer sake of a speed boost!

Full credit to MacOS Rumors, they reported that installing the Developer Tools (the third CD in the OS X retail box) made everything faster. I just tried it, and it's definitely true--even IE is zippier.

[Editor's Note: I've read this in a few places, but can't help confirm any speedup. I installed the Dev Tools about three minutes after I installed OS X, so they were in place when I ran my benchmarks. The theory that I've seen elsewhere on the net is that the "Optimizing System" step that happens at the end of the Dev Tools install was supposed to also happen at the end of the OS X install, but a bug stops it from running.

I'm not sure whether I believe it or not, but if you have the free disk space (600mb or so), it can't hurt to try. If you do, though, please time some application launches before and after you install the Dev Tools, and report back with your results. It'd be nice to have some objective evidence to back this theory!]

NOTE: You can run the "optimizing" routine at any time, by starting a terminal and entering:

sudo update_prebinding -root /

This can take quite a while to run, and may (or may not) speed up application launching times. G3-based users have reported speedups; most G4 owners have not seen any changes. Use at your own risk, and you may or may not see any benefit.
  Post a comment  •  Comments (16)  
  • Currently 2.67 / 5
  You rated: 4 / 5 (6 votes cast)
 
[10,359 views] Email Article To a Friend View Printable Version