Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Resolving generic folder issues System
[Editor: Submitted by 'nikon' last week]

If you ever get generic folders in the dock and filesystem, there are three things that normally cause this:
  1. Corrupted prefs.
  2. Corrupted NetInfo database.
  3. No privilieges on home folder.
For a solution to the generic folder problem, read the rest of the article.
read more (199 words)   Post a comment  •  Comments (0)  
  • Currently 4.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[4,545 views] Email Article To a Friend View Printable Version
Solution for CD/DMG mounting problems! System
Eric Poelzl found the solution for those of us that can't mount CDs or DMG files. He has posted it in Apple Discussions. Open NetInfo Manager (in Applications/Utiltiies) and see if there is a Unknown User (click on 'Users' in the Directory Browser area). If not, you have to add it back in. Create a new entry with the following settings:

realname: Unknown User
expire: 0
name: unknown
uid: 99
passwd: *
home: /dev/null
change: 0
shell: /dev/null
gid: 99

Save your changes and you should be able to mount your CD's and DMG files again.

[Editor's note: I have not tried this myself, and be careful working in NetInfo; if you mess something up, you could make your system unusable.]
  Post a comment  •  Comments (7)  
  • Currently 4.00 / 5
  You rated: 4 / 5 (2 votes cast)
 
[12,183 views] Email Article To a Friend View Printable Version
Apple's 10.1 information page System
While I don't try to maintain macosxhints as a news site (there are many others that do it much better than I could ever hope to!), I am posting this one news blurb.

The demo of 10.1 at this morning's MWNY keynote was quite impressive (even if it was on a dual G4/800 ;-). However, there was much about the update that was not announced. If you haven't yet, make sure you check out Apple's Mac OS X New Version information page. There are a number of details there (like not just resizable column view, but individually resizable columns) that are quite interesting.

We have to wait until September to get it, but the good news is that it appears Apple has been listening to its customers.
  Post a comment  •  Comments (1)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[1,843 views] Email Article To a Friend View Printable Version
Debugging help for supported USB printers System
Over on the MacFixIt forums, "Impish" has posted a step-by-step guide explaining how he got his supported printer (an Espon 888) to work in OS X, OS 9, and Classic.

If you're having difficulties with your supposedly supported printer, you should read the thread on MacFixIt for some ideas on ways to solve your problem.
  Post a comment  •  Comments (0)  
  • Currently 5.00 / 5
  You rated: 5 / 5 (3 votes cast)
 
[2,194 views] Email Article To a Friend View Printable Version
Caution - Xmorph security hole... System
There's a big security hole if you're using Xmorph [Editor: a theme-switcher for OS X]. Look in ~/Library/Preferences/Xmorph Preferences. If you've authenticated once, you should be looking right at your admin password. The author insists that this is a "feature." Feature or not, no password should ever be stored in plain text. Another Real Basic app...

[Editor's note: See the comments - this 'hole' is completely optional and at the user's discretion. Seems like a reasonable balance of ease-of-use and security - you choose whether or not you'd like your admin password saved in cleartext.]
  Post a comment  •  Comments (3)  
  • Currently 2.33 / 5
  You rated: 4 / 5 (3 votes cast)
 
[2,204 views] Email Article To a Friend View Printable Version
Disconnect users from the terminal System
A question on the Macaddict forums asked how to disconnect other users from an OS X machine using the terminal. One method, courtesy of an experienced UNIX-using friend of mine, is as follows:

1) Type ps aux | grep username, where username is the short name of the user you wish to disconnect.

2) Look for the shell process for the user in question in the 'ps' output. If your users use the standard (tcsh) shell, the process name will be -tcsh (tcsh).

3) Note the process number in the second column. For this example, assume it's 123.

4) Type kill -15 123, where 123 is the actual process number you found in step two. My admittedly poor interpretation of this step is that it attempts to nicely end the processes associated with the user. I'm sure that's not completely correct, but it is the general idea.

5) Type kill -9 123, where 123 is the actual process number from step two. This will end the user's session for certain.

I haven't tried this one myself yet, but I fully expect it will work. Are there other (easier, cleaner?) ways to log out a user from the terminal?
  Post a comment  •  Comments (7)  
  • Currently 2.00 / 5
  You rated: 2 / 5 (1 vote cast)
 
[10,410 views] Email Article To a Friend View Printable Version
Open source WaveLAN drivers available System
[Editor's note: Submitted by ehintz on July 6th. This story is great news for those of you using non-Apple wireless cards to access your network. Check out the referenced MacNN forum for some great info about the drivers and how they came to be!]

Open source OS X drivers are now available for Lucent's WaveLAN cards. Instructions for installation can be found in this MacNN forum.
  Post a comment  •  Comments (2)  
  • Currently 4.50 / 5
  You rated: 4 / 5 (2 votes cast)
 
[2,701 views] Email Article To a Friend View Printable Version
LaCie USB floppy drive support in OS X System
I bought a LaCie USB Floppy along with my G4/450 DP, and of course the fact that OS X dosn't support it is rather frustrating. Even more so that LaCie offered no support on this drive whatsoever! The drive is not manufactured by LaCie at all, it's made by Y-E Data, a company in Japan; http://www.yedata.com.

They call it "USB Floppy Disk Drive FlashBuster-U" and "USB FDD SNAP-ON Color Cover Model". There are two other variants; one made for the early iMacs, and one for Windows. Just now, I received a mail from Y-E Data:
Apple will support USB FDD on Mac OS X with built-in driver. But current version of Apple's Mac OS X driver has problem with mount and un-mount operation. Please wait. Apple will fix this problem on future update.

If you want force to take USB Floppy on current version:
  1. Do not install driver from driver CD-ROM. USB floppy drive work with Built-in Driver of Mac OS X.
  2. Insert Floppy Disk to USB Floppy before connecting USB Cable.
  3. Connect USB Cable to your Mac.
  4. Floppy will mount on your Mac.
But, you could not un-mount and change floppy disk.

Apple release Mac OS update 10.0.4, we already test it but, it has still problem. Please wait Apple's next update.

Regards,
========================
Yoshi Sasaya Y-E DATA INC.
It's not a perfect solution, but it does help a bit. Thanx to Mr. Sasaya for his help! ;-)

Bankmann
  Post a comment  •  Comments (9)  
  • Currently 3.00 / 5
  You rated: 4 / 5 (4 votes cast)
 
[23,721 views] Email Article To a Friend View Printable Version
Uptime stats in OS X? System
I am curious how long people have been able to keep their OS X systems up and running without a reboot for any reason. If you are not sure how to check this go to the terminal and type
uptime
It will then return something like:
6:00PM up 8 days, 15:04, 1 user, load averages: 1.24, 1.37, 1.45
The bit that says up 8 days 15 hours is what I am interested in. Reasons for rebooting would also be of use. For example I have found that over time my idle process time goes down so drastically that I must periodically reboot to improve overall system responsiveness and stability. But I also tend to get a kernel panic every 5-8 days as well. Others may find that they have to reboot into OS 9.x to use some app. 8.5 days is the longest I have been able to remain up thus far. I look forward to hearing about this...

[Editor's note: Seems like a reasonably interesting topic, given the relative lack of OS X news lately! Chime in ... my current uptime is 2 days, 23:15. Last reboot was due to a need to burn an iDVD.]
  Post a comment  •  Comments (28)  
  • Currently 3.67 / 5
  You rated: 2 / 5 (3 votes cast)
 
[43,293 views] Email Article To a Friend View Printable Version
10.0.4 resolves (some?) USB issues System
Just a quick note to let you know: I have a Logitech USB optical 2-Button Wheelmouse (3-button if you include the wheel!). It used to freeze if left unused for more than about 15-20 minutes. Pointer would not move, but mouse seemed to be registering the movement (optical LED lights up).

With update 4, I have not had a freeze in 4 days. Seems they fixed some USB issues - Yipee!!

----
Geoff Saulnier - Mac, *NIX, perl, hack!!
  Post a comment  •  Comments (5)  
  • Currently 2.50 / 5
  You rated: 5 / 5 (6 votes cast)
 
[3,211 views] Email Article To a Friend View Printable Version