Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Clear printers and print jobs System
Why would want to clear the Printer and Spool files? If you lose the ability to print in OS X 10.1 and the Classic environments, booting to 9.X.X and printing is not a real solution. But clearing the Printer and Spool files may be a quick way to restore your printing capabilties. To clear the queue and printers:
  1. Open "Print Center" in Applications -> Utilities
  2. Click on the "PrintCenter" menu, then press and hold the option key and select "Quit Print Center". This will bring up a dialog box asking you if you're sure you want to delete your printer and any jobs waiting to be printed. Select "Yes".
  3. Open Print Center again and re-add your printer. I've had this work with Apple, Epson, HP and Lexmark printers.
[Editor's note: I just used this hint to clear a stuck queue on a Brother HL-1270N as well.]
  Post a comment  •  Comments (2)  
  • Currently 5.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[7,243 views] Email Article To a Friend View Printable Version
Protect pre-OS X files and folders System
I wanted to restrict other users' access to folders that existed prior to my upgrade to OS X, like the subfolders in my home folder.

Files and folders that were on the hard disk prior to upgrading to OS X are not assigned to a user or group. They take on ownership by whatever user is logged in. Using the Finder: Show Info to change the Privileges does not work. Any user logging in is listed as the owner with rw, r, r privledges. Group is usually "unknown."

To restrict access, you can log in as the user you want to own the files and copy them. Then delete the original. A faster method can be done via Terminal using "chown". You must sudo to use this command:
sudo chown [user shortname] filename
I did this to a folder and, voila, logging in as a different user I couldn't open the folder and got the "do not enter" folder icon.

For neatness' sake, you can also change the group [Editor: chown username:group filename]. The group is usually "Staff", but check out an existing file's privileges first.

I think an option for chown will change all files below "filename" but I haven't tried it. [Editor: use the "-R" option on chown]
  Post a comment  •  Comments (2)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[3,671 views] Email Article To a Friend View Printable Version
DVD Player update available now System
Based on a blurb in an email I received, I asked Software Update to check for new software. As expected (thanks to the email!), I saw that the "DVD Player Update" was available. This 15.2mb download "delivers improved performance and stability, as well as support for Blue and White Power Mac G3 and Power Mac G4 systems with PCI-based graphics." [According to the blurb in Software Update panel]

So for all of you who have been using the hacked DVD player on your Blue & White's, check your Software Update!

I won't have a chance to test this until later tonight ... anyone have any feedback on performance yet?
  Post a comment  •  Comments (9)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[2,072 views] Email Article To a Friend View Printable Version
Accessing a volume named '/' System
My brother upgraded to 10.1 today. Unfortunately, his non-OS X partitions were all hidden; still, by using GetFileInfo and SetFile, I was able to show and access all the missing partitions.

That is, all the partitions except the one named slash ('/'). While SetFile seemed to work on '/Volumes/\/', I still couldn't access it. After much headache, we found that we could access it in the Terminal or "Go To Folder" by typing '/Volumes/:'. Apparently, the pathname separator character differences between HFS+ and UNIX are to blame...thankfully, not so hard to overcome, at least on the Desktop level.

[Editor's note: Glad you got this one resolved ... I must admit, this is the first I've heard of someone naming their hard drive '/' ... I think I'll be sticking to letters and numbers for my volumes names!]
  Post a comment  •  Comments (3)  
  • Currently 4.50 / 5
  You rated: 5 / 5 (2 votes cast)
 
[2,777 views] Email Article To a Friend View Printable Version
Change your short username System
Someone asked me whether it was possible to change the short username in OS X. I knew it wasn't possible in the Login preferences panel (it's greyed out), but I thought NetInfo Manager should have a way to do this. In looking at the "Users" panel in NetInfo Manager, it seems like it would be a simple matter of changing all references from "oldshortname" to "newshortname". I did not, however wish to try this on my own machine (since it's working well!), so I went digging for some answers.

I found two interesting articles (one, two) on the MacNN forums which seem to describe the process fairly well. The essence of the solution seems to be:
  1. Login as root
  2. Rename the /Users/old_username folder to /Users/new_username
  3. Open NetInfo Manager and click on the lock to allow changes (enter admin password)
  4. Click on the "Users" column, and then edit any reference to "old_username" and replace it with "new_username"
  5. Click on the "Groups" column, and make sure "new_username" is in any of the same groups as "old_username". Wheel, in particular, will be an important group!
  6. Save the changes in NetInfo Manager and quit.
  7. Logout and login as the new 'shortuser' and see if everything works.
Please note that I have not tried this myself! Make sure you have a backup of your important user files before you start, just in case! If you know of a better way to do this, or have actually tried changing your short username, please let us know about it!
  Post a comment  •  Comments (10)  
  • Currently 3.67 / 5
  You rated: 5 / 5 (3 votes cast)
 
[19,079 views] Email Article To a Friend View Printable Version
Mac OS X Solutions Guidebook released System
Some of you may be familiar with the OS X Guidebook I wrote back in April of this year. This was a 12-page PDF file with some general advice on using OS X, and it proved quite popular -- over 20,000 downloads to date!

Since its release, I've been slowly working on a revised version with more detail and updated information relative to recent OS X updates. I used the four-day break for Thanksgiving to complete the revision. Only it was so 'revised' that I felt it merited a new name. After way too many hours in development, I am pleased to announce the release of:

The Mac OS X Solutions Guidebook - download [1.3mb PDF] **

The Guidebook is now 60+ pages long and covers a number of topics, including general advice, the Finder, the dock, Classic, System Prefs, a few key apps, and a detailed section of UNIX command-line tricks and hints. There are over 100 screenshots to help illustrate various hints, and the entire Guidebook runs over 32,000 words (spellchecking took forever!).

As a reflection of the size and scope of the new Solutions Guidebook, it is being distributed as a shareware project. I'll be using the registration fees to help fund macosxhints in the future. The shareware fee is only $10.00 ($5.00 for students), but if you've made a donation (either monetary or a submitted hint) to support macosxhints, then the Guidebook is free -- consider it my way of saying "Thank You" for the support!

For everyone else, please download the guide and put it to use. If, after you've read it thoroughly and tested the hints and found the Guidebook to be valuable, please pay the shareware fee. Not only will you be helping to support macosxhints (remember, I don't accept advertising), but you'll be getting an incredibly useful book for only $10!

As always, I welcome comments, corrections and criticisms - drop me an email with your thoughts.

Enjoy!

** NOTE: If you have trouble with the mac.com download, the Guidebooks is also available via a direct download from macoshxints. If you can't get mac.com to work, try the direct download.
  Post a comment  •  Comments (3)  
  • Currently 1.00 / 5
  You rated: 1 / 5 (2 votes cast)
 
[4,702 views] Email Article To a Friend View Printable Version
Deleting absolutely undeletable files System
I had somehow managed to create a file which simply defied deletion. I was pretty sure I'd created the file, as it was named "testfile" and was in my Documents folder. I'm not sure what I was testing, but the file was simply locked into place. Everything I tried failed to remove this file -- I made sure it wasn't "locked" in the Finder, I tried putting it in another folder first, and I even tried 'sudo chflags nouchg,noschg testfile' in the Terminal. Still, I couldn't even put the file in the trash, and if I tried to delete it as root, I received "Operation not permitted".

I finally killed it by switching to single-user mode and then changing the flags:
% sudo shutdown now               [ends Aqua and enter single-user mode]
% su [become root]
% chflags nouchg,noschg testfile [change the two flags I thought responsible]
% rm testfile [get rid of it!]
% exit [end root]
% exit [restart Aqua]
This did the trick; the file is now history, and no true restart was required (dropping to single-user from Aqua and then exiting back to Aqua is much faster than two restart cycles) ... my 'uptime' even survived intact :-).

Read the rest of the article if you'd like an explanation as to why this had to be done in single-user mode (thanks to Marc D. for providing the addition insight).
read more (188 words)   Post a comment  •  Comments (5)  
  • Currently 4.00 / 5
  You rated: 5 / 5 (3 votes cast)
 
[20,465 views] Email Article To a Friend View Printable Version
Setting A4 paper size for Epson printers System
I've read on MacOSXHints how to change the global setting for the paper size. However, on my Epson 760 this had no effect. This posting by Emma on the Discussions at Apple's website explained why:

The method for changing default paper size depends on what brand of printer you have. If you have an Epson printer, the default paper size depends on the model of printer. To change the default paper size for an Epson printer open the /Library/Printers/EPSON / folder then locate the plugin for your model printer. Control-click on the plugin and select "Show package contents". Then open /Contents/Resources/English.lproj/Localizable.strings in TextEdit.

You will see a line in this file that says "DefaultPaperSize" = "na-letter";
Change it to "DefaultPaperSize" = "iso-a4";
Save your changes.

HP printers use the system-wide default paper size which depends on your language. If your first system language is English, your system-wide default paper size is US letter. (Blame Apple for this, not HP - the whole idea of basing default paper size on language is ridiculous).

To change the default paper size for an HP printer, take the following steps:

Log in as root
Open the following file with TextEdit: /System -> Library -> Frameworks -> ApplicationServices.framework -> Versions -> A -> Frameworks -> PrintCore.framework -> Versions -> A -> Resources -> English.lproj -> Localizable.strings
The last line will say "DefaultPaperSize" = "na-letter";
Change it to say "DefaultPaperSize" = "iso-a4";
Save your changes.

Hope this helps some other Epson owners.
  Post a comment  •  Comments (1)  
  • Currently 4.25 / 5
  You rated: 2 / 5 (4 votes cast)
 
[11,142 views] Email Article To a Friend View Printable Version
Using FireWire MSDOS disks System
I ran into the problem of reading a MS-DOS partitioned FireWire drive. I would plug the drive in and a dialog box stated that the drive was in an unknown format. I remember being able to read (and even format) MS-DOS over SCSI, but with the FireWire, it wouldn't work even in OS9. After trying to get it to work and messing with some Unix commands I stumbled across an interesting way to mount the msdos right on the desktop in Aqua!

Read the rest of this story if you're interested in seeing MS-DOS formatted FireWire drives on your desktop.
read more (424 words)   Post a comment  •  Comments (8)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[7,709 views] Email Article To a Friend View Printable Version
Use Dingbat and Symbol fonts in Cocoa apps System
Have you noticed the the Symbol and Dingbat fonts don't work in Cocoa applications? Do you want them to work? Do you wonder why they don't work when you select one and start typing?

The following solution is courtesy of Vasantha Crabb, who has written an excellent introduction to multiple language support on OS X. Even though I'm a US-centric OS X user, I found it quite interesting. I've put a PDF version of Vasantha's OS X Multiple Language Support guide on my iDisk; if you have any interest in how non-English languages are handled in OS X, give it a read.

To enable Dingbats and Symbol fonts in Cocoa apps, open your System Preferences panel and click the International icon. On the International preference pane, click on Keyboard Menu. Look for Symbol and Dingbats in the keyboard list and place a checkmark next to each. Click the Options button and make sure that command-option-space for switching layouts is checked.

Open a Cocoa application, hit command-option-space until you see either the Symbol or the Dingbat keybard icon in your menubar, and start typing. You should now see Symbol/Dingbat characters onscreen!

If you'd like a brief explanation as to why you need to do this, read the rest of the article. I've snipped a bit of Vasantha's guide that talks specifically about the Dingbat and Sybmol fonts in Cocoa apps ... for the full story, though, read his guide.
read more (339 words)   Post a comment  •  Comments (4)  
  • Currently 2.00 / 5
  You rated: 2 / 5 (1 vote cast)
 
[7,995 views] Email Article To a Friend View Printable Version