Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Restore the OS 9 function keys System
I switched to OS X two days ago and got crazy when I found myself pressing the function keys to reveal my app actions -- I feel invalid without F1-F12 in Photoshop and Flash. I was searching the web for that issue but couldn't find any solution (not even the problem mentioned...) Well, I finally found one...

Boot into OS 9, open the Classic control panel "Keyboard" and change the prefs here. Booting back into OS X, the function keys are functions keys again! Woohoo!

[Editor's note: I'm almost positive we had published something along these lines at some point in time, but I can't seem to find it at the moment...so apologies in advance if this is a duplicate!]
  Post a comment  •  Comments (4)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[3,273 views]  View Printable Version
New USB webcam driver available System
A German guy has done it ... the first USB webcam driver is now available, but only for the Philips ToUCam Pro. I hope that other cameras will follow soon as this is written as open source. Read about the 'wc' driver and its current status on the wc home page.

[Editor's note: I used Oculus for OS X over the holidays to drive our FireWire video camera as a web cam, and it worked perfectly. It captured an image every second to the hard drive, and uploaded an image every 90 seconds to our website for a couple of hours. The Oculus site lists some USB cameras as supported, but I have no idea if they work in OS X or not.]
  Post a comment  •  Comments (4)  
  • Currently 2.00 / 5
  You rated: 1 / 5 (4 votes cast)
 
[4,695 views]  View Printable Version
Troubleshooting startup issues System
A while back, I noted the improved Apple Knowledge Base and its useful options for learning and troubleshooting OS X ... here's one example of why I find it so valuable.

After returning from Macworld Expo, I was browsing my saved "What's new in OS X" search for new or revised OS X documents. One of the items listed was Troubleshooting a Startup Issue. This article contains a number of troubleshooting steps that may help resolve startup problems that include a blue screen, gray screen, flashing question mark, kernel panic or other issue. So if you're having startup problems, give the article a quick look!

And if you haven't built yourself a Knowledge Base page yet, it's well worth the effort. The new Knolwedge Base is the best way I've found to stay connected with official Apple information releases regarding OS X. I certainly have no intention of repeating everything they publish there on macosxhints, but I will try to note when particularly interesting articles are released.
  Post a comment  •  Comments (2)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[4,881 views]  View Printable Version
Recreate the fonts folder to eliminate slowdowns System
My system became slower and slower and bringing up the font menu in Cocoa apps was very slow - taking between 5 and 10 minutes (beachball-cursor, even the dock was incredibly slow).

I checked out the font directories but couldn't find anything strange. So I copied all the fonts from my user's font folder (~/Library/Fonts) to a new folder, restarted my machine, copied all the fonts back and restarted one more time (not sure if the restarts were necessary). After this, my machine works fine as before.

[Editor's note: I have no way of really testing this myself, so it's published here as a possible troubleshooting tip for those that may be experiencing slowdowns in OS X.]
  Post a comment  •  Comments (3)  
  • Currently 2.67 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (3 votes cast)
 
[2,550 views]  View Printable Version
Launch system prefs with the keyboard System
Thanks to Johan K. for emailing this one to me.

If you have the Apple Pro keyboard, you can launch (or bring to the foreground) the System Preferences application by holding down the option (alt) key and hitting the mute key twice.

Strange but true -- it works!
  Post a comment  •  Comments (10)  
  • Currently 3.00 / 5
  You rated: 3 / 5 (4 votes cast)
 
[1,867 views]  View Printable Version
Change the System Prefs area names System
I noticed last night that my desktop machine had "Customize", "Gear", "Connectivity', "Nuts and Bolts" and "Misc" in place of the normal names within the System Preferences window. The normal names are "Personal", "Hardware", "Internet & Network", "System", and "Other". I'm not sure how these were changed on my machine; I honestly do not recall doing it myself (and I searched the site for a hint about renaming system prefs and came up blank). Perhaps some third-party preference panel that I installed and removed changed them at some point. If you have some idea of what might have changed this, let me know (out of curiousity more than anything else).

In any event, noticing that they differed from the official names as seen on my iBook, I set out in search of what was controlling the names and discovered that they are relatively easy to change.

Read the rest of the article for the how-to...
read more (319 words)   Post a comment  •  Comments (9)  
  • Currently 3.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[2,562 views]  View Printable Version
How to force an update to QuickTime System
I created a one-second movie using the QuickTime 'DVCPRO-PAL' Apple codec. If you attempt to play it with QT Player 5.0.2, you should get the standard, "QuickTime does not have the necessary software . . . " message. Then QT Updater should launch and download the new 'QuickTime JPEG Update' and 'QuickTime DV Update' extensions.

This should work for both Classic and OS X. Just play the movie with each version of QuickTime Player. In Classic, these will appear as extensions in the System Folder -> Extensions -> QuickTime Extensions folder.

This seems to be the only change in QT 5.0.4. These are the same components included on the new FinalCut Pro 3.0 installer CD.

[Editor's note: It appears this movie has been pulled from the referenced webpage. I'm leaving the article here as some of the discussion below contains useful information.]
  Post a comment  •  Comments (13)  
  • Currently 2.50 / 5
  You rated: 5 / 5 (4 votes cast)
 
[4,236 views]  View Printable Version
Possible solution to sleep problems on DP Macs System
X Sleep Solution is an app that may well let your dual processor fall asleep if it currently refuses to. It works on my G4/500/DP.
  Post a comment  •  Comments (4)  
  • Currently 2.75 / 5
  You rated: 1 / 5 (4 votes cast)
 
[2,444 views]  View Printable Version
Enable DVD playback on a Beige G3 System
I upgraded my original beige G3 desktop with a 466MHz G3, an ATI 128 Rage Pro, and a Apple DVD internal drive over the years. These upgrades have worked fairly well, but I have alway been disappointed that DVD movie playback has never worked. When the DVD Player 3.0.1 update came out for 10.1, I was hopeful that my beige G3 would finally play DVDs since my mac now has almost the same spec as a B&W. But unfortunately the installer wouldn't recognize my mac.

This morning I saw the hint for "Pacifist" (an OS X version of "Tome Viewer"), and thought I'd give it another crack.

It worked beautifully. For the first time I am enjoying DVDs on me beige G3. Just download "Pacifist" and the Apple DVD 3.0.1 update. Use Pacifist to install the update and the balcony is open!

James

PS: I guessing that the update doesn't use the hardware decoding card on B&W G3s since my ATI card doesn't have one.
  Post a comment  •  Comments (0)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[2,992 views]  View Printable Version
Printing with OSX and Phaser 840 System
Long story - Printing with Tektronix (Xerox) 840 color printer. Areas of the page that should be white (clear) were coming out pale yellow. Besides being annoying, it was using a tremendous amount of ink.

After multiple calls to Apple (results were "Duh?") I managed to get to a very intelligent and helpful Xerox technician. He used Macs, and to make a long story short - remembered this problem from NeXt days - seems that Apple just used the old NeXt print code. This code messed with the printer "white point".

At any rate - Xerox created and sent me a new rom for the printer overnight that fixed the problem. If any of you have this problem, just let Xerox know and they'll take prompt care of it.

Al
  Post a comment  •  Comments (2)  
  • Currently 2.00 / 5
  You rated: 2 / 5 (2 votes cast)
 
[2,123 views]  View Printable Version