Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

How to use SSH for secure mail Network
Mail.app doesn't support SSL or TLS. I don't like sniffable passwords in general and really don't like them when the system has a wireless connection. Here's how to make it easy to use tunnel IMAP or POP3 through SSH. As a bonus, SSH supports compression (-C), which
may improve your transfer speeds.

SSH tunneling requires a remote server with SSH. This does not need to be the same server you're retrieving mail from - you might ssh into a
login server on the same network as your mail server. MAILSERVER and SSHSERVER refer to the IMAP/POP3 and SSH servers respectively.

Read the rest of this article if you'd like a detailed how-to on setting up secure mail transfer.
read more (311 words)   Post a comment  •  Comments (8)  
  • Currently 2.33 / 5
  You rated: 1 / 5 (3 votes cast)
 
[13,917 views]  View Printable Version
Resetting Appleshare client login prefs Network
Curious - changed the "Options.." for "AppleShare Client" for Mac OS X and not know how to return those settings to the defaults?

If you have played around with the options found behind the "Options.." button on the login screen for a server when using the Mac OS X Client, and can not log onto a server any more, or received the error message "-5002 Bad UAM," then you might find this helpful.

The options that can be changed in the Options dialog are:
  • Add Password to Keychain
  • Allow Clear Text Password
  • Warn when sending password in cleartext
If any options are changed, and you are unable to return to this dialog to undo those changes, you can try the following. Go to your Keychain Access application, and remove your keychain entry for that and other volumes for that server.

If that does not work, please read the rest of this article for a couple of other options to restore the full functionality of the Connect to Server dialog box.
read more (240 words)   Post a comment  •  Comments (7)  
  • Currently 2.33 / 5
  You rated: 4 / 5 (3 votes cast)
 
[8,656 views]  View Printable Version
Long hostnames and Windows share trouble Network
I found that I was able to mount CIFS (Windows, for example) shares on some servers, but not others, and the cause turned out to be that the hostname of my computer was just too long.

During the OS 10.1 setup the hostname for my computer was automagically set to "Bennett Hendry's Computer" (without the quotes), which showed up in DNS as bennett-hendry-s-computer. I opened the Sharing preferences panel and changed it to bhendry-mac.

Now I am able to mount CIFS shares on any server without trouble. I also don't need to specify the longer syntax mentioned in previous hints. The syntax "smb://server/share" works perfectly every time in the Connect To Server dialog box.

Ben
  Post a comment  •  Comments (0)  
  • Currently 2.00 / 5
  You rated: 2 / 5 (3 votes cast)
 
[3,885 views]  View Printable Version
Realtek drivers for inexpensive ethernet cards Network
I switched my machine to real IP from our 192.168.x.x but then my transfers from our file server stunk. So I found these 10.1 drivers on VersionTracker. Most of the cheap $10-$15 ethernet cards use the rtl8139c chipset. I found both D-Link DFE530TX+ and the SMC1244TX. I got a D-Link for $10 with a $10 rebate at a local store. Installed the card and ran the driver package. Worked perfectly first try. I guess gone are the days of "Mac Only" hardware. I'm thrilled. An easy way to tell if a card will work is look at the linux drivers, if they are rtl8139, you're set.
  Post a comment  •  Comments (3)  
  • Currently 4.67 / 5
  You rated: 4 / 5 (3 votes cast)
 
[9,553 views]  View Printable Version
Eliminate multiple listings in 'Connect to Server' Network
I saw this tip on MacFixIt and it was just what I had been looking for. In other words this works.

We have had a problem where, when selecting the "Connect to Server" command, we get multiple listings for the very Mac we are using, all with different IP addresses. In one case, the IP address was one we could never even recall using. Mark Delfs offered this solution, which worked:
  1. Turn off AppleTalk from Network System Preferences.
  2. Launch Terminal.
  3. Type cd /var
  4. Type sudo rm slp.regfile to delete the slp.regfile file.
  5. Restart.
  6. Turn AppleTalk back on.
The OS should now rebuild the file and you will no longer see the multiple IP numbers in the Connect to Server dialog box.
  Post a comment  •  Comments (3)  
  • Currently 2.50 / 5
  You rated: 3 / 5 (4 votes cast)
 
[4,743 views]  View Printable Version
Lazy man's Software Base Station Network
hey guys

I had seen the previous post on setting up a software base station via the terminal, but I couldn't get it to work for the life of me. I then saw this free ethernet router program called geeroute.

You simply install the program, and set the client machine with the correct name server on your network and set the router address as 192.168.150.1. It worked with an ethernet network, so I wondered if it would work with airport.

So I just set up the Airport settings on my G4 with 10.0.1.1 as the Airport IP (like they used on the Software Base Station) and set the subnet mask as 255.255.255.0. Then I used 10.0.1.1 as the router address on my Pismo. I gave the Pismo the IP address 10.0.1.6, set the subnet mask, and put in the name server.....and it WORKS!! You can have a software base station up and running in less than 5 minutes!
  Post a comment  •  Comments (10)  
  • Currently 2.00 / 5
  You rated: 1 / 5 (3 votes cast)
 
[5,251 views]  View Printable Version
Accessing SMB/Windows Shares from 10.1 Network
10.1 claims to be able to access Windows (aka Samba) shares through Finder. It does, but getting it to work is not obvious. According to a KnowledgeBase article, you do "Connect to Server.." in finder and enter a URL of the form:

smb://servername/sharename/

Two things to note:
  1. The actual url might require a username, in the form of:

    smb://Username@servername/sharename/

    where Username is a user that can log into the box.

  2. You cannot access shares that require Microsoft's Active Directory Service for authentication (as far as I have been told). It seems that this requires a different kind of password encryption not supported by OS X
I have not been able to determine how to do the mount on the command line, but it is probably done via the mount command as normal in unix with smbfs as the filesystem type.
  Post a comment  •  Comments (31)  
  • Currently 5.00 / 5
  You rated: 5 / 5 (3 votes cast)
 
[13,508 views]  View Printable Version
Switch IP addresses remotely Network
Does anyone know of a way to change your IP address remotely? either through a shell script, Apple Script or a Perl Script? All I would want to do is log in (SSH, or a password protected web page) and run the script to toggle the Network 'Location' (my primary server went down today and my OS-X box is my backup server).

Or better yet does someone know of a script that will ping my primary server every few seconds, then if there is a non-response ping, run the above script.

[Editor's note: See the comments for the answer - 'scselect' is a Darwin-specific command-line utility to switch the current location!]


Panther proven!
  Post a comment  •  Comments (9)  
  • Currently 1.33 / 5
  You rated: 2 / 5 (3 votes cast)
 
[8,103 views]  View Printable Version
Check the Apache logs for Nimda worm attacks Network
I realize that readers might be getting tired of the pipe-related tricks, but here's a quick one that may be of use to anyone running a webserver from OSX. As you realize, the Net is in for yet another round of annoyance with the introduction of the nimda worm. Like its CodeRed predecessors, it primarily targets Microsoft IIS servers, not Apache which is installed by default with OSX. While Apache is immune to this PARTICULAR attack**, it is still affected by the fact that an infected Windows system will launch hundreds of attempts to find other vulnerable systems, thereby creating a denial-of-service situation across the Internet.

Anyhow, if you do serve HTTP from your OSX box, here's a quick way to check if a nimda-infected system has contacted yours:
grep -i "_vti_bin" /var/log/httpd/access_log* | cut -f 1 -d ' ' | sort | uniq
to show all the unique IPs of infected systems. Or you could add:
| wc -l
to the end of the above command to just see the total number of different attempts made.

** A gentle reminder that choosing the Mac as our platform doesn't inherently make us more secure from net attacks and exploits -- it's just the fact that more people are using Windows at this time, so that's where most of the blackhats turn their attention towards.
  Post a comment  •  Comments (13)  
  • Currently 2.00 / 5
  You rated: 2 / 5 (2 votes cast)
 
[5,793 views]  View Printable Version
Multihoming for mulitple network connections Network
I had a devil of a time getting my DSL, LAN, and LW 16/600 to work together on OS 10.0.4. Finally today, thanks to one of the geniuses at the VA Apple store, I have it all working and I thought I would pass along what I did for those suffering the same agony.

Read the rest if you'd like to learn how to have one device (Ethernet) configured to use multiple protocols at the same time...
read more (298 words)   Post a comment  •  Comments (0)  
  • Currently 3.00 / 5
  You rated: 4 / 5 (3 votes cast)
 
[9,051 views]  View Printable Version