Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Communicating with Microsoft Proxy Servers Network
Like a lot of OS X users on NT or Windows 2000 with ISA Server, I had a problem with authenticating behind a MS Proxy Server. Every time I used Explorer, I had to authenticate my user name and password. On top of that, programs like Software Update, Quicken and Watson could not communicate correctly.

Our IT person found that the Mac was not creating a session with the Proxy Server even though Macs were supposed to be able to communicate as a secured NAT client. However, there is a simple work around that has corrected these problems.

On the Proxy server, allow the leased or static IP address for the Mac to fully "open up" to the proxy. This allows the Mac to communicate directly with the Proxy, thus allowing the Mac to communicate as a secured NAT client. Once this happens, all the programs communicate with the Proxy Server and they no longer have to authenticate with every use. Since we have done this, I have not had to authenticate Explorer.

Thought that this might be of service to someone.
  Post a comment  •  Comments (5)  
  • Currently 2.25 / 5
  You rated: 3 / 5 (4 votes cast)
 
[6,298 views]  View Printable Version
Control FileSharing from the command line Network
As it turns out, Apple File Sharing is configurable, via NetInfo. Despite the dearth of documentation, you can even share folders other than ~/Public. Alas, doing the NetInfo / System Preferences dance is a hassle. So I scripted it.

Now you can control your file sharing with a single command from the comfort of your shell of choice.

[Editor's note: You can also control shares with the shareware program SharePoints, which has been discussed here before. But it's nice to have a command-line option available as well, so thanks to 'logan' for putting this together.]
  Post a comment  •  Comments (4)  
  • Currently 2.00 / 5
  You rated: 2 / 5 (3 votes cast)
 
[7,428 views]  View Printable Version
Use a Java client to access VNC servers Network
For a while, I have been trying to get the Java VNC viewer working so that I can VNC into my computer from any Java-compliant browser. this proved to be a bit of trouble but, don't worry, I finally got it working. After compiling the souce code, I played around with the class files and got it working. This, combined with OSXvnc, is a great solution to remotely control your computer from any computer terminal.

It can be found on this boring site of mine. I would like to say that I take no credit for creating a "port"; I merely compiled the source code and put it in a neat package ;-).

[Editor's note: The Java VNC client has been mentioned here previously, but instructions on compiling the client were not included; "c.i.t" has provided a ready-to-run version.]
  Post a comment  •  Comments (7)  
  • Currently 1.67 / 5
  You rated: 2 / 5 (3 votes cast)
 
[19,861 views]  View Printable Version
Quick access to network activity window Network
In Mail.app and OmniWeb and possibly other programs, if you click (or double-click) on the spinning arrows, the network activity window opens up. This tip will not change your life.

[Editor's note: Not a life-changer, but a nice tidbit nonetheless!]
  Post a comment  •  Comments (0)  
  • Currently 2.33 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (3 votes cast)
 
[2,234 views]  View Printable Version
Xerox releases Splash PPDs for OS X Network
Xerox has just released OS X PPDs for the Splash RIP, available on their Splash support page.

We have a Xerox 5765 with a RIP running Splash on a Beige G3 (OS 8.6). This was the standard configuration four years ago. Mac OS X was not supported until today (client side). The only downside to the new software is that you have to use AppleTalk. From the ReadMe in the installation file:
The Splash OS X PPD installer installs PPDs for all currently released Splash products for Mac OS X. The products installed are: G630, G620, G610, PCI 6.0, PCI 5.0, DC 4.0, DC 3.0, DC 2.0.
I have installed and used the PPD for the 5799 v.6.0 without any problems.
  Post a comment  •  Comments (2)  
  • Currently 1.75 / 5
  You rated: 2 / 5 (4 votes cast)
 
[5,995 views]  View Printable Version
Use Goliath for iDisk access behind a firewall Network
macosxhints has carried a tip on how to access iDisk from behind a corporate firewall before, but I have found it is even simpler using Goliath.

First choose New Connection (not Connect to iDisk!) from the File menu. Enter the URL of your iDisk; it will be idisk.mac.com/username/ where username is your iTools account username, and then add your password.

Next click the Advanced settings, click Use Proxy Server box and enter the proxy server address (the same as you use to browse) and again the port that you use for http access. Click OK and you're away.

You can then follow the other hints posted to save the connection as a file and put the icon on the toolbar for instant access, even behind your firewall.
  Post a comment  •  Comments (5)  
  • Currently 4.67 / 5
  You rated: 4 / 5 (3 votes cast)
 
[7,021 views]  View Printable Version
Connect to a Windows-based VPN Network
When I found out that Apple did not include a PPTP VPN client with OS X, I was a bit disappointed. Sure, Cisco provides a VPN client for those using a Cisco VPN, but what about us folks using a Windows VPN server?

After a bit of searching, I found PiePants, a PPTP client made by Rob Newberry. It works perfectly with my Windows 2000 VPN server. Take a look at it if you need Windows VPN connectivity.

[Editor's note: I have not tried this program myself, but thought it might be of interest to some readers.]
  Post a comment  •  Comments (11)  
  • Currently 3.00 / 5
  You rated: 2 / 5 (4 votes cast)
 
[12,854 views]  View Printable Version
Add Axis 1440 printserver support to the Epson 740 Network
It is possible to rather easily hack the printer driver so that Mac OS X will recognize & print to an Epson 740 networked via AppleTalk and an Axis 1440 ethernet print server. Yay!!!

I was already able to print via USB to the Epson 740, but that is of course not what we needed. We needed to continue to use the 740 as a networked printer, via the Axis 1440 ethernet print server that has worked so well for several years with Mac OS 8 & 9.

This hint might also apply to other similarly unsupported printer models that are similar to a newer, supported model.

Downside: I seem to have lost the ability to print to this printer via Mac OSX USB. Oh well. It still prints ok from Classic mode ethernet, Mac OS 9 ethernet, and Mac OSX ethernet, so I'm not complaining. (I didn't test it with Mac OS 9 USB, but that ought to still be just as it was).


Read the rest of the hint for the details...
read more (444 words)   Post a comment  •  Comments (7)  
  • Currently 1.50 / 5
  You rated: 2 / 5 (4 votes cast)
 
[7,619 views]  View Printable Version
Run a networked netinfo database on a laptop Network
I am running our master network netinfo database on my TiBook and a couple of clones on other portables. Why? Well, in our company we all use portables and we don't have a Mac OS X based server.

I have been fighting with this configuration for quite a while as it is pretty unstable once you change the network location (e.g. forever bouncing apps). The problem is that no matter what network location you choose, nibindd (the process which controls your netinfo processes) will always start all the netinfo databases no matter if they are appropriate for you current network location or not.

Read the rest of the article for a workaround to this problem...
read more (103 words)   Post a comment  •  Comments (2)  
  • Currently 3.00 / 5
  You rated: 4 / 5 (3 votes cast)
 
[3,010 views]  View Printable Version
Automount network drives at login Network
This is a bonus tip based on the recently posted Mount server volumes using location files, but it is so useful I thought it deserved its own tip.

Once you have created a Location File using the method explained in said tip, add that file to your Login Items on the Login system preference pane. Next time you boot or login, the referenced network drive will be automaticly mounted.

Best of all, this method works with servers that don't allow passwords to be saved to the keychain.
  Post a comment  •  Comments (3)  
  • Currently 2.80 / 5
  You rated: 5 / 5 (5 votes cast)
 
[17,404 views]  View Printable Version