Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Enable AppleTalk printer sharing with Windows Network
There have been lots of printing hints here lately, but none quite solving the following problem: How to print from a Windows XP machine to an AppleTalk LaserWriter attached to a Mac OS X machine. Here's how to do it:
  1. Things you may need to do first:
    In the Sharing Preference Pane, turn on Windows Sharing and Printer Sharing. Configure samba to use cups as explained here on macosxhints. I don't know for sure that all these things are necessary because I haven't tested it without them.

  2. Find out the name CUPS gives your printer.
    It's probably the name you think it is, but substitute the underscore character for a blank space and the letter g for an apostrophe. You can find out for sure by looking in the file /etc/cups/printers.conf (you will need to do this as super user). There should be an entry for your printer; its name occurs after the word Printer at the beginning of the entry.

  3. Find out the IP address or host name of the Mac OS X machine.
    Use the Network preference pane to get this bit of info; I think either of these will do, but I've only tried it with the IP address.

  4. Go to your Windows XP machine and start up the Add Printer Wizard.
    Select "Network printer ..." then "Connect to a printer on the internet ..." and type the following in the space where it asks for the URL:
    http://ip_address:631/printers/name_of_printer
    Substitute the printer name and ip address you found before for "name_of_printer" and "ip_address".
This is mostly gleaned from other hints on macosxhints and from Apple forums, but I haven't seen it all in one place.
  Post a comment  •  Comments (20)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[41,334 views] Email Article To a Friend View Printable Version
Print to a PC parallel-port-connected HP printer Network
I posted this hint over at the Apple forums and thougth it might be useful here...

I finally figured out how to print to my unsupported HP T45 Officejet which is connected to my Windows 2000 server via parallel port. This will probably also work for other HP deskjets and other versions of Windows provided they are hooked up similarly.
read more (284 words)   Post a comment  •  Comments (13)  
  • Currently 2.33 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (6 votes cast)
 
[60,258 views] Email Article To a Friend View Printable Version
Enable full duplex ethernet in 10.2 Network
You can now enable full duplex ethernet in Jaguar. Previously, the ifconfig command would not recognise the mediaopt full-duplex flag, even though ifconfig listed it as an option. It seems to be fixed now in Jaguar, but I have not yet done any speed tests to confirm whether it really is working. Anyways the error message is gone when you try to enable full-duplex. These commands should be entered in the terminal window:

To view the current ethernet settings:
  % ifconfig
To change to full duplex:
  % sudo ifconfig en0 mediaopt full-duplex
To change back to half duplex:
  % sudo ifconfig en0 mediaopt half-duplex
To force a different speed (your network/hub/router/modem must also support this speed!):
  % sudo ifconfig en0 media 10baseT/UTP mediaopt full-duplex   [or]
% sudo ifconfig en0 media 100baseTX mediaopt full-duplex [etc...]
Check the output of 'ifconfig' to see the supported media types for your ethernet card.

Even if your other network hardware supports full-duplex operation (it probably does) you may not notice a big difference in speed unless you have a lot of two-way traffic. If you do have constant simultaneous upstream and downstream traffic you might see a speed increase up to 12% depending on other network conditions.


Panther broken!
  Post a comment  •  Comments (25)  
  • Currently 4.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[67,986 views] Email Article To a Friend View Printable Version
Access 10.2 shared PostScript printers from OS 9 Network
It's easy to enable OS 9 clients to print to your shared PostScript printers on a Jaguar server; all you need to do is set up cups-lpd on the server. First, add a new file 'printer' to the /etc/xinetd.d directory containing these lines:
service printer
{
disable = no
socket_type = stream
protocol = tcp
wait = no
user = root
server = /usr/libexec/cups/daemon/cups-lpd
groups = yes
flags = REUSE
}
Then restart xinetd with:
 % sudo killall -HUP xinetd
Obviously, "Printer Sharing" needs to be enabled in the 'Sharing' Prefs panel, and if you have the built-in firewall enabled, add a new rule to pass through port 515 (lpd).

OS 9 clients then have to create a new desktop LPR printer, with 'hostname' set to your Jaguar server and 'queue name' set to the printer's CUPS name as displayed by...
 % lpstat -v
... or the CUPS web interface. Of course, this also works with any other client using LPD instead of IPP, such as older UNIX boxes.
  Post a comment  •  Comments (8)  
  • Currently 3.50 / 5
  You rated: 5 / 5 (4 votes cast)
 
[17,949 views] Email Article To a Friend View Printable Version
Use LDAP instead of NetInfo on Jaguar Network
Ok, this is very cool (IMHO). So I am excited, because I have waited for this moment since the first release of OSX. Finally I got everything working to replace my network NetInfo with LDAP. The new Jaguar LDAP support is great. I just replaced my NetInfo network domain with a central LDAP server running OpenLDAP on Gentoo linux.

Additionally, I set up a DHCP server to serve the LDAP URL. With this setup, a Jaguar client will hook up to the network without any further work on the client required. All the network users, groups and shares are available.
This is a very nice out of the box experience. Getting there on the server side was a little harder, but with OSX Server it should be no pain at all.

Read the rest of the article for a short summary of what was done on the server side to get this working...
read more (174 words)   Post a comment  •  Comments (5)  
  • Currently 2.75 / 5
  You rated: 4 / 5 (4 votes cast)
 
[22,479 views] Email Article To a Friend View Printable Version
Locating CUPS print hosts on the network Network
CUPS printing works fine out of the box for most people, but there are a few exceptions. The biggest problem is that many people can't seem to find networked CUPS print servers. I found, in my case, this was because CUPS was not being told where to look for one.

There is a file in /etc/cups called client.conf which needs to be edited. This is most easily done with pico (a Terminal text editor), but as the file is also owned by root, you need to be an administrator. Open the terminal program and move to the cups directory by typing cd /etc/cups then type sudo pico client.conf to start editing the file. If you want to, you could make a backup first by typing something like sudo client.conf client.backup.conf. The first time you use sudo you will get a warning about being careful and, whenever you use sudo after a long period as a 'normal' user, you need to enter your password.

In pico, find the line starting with #ServerName and on the next line, type ServerName Name_of_print_host (don't use quotes or anything; just type the name of the host). Notice the lack of a # sign at the start of the line. There shouldn't be one - that's important. Press control-x to exit pico and save (say yes, you do want to save the file). That's the change made.

Now, for the changes to take effect, you need to restart the cupsd deamon. If you don't like doing this soft of command line stuff, just restart the machine. If you don't want to restart, the following line will usually do it (it finds the pid of the cupsd deamon and sends it a restart command). This all needs to go on one line so it might be better not to copy and paste. Also notice the single quote marks near the start and right at the end are the ones on (on my Apple keyboard) the left under the ~, not the one under the double quote:
sudo kill -HUP `ps -Uroot | grep -n "cupsd" | awk '{print $2}'`
When you next run Print Center, all the printers from the print host should appear.
  Post a comment  •  Comments (2)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[6,920 views] Email Article To a Friend View Printable Version
Change the Workgroup or WINS server in 10.2 Network
After some digging in Jaguar, I've just found the setting to change what workgroup you're found in from Windows clients, as well as the setting for adding a WINS server. It's in the Directory Access application in the Utilities folder; open that up, authenticate yourself, then double-click on SMB in the Services tab. The option to change workgroups or add an WINS server should be before you.

Note that you may have to restart the Windows File Services, log out or possibly even restart in order to change viewing/sharing settings. I did change my sharing workgroup successfully with just a stop/start in the sharing panel. Unfortunately, I don't have a WINS server to test with, so I don't know what's involved in getting the Finder's browser to browse a WINS server, or if it even works for that matter.
  Post a comment  •  Comments (3)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[10,769 views] Email Article To a Friend View Printable Version
Use SSH to secure AppleShare connections Network
When you connect to an AppleShare server via Command-K, click the "Options" button on the User - Password dialog box. Along with the Save to Keychain option is the option to use SSH to secure the connection to the server. Sweet!
  Post a comment  •  Comments (2)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[3,562 views] Email Article To a Friend View Printable Version
Define hosts via the hosts file in 10.2 Network
In Mac OS X 10.1.x, the host table was disabled so that it was quite difficult to add host aliases (eg: "flare" is the alias I use for 192.168.0.2 on my home network). It was possible to do it using NetInfo, but it was not very clear how to do it and was very error prone.

In OS X 10.2 (Jaguar), the hosts table is now active ... even though the hosts file itself says that it only works in single user console mode. So, if you're in a hurry to add hosts that Rendezvous can't find, then simply edit your /etc/hosts file (as root) and add lines for each host alias.

But wait, there's more. It turns out that there's an even better way to do it. Simply create a temporary hosts table file with the extras and then use the niload command to add your host entries directly to NetInfo. This is especially helpful because you can copy a hosts table from some other machine on your network and use niload to import all of the entries for you.

Credit for this hint goes to bnenning, who posted it as part of a response to my Apple Slasdot posting.
  Post a comment  •  Comments (4)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[22,446 views] Email Article To a Friend View Printable Version
Share Appletalk printers over TCP/IP in 10.2 Network
I have a Linksys BEFW11S4 router/wireless access point which I use with two Airport equipped iBooks at home for wireless network access. It was only after I bought the Linksys that I found out that it doesn't support AppleTalk over the wireless network, only over Ethernet.

For most people, this wouldn't be an issue, but I have an Epson StylusColor 900N network printer, and unfortunately Epson's drivers (and those included in Mac OS X 10.2) only support network printing over Appletalk, even though the printer does support TCP/IP in Windows.

Upon upgrading my Macs to Mac OS X 10.2, I was pleased to find that not only does it include the Epson SC900N drivers in the OS, but also if I use one of my desktop Macs to share the printer, the iBooks on my wireless network can now print to it via TCP/IP (via the desktop). I can now print wirelessly and I only have to enable Appletalk on the Mac that is sharing the printer.

To enable Printer Sharing in Mac OS X 10.2, put a checkmark next to "Printer Sharing" in the Sharing preference pane. Any printers installed on the host Mac should then automatically appear in the Print Center window of any client Macs running 10.2 on the same network. Make sure you have "Show printers connected to other computers" enabled in the Print Center Preferences window.

Make sure you set the host Mac's Energy Saver settings to never go to sleep since clients won't be able to connect to printers shared by a sleeping Mac.
  Post a comment  •  Comments (6)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[18,445 views] Email Article To a Friend View Printable Version