Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.3: Restore internet printing from Windows Network
After upgrading to Panther, my Windows machines stopped being able to print to printers attached to my Mac. The Panther upgrade chose to overwrite the .conf files in /etc/cups, but left the printer PPDs in place. Here's what it took to fix it (or create a new one).

To create/restore IPP printers

  1. modify /etc/cups/mime.types and uncomment out application/octet-stream
  2. modify /etc/cups/mime.convs and uncomment out application/octet-stream
  3. Browse to http://localhost:631/printers and click Add Printer
  4. Provide Name, Location, Description of Printer, click Continue.
  5. Choose appropriate device type for printer. A USB printer should appear in the drop down list (e.g. DESKJET 970C (HEWLETT-PACKARD DESJKET 970C)). You can choose that and avoid having to create a the device URL. Click Continue.
  6. Choose Make and Model
Your new printer should now appear in the printer list. (It should also appear in the Printer Setup Utility in Panther as well). A new option in the Printer Setup Utility is to hide a printer from the print dialog shown during a printing. You can hide the printer to avoid confusion for local printer users.

To install the printer in Windows:

  1. Click "Add a Printer" in Printers and Faxes, then click Next
  2. Click "A network printer, or a printer attached to another computer", click next
  3. Click "Connect to a printer on the Internet or on a home or office network"
  4. Fill in the URL (i.e. http://w.x.y.z:631/printers/printer_name).
  5. Select the Manufacturer and Printer Model, and select Yes/No to make printer the default.
If printing fails, make sure that the Windows printer drivers are using the RAW print processor. Happy Printing!
  Post a comment  •  Comments (12)  
  • Currently 2.57 / 5
  You rated: 3 / 5 (7 votes cast)
 
[14,777 views] Email Article To a Friend View Printable Version
10.3: Resolve issues with 'other firewall software' Network
OK, this isn't much of a hint, but ... after I upgraded my iMac to Panther, I received an error when I tried to change my firewall settings through the sharing control panel that stated "other firewall software running." I have seen this posted to other forums as well. To resolve this issue, just delete Library -> Preferences -> com.apple.sharing.firewall.plist and reboot.

Boom, just like that things work again.
  Post a comment  •  Comments (10)  
  • Currently 2.67 / 5
  You rated: 4 / 5 (6 votes cast)
 
[13,729 views] Email Article To a Friend View Printable Version
Automount SAMBA (Windows) share points at boot Network
Today I was reading the wonderful tip on Automounting AFP and NFS Sharepoints at Startup, which is found on Mike Bombich's great Mac OS X site, and it occured to me that this might work for SAMBA (Windows) shares as well. I tried it, and sure enough, it does!

SAMBA sharepoints and standard Windows "shared directories" work in almost exactly the same way as AFP shares. The only difference is the URL that you use. If you want to dynamically mount a Windows (or SAMBA) sharepoint, follow the directions at Mike's site for a regular AFP Dynamic mount and replace the URL value with:

url==smb://username:password@servername/sharepoint
Where servername is either the IP address, hostname, or fully-qualified hostname (foo.example.com) of the machine that you would like to connect to, and where sharepoint is the shared directory that you would like to connect to.

In some cases, depending on the configuration of your network, this may not work. If that happens to you, try:


url==smb://Username:Password@Workgroup/servername/sharepoint
Note: I tested this on MacOS 10.2.8 and can make no promises or guarantees that it will work on any other version of OS X, but it worked for me. Because I have no reason to do so, I have not actually tested this with a static mount, only dynamic. The first URL I listed worked perfectly for me. However, in researching printing to SAMBA-shared printers, I saw many reports of a whole variety of different URLs working for some setups, and not working for others. I suggest that if the two URLs I provided don't seem to work for you, try variations on the theme, or search here for the tips related to printing to samba shared printers and SMB shares for ideas.
  Post a comment  •  Comments (19)  
  • Currently 2.00 / 5
  You rated: 2 / 5 (7 votes cast)
 
[184,919 views] Email Article To a Friend View Printable Version
A better way to connect Macs to a PC's shared Bluetooth Network
I saw this hint you have about sharing a PC's Internet with a Mac over Bluetooth. That's great, but it involves too much configuration and a terminal window login every time. Here's an alternative that "just works," mainly for owners of Symbian based phones.

The PC Suite software supplied with those phones has a server that hosts such connections over Bluetooth (and also IR and cables) for the phones, but it also works with other devices, like Palms and Macs. To make it work, do the following:

On the PC:
Right click on the mRouter tray icon and make sure Bluetooth serial ports are enabled.

On the Mac:
Make a new Bluetooth serial port, called something like Bluetooth-mRouter. Pair it with the Bluetooth Serial Port service on your host PC. Then set it to Outgoing and RS232 mode. Then load up the Network prefs panel, and configure the new port. Make sure it's using PPP. Under PPP options, you can safely deselect "Disconnect if idle." Under Modem, select Null Modem 115200 and deselect "Wait for dial tone."

Now use the Internet Connect menu, select the port you just made, and then select Connect. Hey presto, Internet sharing over Bluetooth. The only limit seems to be that although mRouter can handle up to 460000bps, the Mac Null Modem driver is capped at 115200, so if anyone wants to make a better Null Modem driver, please respond.

Finally, non-Symbian phone owners can download the PC Suite freely from Nokia or SonyEricsson, too. Install them and then remove everything except for the mRouter executable from their startup menu, and they're good to go.
  Post a comment  •  Comments (5)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[10,495 views] Email Article To a Friend View Printable Version
Ampersand sign in file names causes Bluetooth problems Network
I am sharing files with a colleague at the office over Bluetooth. We both have the same Mac, and are up to date with all software.

When he tries to look at a folder that contains files whose name contain an ampsersand sign, the folder just appears empty. It took some time to track that down, but we could eventually easily reproduce the behavior just by adding or removing the ampersand from a file name.

I could not find any reference to this issue describing it as normal, so, to me it's a bug.
  Post a comment  •  Comments (1)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[2,822 views] Email Article To a Friend View Printable Version
Reset network to renew DHCP when changing locations Network
When changing locations in Network via System Preferences and the DHCP service does not provide directly a new IP address, one does not need to restart the computer. A network reset suffices. This can be given via the terminal:
% sudo /System/Library/StartupItems/NetworkExtensions/NetworkExtensions stop
% sudo /System/Library/StartupItems/NetworkExtensions/NetworkExtensions start
A tcsh "Network-restart" script can be easily put into ~/bin to make this easier. Make the script executable with chmod +x Network-restart. Here's the "Network-restart" script:
#!/bin/tcsh -f
#
# aim:      restart network
# usage:  Network-restart

sudo /System/Library/StartupItems/NetworkExtensions/NetworkExtensions stop
sudo /System/Library/StartupItems/NetworkExtensions/NetworkExtensions start
[robg adds: I haven't tested this one.]
  Post a comment  •  Comments (13)  
  • Currently 1.50 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[11,443 views] Email Article To a Friend View Printable Version
Make Macs appear in Windows' Network Neighborhood Network
I'm sure there are many other ways of doing this, but ... after hours of frustration trying to get a new Toshiba laptop running WinXP Home Edition to see our Linux Server and my OS X Ti-Book on our office network through the Network Neighborhood, I finally called in a UNIX guru friend of mine who suggested the following.

Open the Registry on the Windows machine (just type "regedit" from the "Run" command"). Then adjust the following Entry:
\HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \
  lanmanworkstation \ parameters \ enableplaintextpassword
Change the default "Value Data" field from 0 to 1. Restart Windows and Voila! The Linux and OS X machines show up in the Windows network neighborhood.

[robg adds: In order to get my machine to show up at work, I just used Directory Access (in /Applications -> Utilities) to set a matching Workgroup name, and all was good from that point. But I have heard that this hasn't worked for others, so maybe this hint will help.]
  Post a comment  •  Comments (5)  
  • Currently 1.50 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[9,138 views] Email Article To a Friend View Printable Version
Print from OS 9 to an OS X network printer via AppleScript Network
I've tried for quite some time to get my files to print from my wife's iBook (clamshell) running OS 9.2 to the Epson Inkjet or HP Laserjet 4 on our network. The HP is directly connected to the ethernet hub and the Epson is connected to the OS X iMac via USB. I've tried using this hint, but it doesn't work, and I scoured the internet with no result. Yet, there is a simple, if not particularly elegant, way.

I've written a very simple AppleScript and attached it to my drop box folder on the OS X machine. I've placed an alias of the drop box on the desktop of the OS 9 machine (set to appear on start up). When the user of the OS 9 machine drops a file into the drop box, the Applescript is activated and the finder prints the file to the default printer.

Read the rest of the hint for the how-to...

read more (338 words)   Post a comment  •  Comments (7)  
  • Currently 2.33 / 5
  You rated: 1 / 5 (3 votes cast)
 
[8,689 views] Email Article To a Friend View Printable Version
A workaround for AirPort/Wifi unusable after wake from sleep Network
Finding your WiFi/Airport connection broken after your machine wakes from sleep?

It appears that, with some non-Apple base stations where the Mac is using DHCP, it can forget its IP address during sleep, but does not request a new one. The best solution is to switch to using a fixed IP address, as even turning AirPort off then reconnecting to the network has little effect.
  Post a comment  •  Comments (3)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[6,833 views] Email Article To a Friend View Printable Version
Enable/disable wake on admin access in 10.2.8 Network
I just updated to 10.2.8 and, at least on my laptop, the old checkbox in the Energy Saver pane for enabling and disabling 'Wake on admin access' is gone ... but ... we can still use pmset.

So, here is how to enable wake on admin access:
sudo pmset womp 1
To disable it:
sudo pmset womp 0
BTW, womp stands for "wake on ethernet magic packet."

[robg adds: This is the first I've heard of losing the Network Admin checkbox with 10.2.8 -- can anyone else confirm? It's still there on our G3/500 and PowerBook...]
  Post a comment  •  Comments (24)  
  • Currently 3.00 / 5
  You rated: 3 / 5 (4 votes cast)
 
[8,675 views] Email Article To a Friend View Printable Version