Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Windows 2000 VPN connections and Linksys routers Network
I found that connections to a Windows 2000 Server VPN from Mac OS X 10.2.8 or 10.3 were all failing to negotiate. I could connect to the VPN via VirtualPC with MS Windows running on the same computer.

The solution turned out for me to apply firmware 1.44 to my Linksys BEFSX41. The most recent version (1.45.3) of the firmware apparently does something to prevent the VPN from working on the Mac.
  Post a comment  •  Comments (0)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[3,088 views] Email Article To a Friend View Printable Version
Watch folder name endings when using Windows shares Network
Recently, I was using SMB to send a folder from my PowerBook over to a Windows 2000 machine. Unfortunately, when I tried to access the folder from the Windows computer, I received messages telling me the folder was not accessible. I assumed something had gone wrong in the copy, but when I tried to get rid of it, I got the following error:
Cannot Delete File: Cannot Read From The Source File Or Disk
No amount of effort would let me get at, or get rid of, the folder. Windows knew it was there, but wouldn't let me at it. It turns out the problem was that the folder name ended in a period, and Windows hates that. It hates it so much, in fact, that it wouldn't even let me rename the file to fix the problem.

The solution? Rename the file from the Mac side. I remounted the volume, removed the period, and the problem was solved.

  Post a comment  •  Comments (0)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[2,227 views] Email Article To a Friend View Printable Version
VPC 6.1 and OS X networking together on a PowerBook G4 Network
Discovery through adversity once again. After applying the AirPort 3.2 update on my Powerbook G4 1GHz (sans-AirPort extreme), I discovered Virtual PC 6.1 with virtual switch (DHCP) could no longer "see" Mac OS X and vice-versa, both on the AirPort interface logged into an AirPort network. This lead to desperate experimentation that panned out.

Caveat: no testing beyond my experience of AirPort 3.2 update / Panther / VPC 6.1. AirPort card and built-in Ethernet required. Mileage probably will vary.
read more (219 words)   Post a comment  •  Comments (7)  
  • Currently 4.00 / 5
  You rated: 5 / 5 (4 votes cast)
 
[14,220 views] Email Article To a Friend View Printable Version
Prevent sharing of Drop Box Network
The amount of free space on my 40 GB hard drive has been continuously decreasing since I bought it, so I decided to go through and delete space wasters. I began my search by looking for exceptionally large files/folders. It was then that I discovered 8 GB of junk in my publicly-available Drop Box.

Someone on my residence hall's network was using my Drop Box as free storage space for illegal copies of copyrighted works. After I finished watching Kill Bill and Texas Chainsaw Massacre, I promptly set about patching my newfound security hole:
  1. Purge Unwanted Files — Your drop box can be found at ~/Public/Drop Box.
  2. Change Permissions - With the Drop Box folder folder selected in the finder, press COMMAND+I to show information for your Drop Box. In the window that appears, change the setting for Others to "No Access." If it is hidden, the setting can be found in the Ownership & Permissions section.
Although my free space is still dwindling, the 8 gigs I recovered will be more than enough to get me through the month.
  Post a comment  •  Comments (11)  
  • Currently 3.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[9,561 views] Email Article To a Friend View Printable Version
10.3: Personal ipfw firewall configuration startup items fix Network

I am used to manually configuring the ipfw firewall since 10.1. As reported in various sites on the net, I created an /etc/ipfw.conf file with all the rules I wanted. I also created an ipfw directory under /Library/StartupItems/, in which I placed two files: ipfw, containing these lines:

 #!/bin/sh
 /usr/sbin/sysctl -w net.inet.ip.fw.verbose=1
 /usr/sbin/sysctl -w net.inet.ip.fw.verbose_limit=500
 /sbin/ipfw -q /etc/ipfw.conf
and StartupParameters.plist, containing these lines:
  {
    Description = "ipfw firewall";
    OrderPreference = "None";
    Provides = ("Firewall");
    Requires = ("Resolver");
    Messages =
    {
      start = "Sto avviando il firewall";
      stop = "Sto disattivando il firewall";
    };
  }
In Panther, this configuration stopped working. At the login window, the beach ball started to spin indefinitely and I had to reboot in single user mode and disable the ipfw startup item. Finally, I changed Requires = ("Resolver"); to Requires = ("Super Server");, and now it works again. I tried several reboots without any problems -- I can login and the ipfw rules I defined are active.
  Post a comment  •  Comments (10)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[21,649 views] Email Article To a Friend View Printable Version
10.3: Create a system backup on a Windows machine Network

This hint is the result of a successful attempt to use Carbon Copy Cloner to back up my system drive to a shared Windows mount. Back when I had 10.2, I tried several times to use Disk Copy to create a disk image on a mounted NTFS Windows folder via OS X's built-in Samba. The creation process always stalled out after a half Gig or so out of the 10 Gig image I was trying to make. But this time around, with Panther using Disk Utility, I saw the option to create a sparse image. So I went ahead like I did before and tried to create a 10 Gig Image on my mounted Windows share, and it worked. Disk Utility created the sparse image in less than a minute, and the "10 Gig" image only occupied 137Mb of disk space.

Now, when I started up Carbon Copy Cloner, the image I just created was available as a "Target Disk." There were a few glitches along the way, some type of error about a corrupt movie or something, but CCC gave me the option to continue. I got the complete disk clone to work on the second try, because during the first try my iBook went to sleep so I had to change the power settings to "Best Performance".

Maybe people have been doing this with Jaguar, and I didn't see any hints, but I think this is a great way to back up a laptop without having to buy a FireWire drive.

  Post a comment  •  Comments (1)  
  • Currently 1.71 / 5
  You rated: 2 / 5 (7 votes cast)
 
[9,416 views] Email Article To a Friend View Printable Version
10.3: A fix for printer sharing between 10.3 and 10.2 Network
After upgrading to Panther, I observed that my printer no longer appeared in my wife's iBook as a shared printer. It used to in Jaguar.

After searching the reasons for this, I diagnosed a problem with Internet Sharing with only one internet adapter. My iMac's IP was supplied via DHCP by the cable modem, causing the printer address to be in a different subnet than that of my private network (192.168.x.x). Even though my iMac acknowledged ping packets with the 192.168.2.1 address, it bound the the imac.local name to the cable supplied IP.

The solution was to create another Ethernet port in the Networking section of the System Prefs, bind it to Built-in Ethernet, and assign it to a manual address (I used 192.168.2.10, but it could be anything inside your private subnet). I also had to edit the cupsd.conf file in /etc/cups/, and change the ServerName variable to this new address.

Now Rendezvous can find this printer in the local subnet.
  Post a comment  •  Comments (0)  
  • Currently 2.43 / 5
  You rated: 5 / 5 (7 votes cast)
 
[10,644 views] Email Article To a Friend View Printable Version
10.3: Easy auto-mounting of server shares Network
This is so simple its stupid, but I wasted a while trying to figure it out. There are hints up here about automounting servers using netinfo tinkering. I wanted an easier way to config several macs to automount servers in Panther.

Ready?

Startup Items in the Accounts pane of System Preferences. Just drag server icons from your desktop into the window like you would any application you want to run at startup. That's it. Not sure if it worked that way before 10.3. As a bonus, use the Add Password to Keychain in the Options when you connect and you wont have to type passwords next time either.

[robg adds: Wow, this should make a lot of people pretty happy -- we've run eight previous hints on automounting server volumes! I tested it from my PowerBook with a Personal File Sharing share, and sure enough, it worked as described.]
  Post a comment  •  Comments (11)  
  • Currently 2.00 / 5
  You rated: 3 / 5 (7 votes cast)
 
[18,698 views] Email Article To a Friend View Printable Version
10.3: Enable AppleTalk server browsing Network
For some reason, Panther's ability to browse a network for AppleTalk servers is turned off by default. To turn it back on, go to Applications -> Utilities -> Directory Access, and put a check in the box next to AppleTalk (you'll need to click the lock icon and enter your admin password first).
  Post a comment  •  Comments (20)  
  • Currently 2.00 / 5
  You rated: 4 / 5 (7 votes cast)
 
[16,586 views] Email Article To a Friend View Printable Version
10.3: Add IP over FireWire networking Network
All I can say is check out the Network Preference Pane and go to Network Port Configurations.

[robg adds: And I'll add a bit more ... click on New, and you can then select "Built-in FireWire" and add it to use IP over FireWire. THere's also a "6 to 4" item, but I have no idea what that's for.]
  Post a comment  •  Comments (16)  
  • Currently 1.67 / 5
  You rated: 5 / 5 (6 votes cast)
 
[26,756 views] Email Article To a Friend View Printable Version