Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.3: A possible workaround for accessing localhost Network
If you're using a local proxy (Squid, Privoxy, Authoxy, ...) and you're having problems with download errors (outright failures, broken image icons, ...) under Panther, change your proxy settings to 127.0.0.1 instead of localhost.

There appears to be a problem with broken pipe errors somewhere in CoreFoundation, so any app that uses CoreFoundation to do its networking (Safari and NetNewswire, for example), will exhibit this problem. Camino is not affected by the problem.
  Post a comment  •  Comments (5)  
  • Currently 2.17 / 5
  You rated: 5 / 5 (6 votes cast)
 
[10,772 views] Email Article To a Friend View Printable Version
10.3: Connecting a Mac and a PC via IP over FireWire Network
Last night, I was able to successfully connect my Panther iBook to my PC via a 400 Mbit FireWire connection. Extending on a previous hint, here's how you do this. You'll need 10.3 on the Mac and Windows XP with a FireWire card (and likely, a 6 pin to 6 pin FireWire cable):
  1. Make a new network location in System Prefs (Network Port Configurations -> New, FireWire). I called mine "Direct Connection (FireWire)."
  2. Set the location to have a manual IP address; I choose 10.0.0.1 with a subnet of 255.255.255.0.
  3. Disable all of the other ports on the Mac; i.e., only have FireWire enabled.
  4. Turn on FTP Sharing in the Sharing system pref (in my experience, only this yields reliable, fast transfers).
  5. On the PC, right-click on My Network Places, go to Properties, and right-click on LAN and choose Properties. Change the IP address to 10.0.0.2, and the subnet to 255.255.255.0.
  6. Connect the two computers via the cable directly.
  7. On the PC, open up your FTP client and go to 10.0.0.1/your short username. I suggest using Active mode rather than Passive as the latter always times out.
  8. Transfer away!
I copied 1.1 GB of data last night in about three minutes; the transfer speed held steady at a speedy 5 MB/sec! Just remember to change the Location on the Mac and settings on the PC back to what they were when you were done.
  Post a comment  •  Comments (14)  
  • Currently 1.71 / 5
  You rated: 2 / 5 (7 votes cast)
 
[69,448 views] Email Article To a Friend View Printable Version
Create NSF backups on a UNIX server Network
If you need to do networked backups on Mac OS X systems 10.2 and above, it is possible to use NFS mounts. Open NetInfo Manager (in /Applications -> Utilities) and create a new folder under mounts, then include the following properties:
  • opts : -P -c
  • type : nfs
  • dir : /users/username/folder
  • name : server.domain:/path/to/the/export/dir
Make sure the server allows NFS mounts and that the directory in the user's home is created before setting up the mount. The only problem is that the find command won't work on the NFS mount.
  Post a comment  •  Comments (7)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[6,799 views] Email Article To a Friend View Printable Version
10.3: Disabled AUTOMOUNT causes browsing issues Network
After installing Panther I found that, although I could connect to remote servers via IP addresses, the Network Browser did not find any servers on our LAN. I traced the problem to a change that I made in the /etc/hostconfig file.

The background: Several months ago, one of our MacOS X 10.2.x remote server volumes could no longer be unmounted from some of our Jaguar clients. Mounted volumes from this server could only be removed by logging off or restarting. A hint from the excellent 'Mac OS X Unleased (2nd Ed)' by John Ray and William C. Ray suggested AUTOMOUNT may have been the cause. AUTOMOUNT is active by default, but can be deactivated in the /etc/hostconfig file. I deactivated AUTOMOUNT using the pico text editor by entering: sudo pico /etc/hostconfig and changing AUTOMOUNT=-YES- to AUTOMOUNT=-NO- and saving and restarting. This solved the unmountable volume problem and browsing the LAN worked under Jaguar.

Installing Panther broke my network browsing. After struggling with the lack of this feature, I recalled my changes to hostconfig. Again using pico, I edited hostconfig and changed AUTOMOUNT back to the default -YES-. After restarting, network browsing again functions under my Panther installation. Apparently, network browsing is implemented differently under Panther, and AUTOMOUNT must be active for it to function.
  Post a comment  •  Comments (9)  
  • Currently 2.00 / 5
  You rated: 3 / 5 (6 votes cast)
 
[13,630 views] Email Article To a Friend View Printable Version
An odd workaround for a failed wireless connection Network
So I lost my Airport connection - don't ask. Sun spots. No way the GHz Titanium was going to get on web. All settings good to go, Network Preferences showed Airport connection. Safari said different. I've worked with this before, maybe because I have a third-party base station/router, and knew it was just a matter of jiggling something somewhere. Recursive troubleshooting. When Network Prefs doesn't work, Airport Setup Assistant, setting everything to Automatic, usually does. Has to be Automatic though. Forget setting TCP yourself.

This time, nothing. Various power cycling and cursing later, it occurred to me, Okay, how can we get even more basic. In /Sysmtem -> Library -> Core Services, that's where Setup Assistant lives -- and you can run it right from there. Instantly on the web. No visible changes to any settings, but Panther's happy, and that's what mattters.
  Post a comment  •  Comments (7)  
  • Currently 3.20 / 5
  You rated: 5 / 5 (5 votes cast)
 
[15,722 views] Email Article To a Friend View Printable Version
10.3: Upgrade AirPort to avoid lost WEP keys Network
If you are on a wireless network that's (a) not broadcasting it's SSID, and (b) uses WEP, there's a bunch of matters that'll give you grief. Every time you reboot, you'll lose the airport connection -- even if you have your location set to connect to a specific network, the system just doesn't remember the base station, and re-entering a 128bit HEX key everytime is a pain (copy-paste doesn't work).

To remedy this, install the AirPort 3.2 update from Apple. As far as I can tell, it's not part of Software Update. Then re-create your location with the specific network and key. Now the machine remembers the network, key, etc and the AirPort unhappiness is gone.
  Post a comment  •  Comments (5)  
  • Currently 1.86 / 5
  You rated: 2 / 5 (7 votes cast)
 
[13,487 views] Email Article To a Friend View Printable Version
Connect a Palm to a LAN via USB cable Network
There's a splendid program out there called USB-TCP Bridge that takes everything that comes from the USB port and reroutes it to a TCP connection. And vice versa of course -- everything that comes from that TCP connection will be sent to the USB port. This makes it possible to connect a Palm with a USB interface (Zire for example) to a network via a host computer that runs USB-TCP bridge, pty-redir and pppd.

First of all, download USB-TCP Bridge and pty-redir via the above links. Start USB-TCP Bridge and set it up to:
  • Listen on USB and connect to TCP port
  • USB connection type: should be set to "Serial emulation"
  • TCP Port: shoudl be set to 22000.
Press "Start Bridge," and (as written in the app), "You may need to deactivate HotSync before activating the bridge." Decompress pty-redir and run make in the Terminal to compile it. Then run it with:
./pty-redir nc -l -p 22000
This will reroute incoming traffic from port 22000 to a device. pty-redir will print out which device it's going to use -- /dev/ttyp0 or something like that. Next, start pppd on that device:
pppd /dev/ttyp0 115200 10.0.0.1:10.0.0.2 noauth proxyarp
Replace the IP numbers with whatever you are using on your network. Now your connection will be all set to go, just configure your Palm to use USB and connect.

Strong Warning: This hint might jeopardize the security of your network, due to the fact that anyone can connect to your host computer on port 22000 to gain access to your network.
  Post a comment  •  Comments (4)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[13,850 views] Email Article To a Friend View Printable Version
How to set up Active Directory Network
I've seen a lot of people asking how to setup Active Directory (AD), so I thought I'd post my setup which works. This assumes you have a working AD tree, properly configured DNS, and an account that can add computer objects to AD. Here's what the plug-in configuration looks like in Directory Access (located in /Applications -> Utilities):
  • Active Directory Forest: forest.company.net
  • Active Directory Domain: mydomain.forest.company.net
  • ComputerID: mycomputer
You can make the forest the same as the domain if your users don't need to access resources outside the domain. I found this also speeds up authentication in some cases. When you click on Bind..., you have to enter a username and password that has rights to add computers. The format is just:
username
password
Advanced Settings:
  • Turn on the account cache if the computer will be used offline.
  • Turn on multiple domains if users need to access multiple domains
  • If you have more than one domain controller, you can specify the one you want to use: pdc.mydomain.forest.company.net
  • Map a UID: If you don't know what this is leave it alone.
  • Allow administration by: you can put an AD group name here and anyone in that group is added to the local admin group in netinfo.
Select OK, quit Directory Access, reboot.
  Post a comment  •  Comments (26)  
  • Currently 2.43 / 5
  You rated: 2 / 5 (7 votes cast)
 
[46,761 views] Email Article To a Friend View Printable Version
Automatically change network locations with a cron job Network
I've gotten tired of having to change my location every time I open my notebook at home or at school/work. So I have adjusted my crontab as follows:

 0      8       *       *       1,2,3,4,5       scselect School
 40     14      *       *       1,2,3,4,5       scselect Home
Translated, I have it change my network location to School every weekday at 8 AM (the time I'm scheduled to be at school) and back to my Home location when I'm expecting to be home from school.

The only catch is that I don't think this will execute when my computer is asleep (unless this changed with Panther), so I used Fink to install anacron which executes cron commands as soon after their scheduled times as possible, rather then right at the scheduled time.
  Post a comment  •  Comments (8)  
  • Currently 2.40 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (5 votes cast)
 
[6,877 views] Email Article To a Friend View Printable Version
Using ARD and ssh for secure remote administration Network
I have a few headless servers that I maintain with Apple Remote Desktop (ARD) over the Internet. This is not a tutorial on ARD or ssh, but a way to put simple tools together to make things more secure. I don't fully trust the ARD protocol, so I don't want to leave the port open. It is not possible to use ARD over ssh because ARD uses UDP packets that ssh can't forward the same way IPSec tunnels allow to. But IPSec tunnels can be a pain to configure and maintain, and are certainly not within reach of everyone. The servers all sit behind AirPort base stations set to only forward port 22 (ssh) to them. The ssh daemon is running on all servers.
  1. Create a tunnel using the following command:
    
    ssh -L 5009:10.0.1.1:5009 root@server-nnn.dyndns.org
    
    Where:
    • 10.0.1.1 -> private IP address of the base station.
    • server-nnn.dyndns.org -> public IP address of the base station, maintained using the DNSUpdate tool.

  2. Use the Airport Admin Utility to connect to localhost and reach the remote base station.

  3. Turn on forwarding of port 3283 on the base station.

  4. Connect directly via ARD to the public address server-nnn.dyndns.org.
When done, remove the forwarding of port 3283 on the base station. Easy!
  Post a comment  •  Comments (11)  
  • Currently 1.67 / 5
  You rated: 3 / 5 (3 votes cast)
 
[12,000 views] Email Article To a Friend View Printable Version