Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Print from OS X to other Unix CUPS spools Network
If you set up an IPP printer through Printer Setup Utility, remote locations will be in the form of ipp://hostname:631/ipp/queuename. However, generic CUPS uses ipp://hostname:631/printers/queuename. You can set it up this way using the Terminal:
lpadmin -p local_queue -v ipp://hostname:631/printers/queuename
Current settings can be listed with lpstat -v. Of course, you have to change hostname, queuename, and local_queue to the actual values for your system.
  Post a comment  •  Comments (0)  
  • Currently 2.20 / 5
  You rated: 1 / 5 (5 votes cast)
 
[17,785 views] Email Article To a Friend View Printable Version
Enable Rendezvous services on Linux Network
I think there were previous attempts at this before, but I've put up a complete how-to detailing the installation of a Rendezvous responder on Fedora Linux (or any other Linux, actually) at my site.

[robg adds: I realize this isn't an OS X Hint by any definition, but I also know many of you work in mixed Linux/Mac environments, so I thought it might be useful.]
  Post a comment  •  Comments (5)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[2,850 views] Email Article To a Friend View Printable Version
Avoid P800 iSync Bluetooth connection failures Network
I recently convinced the office to buy me a P800 (no I didn't think it would work either, but I ended up with two!) to write software with (I use and emphatically recommend MobileVB from AppForge). Coincidentally, I could also use it for syncing with my Mac.

However, I was continuously plagued with mysterious dropped connections during the "connecting to " phase. No rhyme or reason, resetting, turning wi-fi on or off, location or distance made it better. Then one day, I tried syncing a second time, and it worked! What was the trick? I have the "auto keylock" preference turned on. After I realized the only difference was that the keypad was opened during the successful sync, I now manually lock the keys and leave the keypad open during a sync and have 100% reproducibility of "good" syncs! Hope this helps someone as much as others' hints have helped me!
  Post a comment  •  Comments (8)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[6,067 views] Email Article To a Friend View Printable Version
Enable and disable Airport from the command line Network
If for some reason you want to turn off your Airport Extreme Card from the command line, simply type:

sudo ifconfig en1 down
Where en1 is the interface for your Airport Extreme Card. en0 is usually Ethernet, and en1 is usually the Airport Extrewme card. To bring it back up, just type:

sudo ifconfig en1 up
Enjoy!
  Post a comment  •  Comments (7)  
  • Currently 2.75 / 5
  You rated: 2 / 5 (8 votes cast)
 
[39,218 views] Email Article To a Friend View Printable Version
Send popup messages to Windows users Network
A nifty trick to make messages pop up on the screens of Windows users on your network. Just type the following into the terminal:
 smbclient -M NETBIOSNAME -U FROMNAME 
The -U FROMNAME part is optional but it adds a nice touch to the message. The NETBIOSNAME is just that. It is NOT the DNS name of the computer (although on some networks it can be). After you make a connection you type your message, press return and then control-D. It will immediately appear on the screen of your targeted Windows user. The advantage to doing this from a Mac (or other *nix box) as opposed to a Windows PC is that you can specify the "from" user, which I don't *think* you can do from Windows. Please use responsibly.
  Post a comment  •  Comments (33)  
  • Currently 3.83 / 5
  You rated: 4 / 5 (6 votes cast)
 
[112,281 views] Email Article To a Friend View Printable Version
Specify the domain in SMB login strings Network
My default Workgroup in the Windows domain does not equal my login Workgroup. I found that you can specify Workgroup (along with user ID) in the SMB connect to string. For example:
 smb://WORKGROUP;machine.somewhere.com/Share
This works to specify WORKGROUP for login. This can be expanded to:
 smb://WORKGROUP;User@machine.somewhere.com/Share
I hope this helps! It has taken me a very long time to find this. With this, and Add to Keychain, I can now connect without entering the password! Before, since the WORKGROUP was wrong, it prompted me for password.
  Post a comment  •  Comments (10)  
  • Currently 3.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[29,474 views] Email Article To a Friend View Printable Version
10.3: Use 10.2's Connect to Server dialog via AppleScript Network
It is possible to get the old Jaguar-style Connect To Server... window in Panther via applescript. This script will present the old-style window:

 tell application "Finder"
   open location (choose URL showing File servers with editable URL)
 end tell

Load into Script Editor.

Not sure if this is useful, but it's interesting.

  Post a comment  •  Comments (11)  
  • Currently 2.43 / 5
  You rated: 4 / 5 (7 votes cast)
 
[18,896 views] Email Article To a Friend View Printable Version
10.3: Strange DNS behavior and workaround Network

Sometimes, when trying to get to a web site, I'd get redirected to a strange location. I thought perhaps I was getting hijacked or something. After spending some time analysing the problem with Ethereal, I came to the conclusion that Panther does strange things with DNS resolution. This didn't happen before in Jaguar, so I'm pretty sure it's a Panther thing. Since I spent a few hours banging my head on the wall before figuring it out, I thought I'd share with everyone and save you the frustration.

Like many companies, my company uses a different domain name for DHCP to help local users find servers that aren't available outside the firewall. We use 'company.org' for this purpose, where the real domain name is 'company.net'. If Panther fails a DNS lookup, it tries appending the default domain name to the end of the request. So, if I mistyped "foo.com" as "fooo.com," it would fail and then look up "fooo.com.company.org" -- this is pretty standard behaviour.

But then Panther does something strange - it tries appending just the top-level domain for the lookup -- it looks up 'fooo.com.org,' and since 'com.org' goes to a company that does web domain stuff, it looked like a hijacking.

If it was just mistyped domains, that would be no big deal. However, this also happens if your DNS server just happens to drop the ball on something like 'mail.yahoo.com' for example -- and once it happens, OS X caches it for quite a while. I couldn't figure how to turn this behavior off. Doing sudo killall lookupd will reset the cache though, which should fix it if the DNS server is working again.

I spent quite a while hunting this down, so I thought it might help someone.

  Post a comment  •  Comments (8)  
  • Currently 2.00 / 5
  You rated: 4 / 5 (7 votes cast)
 
[24,467 views] Email Article To a Friend View Printable Version
10.3: Share a Panther printer with OS 9 Network
Previous hints (Share a non-PostScript USB printer with OS 9, Access 10.2 shared PostScript printers from OS 9) detailed how to extend Mac OS X's printer sharing with Classic (OS 9) Macs. The process is now much simpler. The instructions for setting up cups-lpd on the server are no longer necessary -- Panther is already set up to share printers via the lpr protocol.

I have an old LaserJet 6P that was made for Windows: no Postscript, no USB (parallel port instead), no Ethernet, no print server built in. Nevetheless, this solution allows me to print to the 6P, in Postscript, from any Mac. Apple has done most of the work: the GimpPrint drivers (now built into Panther) drive the printer and the Ghostscript software (also in Panther) peforms the Postscript interpretation that the printer lacks. The LaserJet itself is connected via a USB-to-parallel cable. The steps you need to take are:

  1. On the Panther Mac that the printer is physically connected to, you need to find out the printer's CUPS name. You can do this by typing lpstat -v in Terminal, or through the CUPS web interface. If you use lpstat -v, the name is the first part of the line listing the printer. For me it was HP_LaserJet_6P.

  2. Use the Desktop Printer Utility on the OS 9 Mac to setup an lpr printer. Use the "Generic" PPD. The "Printer Address" is the IP address of your server, and the "Queue" is your USB printer's name.
P.S. - This hint will work for any computer that can print via the lpr protocol, not just Mac OS 9.
  Post a comment  •  Comments (25)  
  • Currently 2.86 / 5
  You rated: 5 / 5 (7 votes cast)
 
[46,132 views] Email Article To a Friend View Printable Version
Use rdesktop to connect to Windows Terminal Services Network
I work in a hybrid environment that has Microsoft Windows server with Terminal Server running. To access these servers from my Mac, I downloaded and compiled rdesktop. X11 is required, and I believe the SDK is also required for compilation. Then to execute and start a desktop with a Terminal Services enabled Windows server, I simply type:
  rdesktop server
and there you have it (please make sure your display is set correctly for X11!). Here is an output of the options for the rdesktop command:

% rdesktop 
rdesktop: A Remote Desktop Protocol client.
Version 1.2.0. Copyright (C) 1999-2003 Matt Chapman.
See http://www.rdesktop.org/ for more information.

Usage: rdesktop [options] server[:port]
   -u: user name
   -d: domain
   -s: shell
   -c: working directory
   -p: password (- to prompt)
   -n: client hostname
   -k: keyboard layout on terminal server (us,sv,gr,etc.)
   -g: desktop geometry (WxH)
   -f: full-screen mode
   -b: force bitmap updates
   -e: disable encryption (French TS)
   -m: do not send motion events
   -C: use private colour map
   -K: keep window manager key bindings
   -T: window title
   -D: hide window manager decorations
[robg adds: I haven't tried to compile rdesktop myself...]
  Post a comment  •  Comments (12)  
  • Currently 2.00 / 5
  You rated: 3 / 5 (4 votes cast)
 
[27,173 views] Email Article To a Friend View Printable Version