Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Configure a networked HP LaserJet 2100 via telnet Network
The HP utilities for configuring JetDirect 600N (as used in LaserJet 2100 and others) only run under Windows. The web based configuration utility is not supported on Macs. However, once the DHCP assigned IP address is known (print a test page), you can use telnet to set the IP address and other settings. To access the printer:

telnet 198.162.0.5
Then, to see the current settings:

/
For help:

?
And then, for example, to set the IP address:

ip:192.168.0.100
Hope this helps!
  Post a comment  •  Comments (11)  
  • Currently 3.67 / 5
  You rated: 5 / 5 (6 votes cast)
 
[30,111 views]  View Printable Version
10.3: Another fix for SMB printing Network
I could not print to SMB printer from my OS X for quite a long time. It used to terminate printing with the errors:
Unable to connect to SAMBA host, will retry in 60 seconds
Connection failed with error NT_STATUS_UNSUCCESSFUL
It was too frustrating .. and no pointers on the net helped. So, I started poking around, found /etc -> cups -> printers.conf file. The URI was quite wrong for the SMB printer, and that was the reason it did not print. So, I created printers.conf with the following:

<DefaultPrinter printer>
  Info HP
  Location MYDOMAIN
  DeviceURI smb://ramprasad:jmypass@mydomain/myprintserver/HP
  State Idle
  Accepting Yes
  JobSheets none none
  QuotaPeriod 0
  PageLimit 0
  KLimit 0
</Printer>
Now, I restarted cupsd and it started working fine ... Panther rocks (I could never do such a thing in Windows).
  Post a comment  •  Comments (9)  
  • Currently 1.38 / 5
  You rated: 2 / 5 (8 votes cast)
 
[24,228 views]  View Printable Version
Use LEAP without continual password re-entry Network
If you find constantly entering the LEAP password a pain, I've found a way to at least store the settings. It doesn't look like it auto-reconnects on wakeup, but I guess it's better than having to enter the password etc. after each interruption (i.e. sleep).

Open Internet Connect (last item on the Airport Menu). Select the Network Location for your LEAP Environment, or create a new one. The settings you enter in Internet Connect will be associated with a specific Network Location, so be sure you have the one you use in your LEAP environment active. From Internet Connect's File menu, select New 802.1X Connection. A new icon Labeled "802.1X" will appear in the toolbar of the Internet Connect main application window.

Select the 802.1X Icon, if it isn't already selected. Next to Configurations, select Edit Configurations from the pulldown menu. In the sheet that is revealed, enter the settings for your LEAP Network, and name it something appropriate in the description. I left the default Authentication Protocols selected, although I suspect LEAP is the only one you actually need. Click OK to save the configuration.

Now, if your newly created 802.1X configuration is selected, all of the particulars (Username, Password, Wireless Network) should be populated. Click "Connect" and you're golden.
  Post a comment  •  Comments (5)  
  • Currently 3.00 / 5
  You rated: 3 / 5 (4 votes cast)
 
[9,490 views]  View Printable Version
Brother HL 1440, SMC Barricade 7004 and Netgear 614 Network
I finally went wireless and had a difficult time integrating my Netgear wireless router, SMC Barricade router with print server, and Brother HL-1440 printer. What I ended up doing was using the wireless as the router/gateway and connected a regular Ethernet cable from the wireless port to the Barricade (not the WAN port). The Netgear auto-senses the connection, so you don't need a crossover cable. I then assigned the Barricade an IP address in the same range as the Netgear (temporarily connect the Barricade directly to a computer to set the IP address).

Then, with both devices off, I connected the parallel cable to the printer and Barricade. Turned the Barricade on and then the printer. Set up the printer on the Mac (AlBook in this case w/ 10.3.2) just like described in this hint, except that I chose "HP LaserJet II series, CUPS+Gimp-Print v4.2.5" as the printer model and left everything else the same.

Works great and I found a use for a router/print server I thought was finding its way to the storage box of miscellaneous junk. All I had to buy was a $5 parallel cable. You could also set up the Barricade as the main router/gateway and set the Netgear up as an access point if you wanted.
  Post a comment  •  Comments (0)  
  • Currently 1.50 / 5
  You rated: 2 / 5 (4 votes cast)
 
[8,529 views]  View Printable Version
Use FTP for faster file sharing with Windows Network
I've been a good little Mac head and did the 'obvious' thing to share files between my PC (running XP home) and my G4 PowerBook (10.3.2): I started "Windows Sharing" on the Mac side. It's a bit touchy and things don't always work, but in general, I can find my Mac from the PC (using an IP address only; browsing from the PC doesn't work) and copy files from the PC to the Mac. The only problem: it is SLOW. Things often start very fast but after about 50MB, it bogs down and starts to crawl. I'd like to understand this issue in more detail but that isn't really the point of this tip. I've found a fairly good workaround: use FTP.

I downloaded a free FTP client for my PC (I happened to use FileZilla which is OK but it has a confusing UI), turned on FTP sharing on my Mac and found that what used to take 20 minutes to copy, I can now copy in under 50 seconds! This certainly isn't going to be easy for newbies, as an FTP client like FileZilla can be a bit intimidating, but once you get it setup, it is very fast.

Any comments on making PC/Panther file sharing better would be appreciated as that is the real problem (I searched the hints but couldn't find anything).

[robg adds: I thought we had previously run a hint on using FTP for Mac/PC file transfers, but I can't find it this morning ... so apologies if this is a duplicate.]
  Post a comment  •  Comments (15)  
  • Currently 2.33 / 5
  You rated: 3 / 5 (6 votes cast)
 
[40,218 views]  View Printable Version
Airport update 3.3 unlocks cards sold in France Network
Until now, French mac users had severe difficulties joining public wi-fi networks. Reason? For years, the Airport cards sold in France were limited to four channels. A restriction required by a local legislation (no longer active today; that's why it doesn't apply to AirPort Extreme cards).

Most of users thought the limitation was hardware. It was not! With the AirPort 3.3 update, all the channels are now available in the first generation cards. To check this:
  1. Update your Airport software
  2. Select "Create a Network" ("Créer un Réseau") from the AirPort menu
  3. Admire: now, all the channels are available to you.
This is not documented by Apple, so I thought your french readers would by interested to learn it.

Sorry for my bad english, I work hard to improve it ...
  Post a comment  •  Comments (6)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[3,239 views]  View Printable Version
Enable both GPRS and Address Book over Bluetooth Network

I connect to the internet through Bluetooth and my t68i. But although I can receive calls and text messages during the GPRS connection, it was a pity that I couldn't turn on Address Book functionality. A quick look into BluetoothMonitor from the Developer Tools package (in Applications -> Utilities -> Bluetooth) gave the answer: both default modem and Address Book uses the same channel ID (1), which results in conflict. So, I opened Bluetooth Serial Utility in /Applications -> Utilities, and added a new port. I called it "Bluetooth-Serial-2" or whatever:

  • Port Direction: Outgoing
  • Select Device... (your phone name) > Serial Port 2
  • [yes] Show in Network Preferences
  • Port Type: Modem

Then I opened Network Preferences and it asked me to add the new port. I made some cosmetic changes -- renamed it to "Bluetooth modem" and disabled the original "USB Bluetooth Modem Adaptor" in "Network Port Configuration." Then I set up the PPP section (remembering to uncheck "Send PPP echo packets" in PPP Options...) to my former values, as well as Bluetooth modem (thanks to these GPRS scripts which works great!)

And now it works, because it uses RFCOMM Channel ID: 5 now. When typing this, I received some SMSes and a phone call and they popped up! I also tried iSync (which uses channel 11) and first I got some error messages. However, I believe it was because I was downloading a large file at the same time as for the second and third tries, everything was okay.

I hope that this helps somebody too. I haven't found any other resources with this problem. I also don't know what are those security (authentication and encryption) options in adding the serial port?

  Post a comment  •  Comments (7)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (3 votes cast)
 
[11,061 views]  View Printable Version
10.3: A fix for post-upgrade Windows login issues Network
We upgraded a machine at work from 10.1 to Pather, and tried to enable Windows sharing for the first time. Although everything seemed to be set up properly (SMB enabled in Directory Access, Windows sharing set in the Network preferences), we couldn't login to our existing accounts from a Windows machine. After scanning the Web and Help files, we finally came up with the solution.

The Tip is to change the password for any existing accounts for which you want to enable logins from a Windows machine; this will create the necessary associations to allow the user to access via Samba. This is mentioned in the Help files, but you need to look really hard! :)

New accounts set up after Panther was installed should work straight away.
  Post a comment  •  Comments (5)  
  • Currently 2.57 / 5
  You rated: 3 / 5 (7 votes cast)
 
[11,354 views]  View Printable Version
10.3: Check network speed to resolve connection issues Network
It seems that Panther's Ethernet speed detection is a little off. I've been having problems with new machines on the network not being able to access the net, due to the speed being set too fast. It's an easy fix, luckily. In the Network preference pane, click your active Ethernet connection and switch to the "Ethernet" panel.

Select "Manually (Advanced)" from the Configure pop up and change your Speed setting. Unless you know the actual speed of your network, you'll have to do it by trial and error (though, there are only three options to choose from). Pick one and hit "Apply Now" and switch back to the "TCP/IP" panel to see if it's found an IP address (it might take a second).
  Post a comment  •  Comments (21)  
  • Currently 2.14 / 5
  You rated: 3 / 5 (7 votes cast)
 
[61,274 views]  View Printable Version
Old automount entries can cause application hangs Network
I had an interesting problem yesterday. All of a sudden, several of my applications were hanging. I got the spinning beachball, and had to force quit them. But it took several force quits to kill the applications, either from the Dock or from the Force Quit Application window (Command-Option-Escape). This first began with Word freezing, when I tried to insert a graphic from a file. Well, I thought, this is just Word ... but then it happened when trying to use the Acrobat PDF Writer to create a PDF from a Word document. Then other applications started hanging, including the Finder.

One thing I noticed was that the hanging occurred in operations which should have displayed an Open or Save dialog. I'll spare some of the troubleshooting operations I went through to see if the problem was related to specific application updates (the iCal update, or another update of a pre-release version of a network utility).

The solution came when I recalled a similar problem with OS 9 hanging because of aliases to recent servers in the System Folder's Recent Servers folder. So I fired up the Terminal and went to /var/automount/Network, and, indeed, found a half-dozen directories there that corresponded to different servers. After deleting these, everything worked fine.

I haven't seen this problem reported elsewhere, but it's certainly something to look for. If an application hangs when it's about to display an Open or Save dialog, it could be that the Finder is looking for those recent servers before displaying the dialog, so when you click the Network icon in the sidebar they display.
  Post a comment  •  Comments (6)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (3 votes cast)
 
[8,345 views]  View Printable Version