Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Optimising MTU setting in PPPoE ADSL Connections Network
I use PPPoE on an ADSL connection which is limited only by the modem sync speed (ie: no data rate capping by the ISP, on the downstream at least), and I wanted to optimise the MTU to get the best throughput. The consensus seems to be that the optimal MTU is 1454, based on the fact that 1492 the maximum possible, and 1454 is the highest value less than this which doesn't end up with any padding bytes in the last ATM cell. An ATM cell is the basic transfer unit over a DSL link, and they are all fixed length, padded out to this length if the packet doesn't end on a cell boundary.

I tried configuring the 1454 value using a couple of techniques mentioned on macosxhints, but they didn't seem to have much effect, at least not on the downstream packets. A little network tracing showed that Mac OS X PPPoE was still negotiating an MTU of 1492 with my ISP. So I did a little digging around and came up with the following solution...
read more (243 words)   Post a comment  •  Comments (13)  
  • Currently 2.80 / 5
  You rated: 5 / 5 (5 votes cast)
 
[25,421 views]  View Printable Version
Emailing 'file:' URLs to both PC and Mac users Network
I have figured out how to send email hyperlink files to both Windows and Macs users at work. These files comes off a linux file server; the Windows users are using 2003 Exchange servers, and we have various Mac users. The hyperlink file in the email that you send to Mac users is different than the hyperlink file that you would send to a Windows users. In the end, however, both Windows and Mac users are able to click on a hyperlink to open a file off the server.

DISCLAIMER: Even though this works for me, it doesn't necessary mean that it will work for you. Success depends on the file server, Exchange server, ports and privileges, syntax, etc. This hint provides clues on how to set up hyperlinked file such that you may be able to send them to both Macs and Windows users via email. You will probably have to experiment a little (or a lot) to get this to work for you.
read more (146 words)   Post a comment  •  Comments (7)  
  • Currently 1.00 / 5
  You rated: 1 / 5 (3 votes cast)
 
[16,525 views]  View Printable Version
Create a remote X11 desktop over SSH (revised) Network
This hint is an evolution of another hint, which I had a hard time getting to work. You can read it for the rest of the detail, but the short story is that it allows you run a full remote X11 desktop session in a window on your Mac.

The longer story is that it probably won't work, because your Mac probably doesn't have the same X11 fonts installed as does the remote server. The older hint actually addresses this, but the explanation is confusing, and it only works if there is no firewall between you and the server. The fix is to forward the TPC port of the X font server over the SSH session, so that your local machine can actually talk to it. Here is what the entire setup looks like:
localhost%  ssh -L7100:localhost:7100 -Y user@remotehost

(in another Terminal window)
localhost%  xset +fp tcp/localhost:7100

(back in the first window, after it has ssh'd into the remote host)
remotehost% Xnest ":1" -geometry 1280x810 -query localhost
Discussion:

You have to have the ssh session open, with the port forwarding active, before you will be able to add the remote font server to your local font path. And you have to have the remote server's fonts in your font path before it will be possible for the remote desktop session (CDE on Solaris in my case) to start up.

One of the problems I had with the old hint was that it said to do xset +fp tcp/ip.of.remote.host:7100 and I thought he meant "use the tcp/ip address...", when actually the prefix tcp/ is really part of the syntax. The other problem is that it wasn't clear where you were supposed to run the xset command, or for that matter why you'd be tunneling X in SSH at all if there wasn't a firewall in the way.
  Post a comment  •  Comments (6)  
  • Currently 2.43 / 5
  You rated: 3 / 5 (7 votes cast)
 
[51,237 views]  View Printable Version
Restore wireless connection strength when using Bluetooth Network
About once or twice a day, the strength indicator on my AirPort drops right down and eventually disconnects. Needless to say, this is pretty frustrating, but after four months, I have finally discovered the reason. It is because Bluetooth uses the same frequencies as 802.11, which opens up the possibility of packet collision. When this happens, Bluetooth is supposed to hop frequencies, and 802.11 is supposed to add a delay somewhere to compensate.

To fix, simply turn off Bluetooth, turn off AirPort, turn on AirPort, then turn on Bluetooth. This also usually fixes the reverse problem, where there is lag with a Bluetooth keyboard (and possibly mouse, but I've never used one).

I should add this is probably only a problem if Bluetooth is communicating continually. In my case, the problem is my keyboard. If you're just syncing your phone or something of that nature, then this will probably not affect you.
  Post a comment  •  Comments (19)  
  • Currently 1.75 / 5
  You rated: 2 / 5 (4 votes cast)
 
[14,606 views]  View Printable Version
10.4: A possible fix for wireless connection problems Network
Tiger only hintWell, much like may other people, ever since I upgraded to Tiger, I have had issues with the AirPort connection on my good ol' Pismo. No automatic connection whatsoever -- on bootup, restart, or wake from sleep. It was really annoying. My home wireless network (DLink WEP protected) would show up, and I could manually connect, but not without human intervention.

I finally found the complete answer: Keychain and Network Preference settings:
  1. In Network Preferences > AirPort, set the "By default, join:" to "Preferred network."
  2. In AirPort > Options..., set "If no preferred networks are found:" to "Keep looking for recent networks."
  3. In Utilities > Keychain Access, select your Network under Login Keychains. Check the "Show password:" box and make sure it is correct -- mine had a "0x" prefix added to it that I had to remove. Under the "Access Control" tab, select the "Allow all applications to access this item." I may be wrong, but I think this is the key to getting all of the automatic connections to work, well, automatically.
I had been able to get partial success with the first two steps, but until I did the third step, nothing was consistent, especially automatic connection at startup. Hope this helps. I would be interested to see if it works with other people's setups.
  Post a comment  •  Comments (21)  
  • Currently 3.00 / 5
  You rated: 5 / 5 (4 votes cast)
 
[37,427 views]  View Printable Version
10.4: Fix firewall blocking of Mail under internet sharing Network
Tiger only hintWe just put in an PowerMac at a retired relative's house running Tiger connected to the internet via DSL. Normally, the PowerMac will only be used as a standalone machine, but it does have an AirPort card. While we're visiting, we want a wireless network so we can use our notebooks to access the internet.

So, today, we tried it. Web surfing worked immediately. Mail, however, would not work. We figured out that the firewall running on the PowerMac was blocking ports Mail needed, but then it took a bit of playing around to make it work. We turned on logging and found blocked ports that might be used by Mail, told the firewall to allow them, and got things working. Since there was already someone using a port scanner on us, we removed some of the ports from the allowed list that we weren't sure we actually needed there, and things still worked.
read more (311 words)   Post a comment  •  Comments (3)  
  • Currently 2.00 / 5
  You rated: 1 / 5 (3 votes cast)
 
[15,141 views]  View Printable Version
Bypass firewall restrictions via an HTTPS proxy Network
Our IT people decided that it was a bad idea to access the Internet recently, and our beloved open-access policy was replaced with a block on all ports, with ports 80 and 443 (http and https) now routed via a proxy server. No more getting my Gmail or other POP/IMAP mail, no more MSN, Jabber, ICQ, etc.

Needless to say, I was peeved. I did some digging and came up with this absolutely wonderful little program called Proxytunnel. You see, if your network admins are anything like mine (and most are), they will have allowed you acccess to secure sites via an HTTP proxy. The thing with SSL and proxies is that because everything's encrypted, the proxy can do naught but just pass on your requests to the sites in question, and can't have any say on what protocol is used. So get Proxytunnel, drop it in /usr/local/bin or anywhere else in your path, and then do something like this:
/usr/local/bin/proxytunnel -a 5222 -g 123.123.123.123 \
-G 8080 -d myjabberserver.com -D 5222
You can now access your Jabber server by setting up iChat to connect to server localhost instead of myjabberserver.com (the 123.123.123.123 IP address is the IP of your proxy server; 8080 is the port. The first 5222 is the port on localhost that proxytunnel will be listening to, the last one is the port of your jabber server. Note that you need to run Proxytunnel as root if you want it to listen on a port below 1024; however, you can make it listen on a different port.
read more (622 words)   Post a comment  •  Comments (39)  
  • Currently 2.14 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (7 votes cast)
 
[175,246 views]  View Printable Version
Cell phone USB modems and port number issues Network
This is a tiny hint that hopefully will save the rest of you some time. I have been using a Motorola cell phone (V300) to connect to the internet via GPRS -- it's actually T-Mobile's Internet Service, which is quite a bargain at $20 per month for unlimited usage.

The thing that is important to remember is that when you configure your cell phone with Internet Connect, it saves the OS X USB modem device string literally from the first port you plugged the phone into. This means if you plug it into the second port later and try to use the phone, it will appear to be working (i.e. the phone appears on System Profiler), but it will refuse to actually make a network connection. The way you can tell is to open Console and look at system.log. You will see references such as pppd[240]: Device '/dev/cu.usbmodem1B11' does not exist.

If you open Terminal and look in the file system, you can see that you have plugged the phone into the wrong port: in my case, I will have a file called /dev/cu.usbmodem3b11 (note the 3 instead of the 1). The way to solve this is to unplug the modem and put it in the original port; then the modem will be at /dev/cu.usbmodem1b11 and all will work again.
  Post a comment  •  Comments (3)  
  • Currently 2.60 / 5
  You rated: 1 / 5 (5 votes cast)
 
[12,755 views]  View Printable Version
A possible Bluetooth network connection fix Network
Tiger only hintAfter weeks of happily using my Motorola v710 phone and a DLink DBT-120 Bluetooth USB to wirelessly connect my G4 PowerBook to the internet, it stopped working. Everything described here happened while running Tiger. I was presented with a dialog box with the following disconcerting message:

Internet Connect
The selected communication device does not exist.
Please verify your settings and try again.

At this point, I took a look at system.log using Console, and found the following error being reported:
Jul 25 09:33:44 hostname pppd[3343]:
  Device '/dev/cu.Bluetooth-Modem' does not exist
Sure enough, no such entry exists under /dev. After repeatedly rediscoving the phone and fiddling with my connection configurations, I continued to get the same message. Apple Support was happy to talk about Tiger, but informed me that Bluetooth network connections are not supported (grumble, grumble). Fortunately, I have a second machine which I had also set up to use my Bluetooth phone for a network connection (though it has an Apple internal Bluetooth module instead of the USB style on my Powerbook). I took a look at the Bluetooth entries under /dev on my still working machine using ls -l /dev/*Blue*. I then created identical entries on my Powerbook using these commands:
sudo mknod /dev/tty.Bluetooth-PDA-Sync c 9 2
sudo mknod /dev/cu.Bluetooth-PDA-Sync c 9 3
sudo mknod /dev/tty.Bluetooth-Modem c 9 4
sudo mknod /dev/cu.Bluetooth-Modem c 9 5 
sudo chmod a+rw /dev/*Blue*
Now all seems fine. I have no idea what could have caused this problem, nor do I know the proper way to recreate the /dev entries expected by Tiger. Additional insight into possible causes of this problem or the appropriateness of the solution would be appreciated...
  Post a comment  •  Comments (5)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[13,564 views]  View Printable Version
Unmount all remote volumes on idle with Applescript Network
I found that my Mini becomes unstable and sometimes freezes if I leave my SMB shares mounted for days at a time. So, I combined several scripts found on this site into a new script that unmouns all volumes when the computer's been idle for a while.

The main credit for this goes to this older hint.

[robg adds: I haven't tested this one...]
  Post a comment  •  Comments (1)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[7,070 views]  View Printable Version