Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Use a D-Link DWL-G122 USB WiFi Dongle - revisited Network
Let's say you have an "old" Mac you want to wirelessly connect to your AirPort network. In my case, it's an eMac. Like me, you probably don't want to buy an expensive AirPort Extreme card. It's worse if you have an old G3 CRT iMac: the already-expensive card needs an exepensive adapter! So you look on the internet for a cheap USB WiFi dongle solution, like many of your PC friends own. What? They don't make any of these for Macs? D-Link made one two years ago, but its new version (the DWL-G122) doesn't support OS X any more. So I came across a one-year-old hint here, which made me purchase it, because the hint (and replies) stated that "rev B1" of this dongle used a chipset that was Mac-compatible ... and that the maker (Ralink) had an OS X driver available on their site.

But I quickly was disappointed: I could only use it when I had no password assigned to my wireless network! It just wouldn't work when my WEP encryption was enabled. After much research, and the help of others in the Ralink forums, I found a solution. Put simply (for you quick-minded network genies), you need to enable WPA Personal encyption (instead of WEP, which seems to be totally broken with this version of the driver) and use a 13-character password.

For other, less-exeperienced users, I have written a very detailed walkthrough, which is a combination of the old hint, personal experience, info found on Apple's help pages, and elsewhere on the internet.
read more (1,119 words)   Post a comment  •  Comments (35)  
  • Currently 1.75 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (8 votes cast)
 
[125,511 views] Email Article To a Friend View Printable Version
Play iTunes from anywhere via SMB Network
OK, so this is probably a combination of all sorts of previous hints, but this is how I access, listen to, and even edit my iTunes music, located at home, from any place with an internet connection via SMB. This is an alternative to a recently published hint about using zerospan to access your iTunes music as shared music via Bonjour. I tried that hint, but didn't succeed because of firewall issues, I think.

Read on for the step-by-step...
read more (426 words)   Post a comment  •  Comments (12)  
  • Currently 1.67 / 5
  You rated: 1 / 5 (3 votes cast)
 
[34,785 views] Email Article To a Friend View Printable Version
A script to determine Maximum Transmission Unit Network
Though OS X should, under normal circumstances, just automagically figure all this stuff out on its own, certain brain-dead networks are messed up to the point that standard settings won't work reliably and OS won't be able to auto-correct.

In particular, some (not me, thankfully) will have a problem with their Maximum Transmission Unit (MTU) set too high. There are some older hints discussing this problem, but none really discuss how to figure out if you do or not.

This script will do the trick. If it says that your MTU is 1500 or more, you can forget all about MTUs. If it says it's something smaller, and you've been having network problems, you've probably found at least one of the mysterious sources of your troubles. If it says it's something smaller, and your network is behaving properly, just forget you ever ran the script.

[robg adds: Save the script using your favorite text editor, and then remember to make it executable (chmod a+x script_name) before running it. You should also edit line 13 (PingHost="ns.fastq.com") and replace the hostname with a host of your choosing -- your local nameserver is suggested in the script's comments. I tested it, and it seems to work as described.]
  Post a comment  •  Comments (16)  
  • Currently 1.50 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[13,783 views] Email Article To a Friend View Printable Version
Use the E-Tech Broadband Router's print server Network
I bought a dirt-cheap E-Tech Broadband Router with USB Printer Server (Model RTPR01), which officially supports the Mac platform only on the routing part of the product. There's no mention in the manuals about the built-in print server being compatible with Mac OS X, but I managed to make it work in a, for me, quite unexpected way. Note that I'm using Mac OS X 10.4.4 on a G3 iMac and G3 iBook. Now I can use the print server to print via my home network on an Epson Stylus Color 760. Here's how I did it:
  1. Download and install Gimp-Print 5.0.0-beta2 or later (not Gimp-Print 4.2.7, which doesn't work for reasons that I don't know).
  2. Add a printer in the Printer Setup Utility and then click the 'IP Printer' button.
  3. Type the IP-address of the E-Tech router (which is 192.168.1.1 by default, but can be changed in anything you need).
  4. If you want, type a name and a location.
  5. Choose a suitable printer driver at the 'Print Using' drop-down menu.
  6. Choose 'HP Jet Direct - Socket' at the 'Protocol' drop-down menu.
  7. Click the 'Add' button in the Printer Browser dialogue.
Voilá! Your E-Tech Router/Print Server should work properly (supposing you connected all the cables properly). To me it was quite a surprise that it worked (after hours of trial-and-error) because I am printing with an Epson printer -- so I wouldn't expect the 'HP Jet Direct - Socket' protocol to work.

If your printer is still not working and you are using the E-Tech Router/Print Server behind an already working DHCP-server, make sure the first three octets (and only the first three octets) of the IP address of the E-Tech Router / Print Server match the first three octets of the IP addres of your DHCP server. In that case, you should also disable the built-in DHCP Server of the E-Tech Router/Print Server to avoid conflicts.
  Post a comment  •  Comments (2)  
  • Currently 2.75 / 5
  You rated: 2 / 5 (4 votes cast)
 
[8,491 views] Email Article To a Friend View Printable Version
Add Bluetooth support for Motorola V3i Network
I can't belive I got it to work, but it did, just by modifying the MetaClasses.plist file. The new stuff has to be after the 'v3' entry, but before all of the USB entries -- at least that's how mine works. So far, this is what the code looks like.

To find the MetaClasses.plist file, control-click on the iSync application and select Show Pacakge Contents from the pop-up menu. Navigate to Plugins -> ApplePhoneConduit.syncdevice -> Contents -> Plugins -> PhoneModelsSync.phoneplugin -> Contents -> Resources, and in that folder you will find MetaClasses.plist. Before you start changing stuff around, my advice is to make a copy of your original file and name it MetaClasses.plist.old or similar.

Now here's the kicker ... for whatever reason, the file uses the MOTV3-black.tiff icon. So I just deleted that one, and used a new one I made. You can find a lot more on this topic in this thread at howard forums.

[robg adds: This previous hint explained how to add basic iSync support, but without Bluetooth.]
  Post a comment  •  Comments (3)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[24,813 views] Email Article To a Friend View Printable Version
Use Hamachi to create secure remote networks Network
I imagine that, like me, many people are stuck behind a firewall that you don't control, but you would like to access a computer outside of the firewall (either out -> in or in -> out). The best solution I've found this is a free product called Hamachi.

Hamachi runs on Mac OS, Windows, and Linux. With Hamachi, you can create a private virtual network that allows you to communicate amongst the various machines that have the Hamachi client installed. Unlike the Windows version, the Mac version is currently command line only, but can be fairly easily installed by following these instructions from the Hamachi forums. Note that you'll also have to install the OS X TUN/TAP driver.

[robg adds: I haven't tested this one. If you are going to do so, I would strongly suggest you check with your IT department first -- many companies, such as one of my previous employers, have very harsh policies when it comes to circumventing firewalls.]
  Post a comment  •  Comments (5)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[22,189 views] Email Article To a Friend View Printable Version
Share a DSL internet connection over FireWire Network
I have two machines, one connected to the net via DSL, the second connected to first via FireWire. The question is how to get Internet access on the second machine? Apple claims it's possible, but does not provide any setup instructions. So here's a solution that worked for me.

Machine A:

Tiger. Connected to Verizon DSL modem. Ethernet is first item in Network prefs, FireWire is second.

Ethernet port: DHCP with manual address. IP set to something in router range, that is, given router IP of 192.168.1.1, set the IP address to 192.168.1.x, where x is anything between 2 and 255.

FireWire port: DHCP with manual address, and IP address to a different network. For example 192.168.2.1 (the last digit must be 1). Now enable Personal File Sharing and Internet Sharing. In Safari, connect to your router i.e. http://192.168.1.1. You will see your DSL modem setup screen. Note your primary and secondary DNS IP numbers. That should be somewhere on the Status page or something similar.

Machine B:

Not connected to modem. FireWire is the only network port in Network prefs. Set it to DHCP. Apply. Note IP router number that machine B will select automatically. If different than IP FireWire port address on machine A, go to machine A and set its FireWire IP to router IP on machine B.

Enter primary and secondary DNS IPs that you obtained from your modem above in "DNS Servers" field, one per line. Enable Personal File sharing.

Both machines will have access to internet and be able to mount each other for file sharing. It is possible to have a FireWire camera or disk connected at the same time to the other FireWire port, and everything works fine -- but slowly.
  Post a comment  •  Comments (10)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (3 votes cast)
 
[20,600 views] Email Article To a Friend View Printable Version
Find 'clear' PPP modem passwords in System Profiler Network
I forgot my modem (STN, non xDSL) PPP password. The connection was still running, but should a crash happen...

This password should have been recorded in my Keychain. Unfortunately, it wasn't (possibly because I installed Tiger as a Jaguar update). No matter. If the password wasn't in the Keychain, it was elsewhere! SO I looked in a lot of places, and tried tons of tricks, to find my password.

There are always things you never think of and places you never visit. Looking for something else, I opened System Profiler. I was browsing the window when I noticed the Network branch and the Configuration entry within it. I clicked on it, and all my configurations were there. When I clicked on my modem connection entry, I saw a magic word: password, followed by hex numbers.

After a short hex decode (each four hex digits match one character), my password was mine again. I was pleased. Now I do consider this a security concern, but I'm glad it was there.

[robg adds: I can't confirm this one, as I don't have a configured modem...]
  Post a comment  •  Comments (3)  
  • Currently 2.50 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[7,673 views] Email Article To a Friend View Printable Version
Use a keyboard shortcut to change Locations Network
I change locations (use the Apple Menu -> Location menu item) at minimum twice every workday. I wanted to add shortcuts to make it easier/faster, but after adding the name of my location in the Keyboard & Mouse Preferences panel, it still didn't work. The shortcut shows in the menu item, but it only works after you have hovered over the "Location" submenu, and let it display the menu (and you have to do this every time an app is launched).

So I thought, why not have a keystroke do the job via Butler (or another similar utility)?

Note: Control-F2 (by default) selects the Apple Menu and it will prevent you from creating a keystroke with that definition. Before you proceed, you have to disable the 'Move focus to the menu bar' feature in the Keyboard & Mouse System Preferences panel. Look on the Keyboard Shortcuts tab, in the Keyboard Navigation section. Just uncheck the box next to this feature.
read more (250 words)   Post a comment  •  Comments (8)  
  • Currently 1.75 / 5
  You rated: 1 / 5 (4 votes cast)
 
[16,934 views] Email Article To a Friend View Printable Version
Use a Brother MFC-420CN as networked card reader Network
The Brother MFC-420CN is a multifunction scan - fax - print - copy machine that can be networked. There's also a multi-card reader in the front of the machine, for CompactFlash, SmartMedia, xD-Picture card, Memory Stick and Secure Digital media cards.

If you find out the IP of the printer (using the DeviceSelector application in /Library -> Printers -> Brother -> Utilities), you can FTP to that address and copy files over from any supported card inserted in the printer. It's not as fast as a dedicated USB card reader, but it works!
  Post a comment  •  Comments (3)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[9,314 views] Email Article To a Friend View Printable Version