Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.5: Set up NFS exports in 10.5 Network
Setting up NFS exports under Leopard is insanely easy: just add an entry to (or more usually, create) /etc/exports, and it gets picked up automatically. This file survives reboots, as well; pretty cool.

Here's an example:
muse:~ root# cat /etc/exports
/Volumes/BigDisk/Panic	-maproot=netroot	10.0.1.1
muse:~ root# showmount -e
Exports list on localhost:
/Volumes/BigDisk/Panic             10.0.1.1 
muse:~ root#
[robg adds: I haven't tested this one.]
  Post a comment  •  Comments (3)  
  • Currently 2.20 / 5
  You rated: 3 / 5 (5 votes cast)
 
[24,416 views] Email Article To a Friend View Printable Version
Change the default user name for AFP connections Network
When you connect to another Mac (or other device) using AFP, did you know you can control what shows up in the Name field? By default, OS X will populate your full user name, but you can change this via some hidden preferences.

For instance, to make the dialog show your short username instead, do this in Terminal:
$ ### in 10.4...
$ defaults write -g com.apple.AppleShareClientCore -dict-add afp_use_default_name -bool NO
$ defaults write -g com.apple.AppleShareClientCore -dict-add afp_use_short_name -bool YES
$
$ ### in 10.5...
$ defaults write /Library/Preferences/com.apple.NetworkAuthorization UseDefaultName -bool NO
$ defaults write /Library/Preferences/com.apple.NetworkAuthorization UseShortName -bool YES
You can read about the other options, including one to display a custom name, in this Apple article.
  Post a comment  •  Comments (4)  
  • Currently 3.33 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (3 votes cast)
 
[9,663 views] Email Article To a Friend View Printable Version
Apple Remote Desktop Administration from a PC with NAT Network
Last weekend I had to connect via VNC/Apple Remote Desktop to the MacBook that manages my mother's business from a PC. This was complicated by the fact that we were both behind NAT routers in different regions of the country.

This hint provided a good start. Unfortunately, I did not have the luxury of advanced setup and all of my machines run Windows XP. These instructions require a slight short-term reduction in the security of your PC; use at your own risk. These steps are quick-and-dirty, some refinements are certainly possible.

Read on for the detailed how-to...
read more (848 words)   Post a comment  •  Comments (5)  
  • Currently 2.75 / 5
  You rated: 5 / 5 (4 votes cast)
 
[38,161 views] Email Article To a Friend View Printable Version
10.4: Easily wake a networked Mac via Automator Network
I've got my mini hooked up in one room to a TV. It doesn't really have easy access to a keyboard and mouse, but it is connected to a huge external hard drive that I store all sorts of files on. So sometimes, when the mini is asleep I need at the files. Searching on Google for "wake mac on lan" took me to this older hint, which hasn't had much action lately.

After trying the hints on that page, the problem was that after waking the mini, I would still have a terminal window open. Now there may be away around that, but I couldn't find one. So I took the information I learned there and plugged it into an Automator workflow, using the Automator: Run Shell Script action. The Shell should be /usr/bin/python, the Pass input should be to stdin, and the body of the script should be:
#!/usr/bin/env python
import socket
s=socket.socket(socket.AF_INET, socket.SOCK_DGRAM)
s.setsockopt(socket.SOL_SOCKET, socket.SO_BROADCAST, 1)
s.sendto('xff'*6+'x00x11x22x33x44x5a'*16, ('192.168.1.255', 9))
You will have to replace the 00, 11, 22, 33, 44, 5a with your own mac address, of course -- you can find this in the Network System Preferences panel.

Then save the Automator action as an application or a Finder plug-in. When it is run, there is no Terminal window. (I saved mine as an application, changed the icon to a picture of a mini, and now I have an icon in my dock that, when clicked, wakes my mini in the other room).
  Post a comment  •  Comments (8)  
  • Currently 3.00 / 5
  You rated: 4 / 5 (5 votes cast)
 
[14,209 views] Email Article To a Friend View Printable Version
Create self-contained SSH key scripts Network
I was playing around with making SSH access to a remote machine as easy as possible for my other half. Initially, I generated a key pair using ssh-keygen and installed the public key on the server as usual, put the private key in a folder with a .command (double-clickable shell script for Finder) script like the following:
#!/bin/bash
# chimpy.command - Logs user bob into chimpy using private
# key bob.dsa

ssh -i ./bob.dsa bob@chimpy.sampsa.com
Alas, that did not work as the .command file sets the current working directory to the user's home directory, not the directory it was executed from. Annoying. But then I realized that as the key is actually a text file, so why not make the key itself an executable script?
read more (114 words)   Post a comment  •  Comments (11)  
  • Currently 3.40 / 5
  You rated: 3 / 5 (5 votes cast)
 
[17,819 views] Email Article To a Friend View Printable Version
OS X VPN client and Cisco ASA Network
Disclaimer: The following is a highly technical hint.

Summary: This hint is for Network Engineers who want their firewalls to accept VPN connections from standard OS X L2TP / IPSec clients (should also work for Windows and Linux clients). If you are not a network engineer, but are having trouble connecting to one of these devices, you can also forward this tip to your company's "firewall person," so that they can fix it.

Problem: A Cisco ASA or PIX firewall can be a VPN server, but a basic VPN configuration will not allow the default OS X L2TP/IPSec client to connect, even though the Cisco client will. It may not be convenient to distribute the Cisco VPN clients, or your users may not wish to use them.
read more (367 words)   Post a comment  •  Comments (6)  
  • Currently 1.83 / 5
  You rated: 1 / 5 (6 votes cast)
 
[70,554 views] Email Article To a Friend View Printable Version
Use Entourage with Exchange Server 2007 Network
Recently, my company implemented a new Exchange 2007 server for our email. No special changes or accommodations were made to support OS X. After a bit of searching and trial and error, I figured out the settings for Entourage to work when connected to the corporate network: email, contacts, and calendar all work.

I started with version 11.3.6 (070618) of Entourage, and added a new Exchange email account. I then tried the automatic setup, but it failed so I went into manual mode. During the setup, i found two fields that require surprising entries:
  1. Under the Account Settings tab, the Exchange Server field. Here is what works for me:
    https://my.internal.owa.server.name/exchange/username@domain.com
    Be sure to use /exchange/ rather than some other directory, and include your full email address afterwards. This was surprising because to connect with Safari, the URI is:
    https://my.internal.owa.server.name/owa/
  2. On the Advanced tab, for the Public folders server, I use this URI:
    https://my.internal.owa.server.name/public/username@domain.com
    Once again, use /public/ not some other directory.
Evidently /exchange/and /public/ are virtual folders that Exchange 2007 creates for backward compatibility. The data for the rest of the fields was as expected. Hope this helps!
  Post a comment  •  Comments (8)  
  • Currently 4.46 / 5
  You rated: 5 / 5 (13 votes cast)
 
[49,780 views] Email Article To a Friend View Printable Version
10.4: Another fix for Windows 2003 share mounting Network
Many users have problems mounting shares from Windows 2003 Servers from OS X Tiger (10.4 - 10.4.10) clients. The following solution has been tested in our enterprise where we have W2K3 servers, physical as well as virtual, and some within a SAN.

Problem: From the network view in OS X, we could browse to the servers, but when we tried to connect, we would get the Delete/Fix Alias error. When connecting from the Finder with Command-K (either with smb://servername, smb://ip.address, smb://servername.fqdn, cifs://servername, etc.), we would get the dreaded Error -36 and the Console would show:

mount_smbfs: session setup failed (extended security lookup2): syserr = Socket is not connected
mount_smbfs: could not login to server SERVERNAME: syserr = Socket is not connected

Using smbclient from the terminal would work fine.

Solution: After making sure that there are no Local or Domain policies interfering (NETBIOS, WINS, Kerberos, Firewalls, IRPStackSize problems, etc.), try the following.

On the server in question, in Control Panel » Network Connections, select the NIC, click on Properties, then on "File and Printer Sharing for Microsoft Networks," click on Properties and check the option for either Maximize Throughput for File Sharing or Maximize Throughput for Network Applications (depending on the use of the server). This changes the value of the REG-DWORD "Size" at HKEY_LOCAL_MACHINESYSTEM » CurrentControlSetServices » lanmanserverparameters from 1 or 2 to 3. From the command line or Services.msc, restart the "Server" service or reboot the machine. Thanks to Joel Ayala for the expert Windows perspective.

[robg adds: We have a few more Windows 2003 hints in the system.]
  Post a comment  •  Comments (4)  
  • Currently 2.20 / 5
  You rated: 3 / 5 (5 votes cast)
 
[24,916 views] Email Article To a Friend View Printable Version
Create a personal replacement for the .Mac service Network
The following is not mine, but I ran across it and it looks awesome. If you like the services .Mac provides, but would rather provide them yourself and you have a spare machine lying around, this how-to explains the steps required to do just that. I'm going to try it later tonight on an ubuntu server at home, and will post my findings in the comments.

[robg adds: Typically I would contact the author and request permission to repost their solution here, so we have it in the system. However, this particular how-to is quite long, very detailed, and contains lots of screenshots. It's also not for the faint of heart, as you'll have to do a fair bit of digging to find info, and then some configuration work. You're not just setting up a server that provides .Mac-like services, but you're setting it up such that the functions on your machine that use .Mac actually work with your internal server.]
  Post a comment  •  Comments (7)  
  • Currently 2.50 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[11,011 views] Email Article To a Friend View Printable Version
One way to make 'hidden' SMB shares reappear Network
At my work, we have a large number of SMB shares, and for some reason they stop showing up on desktops sometimes. If you look for them in Terminal, they are mounted, but they are not in the Finder anywhere. If this happens, here's one way to get them back.
  • Launch Terminal and type cd /Volumes
  • Type ls to list the directory's contents, and find the volume name in the list.
  • Type open volumename, where volumename is the name as shown in the prior output.
A new Finder window will open with the root contents of the volume you chose, and the icon will then appear in the Finder window and on the desktop (if you have network volumes showing on your desktop).
  Post a comment  •  Comments (10)  
  • Currently 1.80 / 5
  You rated: 3 / 5 (5 votes cast)
 
[12,309 views] Email Article To a Friend View Printable Version