Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Using Apple's mod_rendezvous Apache module Internet

Mac OS X 10.2.4 includes a new Apache module called mod_rendezvous_apple. When you install the 10.2.4 update, it will replace your Apache configuration (in /etc/httpd/httpd.conf) with a new file which includes lines to load and enable the new module. Note: If you want to get at your previous configuration, it's saved in /etc/httpd/httpd.conf.applesaved.

One of the cool things about Apple's mod_rendezvous_apple is that it can register individual user's sites with Rendezvous. It's somewhat annoying, however, if you have a large number of users, as this results in a very long "Rendezvous" entry in your Safari bookmarks.

It's easy to turn this off, though. Edit the /etc/httpd/httpd.conf file (you'll need root permissions for this) and find the following lines: (they are near the end of the file)

<IfModule mod_rendezvous_apple.c>
RegisterUserSite all-users
RegisterDefaultSite
</IfModule>
Either replace "all-users" with the names of the users whose sites you want to be registered with Rendezvous, or just remove the line (or comment it out by putting # at the beginning of the line) if you don't want any user sites to be registered.

  Post a comment  •  Comments (9)  
  • Currently 1.60 / 5
  You rated: 1 / 5 (5 votes cast)
 
[9,054 views] Email Article To a Friend View Printable Version
Renewing a DHCP lease Internet
If you have a cable modem, you may have to sometimes "renew your DHCP lease" — in other words, get a new IP address from your Internet provider's DHCP server. This is particularly useful when your ISP has recently been suffering connectivity problems and your earlier established connection was disrupted. There are two ways to do this: the 'normal' way, and also the 'shell' way. This is shortened somewhat from this webpage...

The 'normal' way involves the Network preference pane in the System Preferences application. Click on the "Show" pull-down menu and select either 'Network Port Configurations' or 'Active Network Ports,' depending on whether you're using 10.2 or an earlier version. Click off the box next to your network port (usually 'Built-In Ethernet,' unless you're using AirPort), then hit 'Apply Now.' Then click it back on and hit 'Apply Now' again. And as Emeril might say ... BAM! New DHCP lease.

You can also do this through the Terminal. First type the Unix command sudo ipconfig set en0 BOOTP, and then the command sudo ipconfig set en0 DHCP. I aliased the two commands together as 'new-ip' (you put them both on the same line, using a semi-colon to separate them). Don't know how to use aliases? Read this hint (and possibly this one, if you're in 10.2).

If you're working with IP addresses through the terminal, ipconfig getifaddr en0 is another useful one; it should show you your current IP address.

[Editor's note: That last command will only work if you're not hiding behind a router of some sort. If you are, it will instead return your local machine's IP number.]
  Post a comment  •  Comments (20)  
  • Currently 2.83 / 5
  You rated: 1 / 5 (6 votes cast)
 
[153,173 views] Email Article To a Friend View Printable Version
Telnet into your .Mac mail account Internet
Here's something I just tried and found that worked ... In Terminal, type (when online of course) telnet mail.mac.com 110 and hit return. Type in user followed by a space and then your .Mac username. 'OK password requred for user ...' should appear. Now type in pass followed by a space and then your password and hit return. 'OK Maildrop ready' should appear. You are now connected directly to your own mailbox on the .Mac Mail server.

Now you can do things with your mail. The command list will show a list of all your email, including the size of each. The command top 2 will show you the contents of email #2, while the command top 2 10 will show you the first 10 lines of email #2. The command dele 3 will delete message #3, while the command quit will log you out of your mailbox. It is very important to use the quit command, because none of the changes you make will take effect otherwise.

Another world changing tip - no doubt!

[Editor's note: I couldn't get top 2 to work; I got a "missing argument" error. But "top 2 20" and other variants worked...]
  Post a comment  •  Comments (31)  
  • Currently 2.50 / 5
  You rated: 4 / 5 (6 votes cast)
 
[13,066 views] Email Article To a Friend View Printable Version
Create a one-step whois lookup script Internet
OS X comes with the 'whois' command, a useful utility for checking domain name registrations and finding domain contacts. It's run from Terminal.app. However, since the advent of all the new ICANN approved registrars for domains, one must run 'whois' twice to actually get some meaningful results if the domain is not registered at Network Solutions. Run whois once to get the whois server that's serving the domain information, and a second time (with the "-h" swtich), to actually query the first referenced whois server.

I've written a little bash script to make this just a little bit easier (and in one step). It's included below in the hopes others may find it useful.
 #!/bin/bash
echo "Getting server..."
export SERVER=`whois $1 | grep -i whois\ server: |
awk '{print $3'}`
echo "Searching server: $SERVER"
whois -h $SERVER $1
[IMPORTAND NOTE: The "export" line must be entered as one line, not two; just replace the line break with a space...]

Copy the above text to your clipboard (Command+C), then fire off Terminal.app to create the script. Start a pico session, as root, and create the script with sudo pico /usr/bin/mywhois. Use Command+V to paste the above text into pico, and save and exit. Now, just make the script executable, by entering sudo chmod +x /usr/bin/mywhois, and you're done!

Now when you run a mywhois macosxhints.com, for example, the first few lines will show:
 Getting server...
Searching server: whois.godaddy.com
The data contained in Go Daddy Software, Inc.'s WHOIS database,
while believed by the company to be reliable, is provided "as is"...
[Editor's note: I tested this an it ran just fine as is in my relatively standard tcsh shell environment.]
  Post a comment  •  Comments (17)  
  • Currently 1.67 / 5
  You rated: 3 / 5 (3 votes cast)
 
[11,995 views] Email Article To a Friend View Printable Version
A PHP script to show current QTSS song on the web Internet
Here is a script that will display the currently playing track info from QT SS on a web page using php.

This was basically written by vonleigh with help from nosaj56 in the forums - thanks guys!
<?php 

// Define path to playlist.current
// Change to match your playlist name and path
$path = "/path/to/QTSS/playlist.current";

// Read playlist.current into $file
$file = fopen($path, "r");

// Read the contents of $file into $content
$content = fread ($file, filesize($path));

// Separate into parts and put in $info array
$info = explode("/",$content);

// Delete .mp3
$song = substr($info[5], 0, -4);

// Make sure to close after you open
fclose($file);

// Print the information
echo "<br> Track: $song <br>";
echo "<br> Album: $info[4] <br>";
echo "<br> Artist: $info[3] <br>";

?>
You might need to change the permisions of the playlist directory with chmod 777 to get it to work.
  Post a comment  •  Comments (2)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[4,601 views] Email Article To a Friend View Printable Version
Wireless net access with Motorola C332 and T-Mobile Internet
I just switched over to T-Mobile Cellular and lo, and behold, there is a USB port on the bottom of my Motorola C332 phone (it's the sorta kidney-bean shaped one with the blue border). The manual said it was for a computer connection and, after some looking around, also a data connection. All I needed was a USB to mini USB (I don't know what else to call it) cable. I then remembered I had one in my Camcorder bag. If you don't have one, they are easily available.

I plugged the USB cable into both computer and cell phone ... and nothing happened. I then went to my Network Preferences and it auto-detected a new Network Port (like Ethernet or Internal Modem) called Motorola Phone (C330). I created a new location called Mobile and put in my dial-up PPP settings (making sure that "Motorola Phone (C330)" was showing by the text "Show:"). Then I went to Modem and saw that there were a whole slew of Motorola modems. After trial and error, the one that worked for me was Motorola iR TimePort (7089).

After saving the configuration, I was able to dial-up through my cell phone and access the internet! Was it fast? No! Was I connected to the internet remotely with no wires except the one connecting my PowerBook to my Cell phone? YES! I thought that was pretty cool. Just a note ... you have to have T-Zones Service to make this work, and there may be charges I am not aware of.
  Post a comment  •  Comments (16)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[10,437 views] Email Article To a Friend View Printable Version
Use Google Mac to restrict search results to Mac only Internet
If you're as big a Google fan as I am, you can go to http://www.google.com/mac and your results will only be Macintosh related. Now there's no need to specify mac or macintosh in the query/input line.

[Editor's note: Google Mac has been listed here on the links page for a while, but I thought it was worth a mention in a hint -- you can eliminate many excess results if you're looking for Mac-specific information by using Google Mac.]
  Post a comment  •  Comments (5)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[5,827 views] Email Article To a Friend View Printable Version
Use a Sanyo 4900 phone as a wireless modem Internet
If you have a Sanyo 4900 phone and would like to use it as a wireless modem, here's how to do it. First, to give credit where credit is due; this document explains how to get things working under Linux. To answer a question on that page, yes, the cable from Sanyo is much cheaper and yes it's the right cable. The phone gets picked up as a standard modem titled "Sanyo USB Phone".

You will also need service. Sprint's latest "vision" plans are pretty well priced, and don't rip you off at all. The only thing that sucks if that the off-peak minutes start at 9 pm, but if you're okay with that, then you can get the phone for $50, and apparently there's a rebate on the phone over at Amazon. I'm going to go look today, but I digress...

[Editor's note: No Sanyo phone here, so this hint is untested...]
read more (266 words)   Post a comment  •  Comments (26)  
  • Currently 3.25 / 5
  You rated: 1 / 5 (4 votes cast)
 
[32,911 views] Email Article To a Friend View Printable Version
Accessing an iDisk with Privoxy installed Internet
If you have Privoxy installed, you'll have trouble mounting your iDisk. To get around this, go to the Proxies tab in Network Preferences and enter "mac.com" in the bypass list.

[Editor's note: I haven't tested this myself, and an earlier hint seems to imply that the bypass setting doesn't work properly. Can anyone using .mac and Privoxy verify this hint?]
  Post a comment  •  Comments (4)  
  • Currently 0.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (0 votes cast)
 
[3,504 views] Email Article To a Friend View Printable Version
Access WAP sites with Opera Internet
Ringtones and logos can be downloaded to cell phones via WAP browsers built into the phone. Often times, these files are only available via WAP and not HTTP. However, the current Mac OS X beta version of Opera will access WAP sites and let you download these files to your Mac. With Bluetooth File Transfer or third party software like Ericsson Client, you can then transfer the files from your Mac to your phone. Great way to avoid airtime charges or if your phone plan doesn't include WAP.
  Post a comment  •  Comments (1)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[5,477 views] Email Article To a Friend View Printable Version