Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

A fix for Vista only seeing one CPU in Boot Camp Install
I've been using Vista Ultimate on my MacBook Pro (Core 2 Duo), and since installing the latest Boot Camp drivers package, it only saw a single core. When booting up, prior to the GUI loading, it would show one system processor in the plain text area where it lists the Windows version. Once fully booted up, the Task Manager's performance window would only show one processor, although Device Manager did show two processors and the About window (right-click My Computer » Properties) did list the CPU as a dual core, though all performance measuring apps listed one as available.

To fix this, you will need to access the Vista NTFS partition from another OS. There are a few hints on how to do this (here's one), and I followed the installation of MacFUSE and NTFS-3G, unmounted the read-only Vista partition, created the directory /Volumes/Windows, then remounted it using the command line:
sudo ntfs-3g /dev/disk0s3 /Volumes/"Windows" \
-o ping_diskarb,volname="Windows"
Then I typed:
ls -al /Volumes/Windows/Windows/System32
You will see three files: hal.dll, halacpi.dll, and halmacpi.dll. You will likely see that hal.dll is the same size as halacpi.dll and halmacpi.dll is a different (larger) size. If this is not the case, then stop reading this hint as it does not apply to you.
read more (124 words)   Post a comment  •  Comments (2)  
  • Currently 1.25 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[12,620 views] Email Article To a Friend View Printable Version
10.4: A quick fix for CA's Threat Manager install script Install
The current release (r8.1) of this fine anti-virus software for Mac OS X has a problem in one of its startup scripts: it confuses Mac OS X 10.4.10 with Solaris 10, and the console will not open.

The default location for the script is /Library » Application Support » CA » SharedComponents » iTechnology » S99igateway. If you want to get the program working quickly (before the next update), comment out the check for Solaris 10 (lines 29-33). The ambiguous result is here:
SunVersion=`uname -a | awk '{print $3}' | cut -d . -f2`
I changed it to simply SunVersion="0", and the script than ran as expected.
  Post a comment  •  Comments (3)  
  • Currently 1.25 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[6,587 views] Email Article To a Friend View Printable Version
An HP All-in-One software installation issue Install
If your system drive was set up with a case-sensitive HFS file system, HP's All-in-One installer will fail when it gets to the HP Setup Assistant -- it will ask you to "Select Device" and give you an empty list. To get the installer to work, you have to install it on a case-insensitive file system. I've confirmed this with version 7.9.1 of the PhotoSmart C6100 series and version 7.9 of the Officejet 7310 series drivers.

The solution? The only one I've found is to re-format and install on a file system that is not case sensitive. After hearing back from HP's tech support, they confirmed the problem and the solution:
Thank you for contacting HP Total Care.

The software for the Photosmart C6180 is not supported on a case sensitive partition. You will have to install the drivers on a case-insensitive partition.
I only wish they had mentioned that anywhere in the online troubleshooting section. Sigh.
  Post a comment  •  Comments (6)  
  • Currently 1.25 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[15,967 views] Email Article To a Friend View Printable Version
Use a Windows Upgrade disc for Boot Camp installs Install
I use Windows PCs to check if my cross platform software, created on a Mac, works properly on Windows. Over the years, I have found myself upgrading OSes on the Windows side, and so I only have upgrade CDs for most versions of Windows. Thus, when it came time to install Windows XP Pro into BootCamp on my MacBook, it got to the point where it wanted to see "an original qualifing disc." But of course, there was no way to eject the disc I was installing from. On a whim, I tried the following...

I restarted, but first hooked up an external drive, and put the old qualifying disc in it. Yep, sure enough ... the system found the original disc in the external, and skipped the step demanding that I eject and insert same. The Windows XP installation then went fine from that point.
  Post a comment  •  Comments (7)  
  • Currently 1.75 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[27,233 views] Email Article To a Friend View Printable Version
Fix an AOL install problem on Intel Macs Install
AOL seems to have a problem installing on multi-core Intel Macs: The installation hangs at "Installing Main Database." I found a successful workaround for this problem. Go to Apple's developer website and download the CHUD tools (Tools Download page; direct download [32mb]).

Once installed, there will be a Processor preference pane in System Preferences. Use this to turn off all but one processor, then run the AOL installer. Once the installer finishes, turn the processors back on.

[robg adds: I haven't tested this one, but I seem to recall that disabling CPUs solved install issues with other apps.]
  Post a comment  •  Comments (3)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[7,371 views] Email Article To a Friend View Printable Version
Installation guide for Tomato firmware on a Buffalo router Install
Tomato is a free, open-source, Linux-based firmware for some wireless routers. The major focus areas for Tomato are stability, speed, and efficiency. It is maintained by Jonathan Zarate. The firmware is notable for its web-based user interface that includes several types of bandwidth usage charts, advanced QoS/access restriction features, raised connection limits which enables P2P networking, and support for 125 High Speed Mode. There are lots of guides on getting the firmware to work with Linksys Routers, but not a clear one for Buffalo routers. Flashing the Buffalo is a bit trickier, but it's worth it because it is cheap and plentiful (check out newegg). Here is a step-by-step guide.

First, you need to determine which router you have. Buffalo doesn't display the exact model number on the box. Unbox the router, and check the back side, where it has info like username, password, router address, and more. You'll find the router model ID code there. This guide applies specifically to the WHR-G54S, but you can also flash the WHR-HP-G54, WZR-HP-G54, and WZR-RS-G54, from what I can find on the web.

Next download the Tomato firmware from the above-linked site. Extract the contents. (You may need to search for a program to extract the 7zip file format; The Unarchiver freeware for the Mac is what I used.) Now look through the folders for a trx folder. Inside that folder is a file named code.trx; that is the new firmware.

Plug the router in, and get the ethernet cable out. Plug one end of the ethernet cable into the LAN ports (be sure it's the LAN port, not the WAN port; this is where I got stuck). Plug the other end of the ethernet cable into your Mac's ethernet port.
read more (566 words)   Post a comment  •  Comments (6)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[40,069 views] Email Article To a Friend View Printable Version
10.4: Prevent a Windows XP install lockup in Boot Camp Install
I nearly gave up in frustration after downloading Boot Camp, making the driver CD, printing out the instructions, and slipping in the XP Pro install disk and then having the installation freeze after just starting to install. I called AppleCare, asked the local certified tech, other Apple geeks, etc. who could not figure out what the problem was, and I even exchanged the system disks because the techs thought they must be defective.

Then, I remembered that -- because my desk was overloaded with the old and new towers, big LCD, and my printer was too far away from the tower -- I had plugged the printer into the keyboard to print the directions. I'd left it plugged in, and the Windows install gagged on the connection. In that moment of enlightenment, I unplugged the printer USB connection to the Apple keyboard, and the installation of XP Pro via Boot Camp went quickly and smooth as silk.

Nowhere did I notice in the instructions to be sure not to plug in anything via the keyboard USB, so it really threw me at first. Simple solution, at least. Moral of the story: Don't plug anything into your USB keyboard connection while installing Boot Camp/Windows!
  Post a comment  •  Comments (3)  
  • Currently 2.43 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (7 votes cast)
 
[14,309 views] Email Article To a Friend View Printable Version
10.4: How to create a partitioned RAID setup Install
I just read this older hint about RAID and partitions on OS X Server, and it seems that it does not work in 10.4. So I tried doing it differently.

I opened Disk Utility from the utilities folder and did the following. On the two disks I would be using, I created equal partions, i.e. all the same size. I named these partitions 1a, 2a, 3a on the one drive, and 1b, 2b, 3b on the second. Then I went to the RAID tab and did this:
  • Dragged the partions 1a and 1b to the RAID window and clicked Create.
  • Dragged the partions 2a and 2b to the RAID window and clicked Create.
  • Dragged the partions 3a and 3b to the RAID window and clicked Create.
Now I had three RAID partitions. I don't know how safe this is, but it seems fine after running some tests.
  Post a comment  •  Comments (5)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (3 votes cast)
 
[13,285 views] Email Article To a Friend View Printable Version
10.4: Create a simpler PowerPC and Intel boot drive Install
Jonathan Rentsch in this article describes how to make a two-partition external disk that can boot either an Intel or a PowerPC Mac, but it required an extra partition on the Intel Mac. My partner Mike Palacio and I did it without the extra partition, using the following method.
read more (290 words)   Post a comment  •  Comments (12)  
  • Currently 2.20 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (5 votes cast)
 
[62,776 views] Email Article To a Friend View Printable Version
10.4: Version Cue / Intel Mac / latest updates woes Install
Tiger only hintI have seven Macs, including two Intel Macs. On May 11, 2006, Apple released 'Security Update 2006 003' and 'QuickTime 7.1' through Software Update. After installing the update, the Intel Macs would no longer boot. Dead. Nada. I called Apple Care, but they could not fix it.

After some futzing, I managed to fix them this way:
  1. Cold reboot and hold the Shift key after the tone (Safe Boot...)
  2. Go to /Library/StartupItems, and remove Adobe Version Cue if it is there
  3. Reboot
[robg adds: I don't have Version Cue, so I can't confirm this one (my Intel mini handled the update just fine).]
  Post a comment  •  Comments (6)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (3 votes cast)
 
[22,972 views] Email Article To a Friend View Printable Version