Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.3: Trash the Help cache files after upgrade installation Install
I was looking up various topics in the new Help Viewer after installing Panther, and noticed to my surprise that there seemed to be a lot of out-of-date information. For example, there were help pages referring to Key Caps, and even a link to launch it (which of course didn't work). Likewise, the pages discussing font installation made no reference to Font Book.

After a few of these, it occurred to me to check for cached help pages. Sure enough, the folder ~/Library -> Caches -> com.apple.helpui -> Mac Help contained a large number of files that predated my Panther installation. I quit Help Viewer, trashed the folder, and restarted Help Viewer. Now there is documentation for Font Book, and searching for "Key Caps" leads to pages describing the new Keyboard Viewer.

So new Panther users who are trying to use the online help to make the adjustment should remember to throw away the old Help cache folder, or else the Help Viewer is more likely to be confusing than helpful.

[robg adds: This will only be a problem if you did an upgrade install (or perhaps an archive and install). Clean installations will (fairly obviously, I hope) have no cache issues.]
  Post a comment  •  Comments (9)  
  • Currently 2.00 / 5
  You rated: 4 / 5 (7 votes cast)
 
[14,392 views]  View Printable Version
10.3: Force Software Update to display installed updates Install
After installing OS X 10.3 and various software updates (Keynote, iSync) which were made availabe by Apple after 10.3, I found out that the installed updates were not displayed in the Software Update PrefPane. I thought "Oh no, not again!" Apple did the same bug as with the update from 10.1 to 10.2! But this time it is different. With 10.2, software updates were not displayed when the permissions of the software update log were wrong. With 10.3, they are not displayed when the format of the log file is wrong. And the format changed with 10.3!

So to fix this, you have to navigate to /Library/Logs/ and edit Software Update.log in your favorite text editor. Remove all lines from updates that were installed before 10.3. You should end up with something like this:
2003-10-24 18:56:14 +0200: Installed "iSync" (1.3)
Save the log file. Go to the Software Update preferences panel and you will see your software updates again!

[robg adds: I think you'll only run into this glitch on an upgrade install. Both clean install and archive and install should give you a clean log file, though I can't confirm that on the archive option (I did clean installs on all three of our machines).]
  Post a comment  •  Comments (7)  
  • Currently 2.71 / 5
  You rated: 2 / 5 (7 votes cast)
 
[13,420 views]  View Printable Version
10.3: Workaround for GeForce4MX install troubles Install
Problem: Apple NVidia GeForce4 MX 32mb AGP video card is not functioning in G4/400 (AGP) after Panther install. This card works fine in Mac OS 10.2.8, but does not work in two consecutive Panther installs - one "archive install" and one clean install.

Proof of problem:
  1. Start Panther installation.
  2. At restart (between disk one and two), the monitor shows an image briefly then switchs to black and never returns.
The origial ATI Rage card that came in the G4/400 (AGP) was having some issues with Keynote locking up, so I purchased this card specifically for Panther usage. It's specs are as follows: Apple NVidia GeForce4 MX 32MB AGP 2D/3D Video Card for PowerMac G4 AGP/Graphics/Gigabit Ethernet/Digital Audio/QuickSilver Models. (1) DVI, (1) ADC Port, (1) DVI to VGA Adapter. New, Supported by Quartz Extreme, 1yr OWC Warranty. (APL661NV4MX32DVKIT) (from macsales.com).

The card is sold as G4/400 (AGP) compatible (even though I believe it is a 4x card and the G4/400 AGP slot is 2x) and has run perfectly before installing Panther. Apple lists the card on the list of compatible Panther cards (last time I checked about two weeks ago).

First Solution:
Switched out the new Apple NVidia GeForce4 MX 32mb AGP video card for the stock ATI Rage video card that came in the G4/400 (AGP), and both installs I had previously begun continue to completion. Mac OS X 10.3 running.

Read the rest of the hint for the second solution...
read more (160 words)   Post a comment  •  Comments (9)  
  • Currently 2.13 / 5
  You rated: 4 / 5 (8 votes cast)
 
[14,520 views]  View Printable Version
10.3: IrDA-compatible PowerBooks may have menubar issues Install
When I grabed my Panther install and updated 10.2.8, everything went fine with one very annoying exception: the menubar, and thus fast user switching, was unusable as the menubar was reloaded every three seconds or so. In Terminal, my ol' friend from Linux days, I discovered that systemUIserver was restarted over and over again. The frequency of its restarts reminded me of the frequency of the flashing IrDA icon when searching for a connection.

I opened ~/Library -> Preferences -> com.apple.systemuiserver.plist and deleted the line containing "IrDA." When I turned on the IrDA display in menubar in System Prefs, the error reappeared, and I could only turn it off via editing the .plist file.

My System: PB Ti 500. Otherwise Panther installed fine on an iBook 800 (update from 10.2.3) and an iMac 233 (clean install).
  Post a comment  •  Comments (3)  
  • Currently 2.25 / 5
  You rated: 2 / 5 (8 votes cast)
 
[7,599 views]  View Printable Version
10.3: Office (and other?) updater issues due to .mac sync Install
While I was testing Apple's seeds of Panther, I ran into a small problem when I tried to install and update Microsoft Office v.X. I think this might help some folks using these updaters (and possibly other Vise updaters). The Office 'drag and drop' installation went fine, but the Office v.X 10.1.2 updater seemed to hang at startup when displaying a "Gathering information..." popup. Quite annoying.

A small look at the currently running processes helped me to solve this mystery: a "webdav mount" process was working quietly along with the installer. Thanks to Panther, if you have a .mac account and if you have activated the iDisk auto-sync feature, your computer will automatically mount your iDisk whenever connected to Internet.

It was the case here, and the updater was busy looking for Office through all mounted volumes, including the whole iDisk, with its "software" directory provided by Apple. Given the tremendous speed of iDisk's webdav, it can take a few hours to achieve this task.

The fix for this problem is pretty simple: just disconnect from Internet when running some Vise updaters, including Office's, and everything goes fine afterwards.

[robg adds: I had this happen with a separate updater this weekend, so I figure this is quite relevant!]
  Post a comment  •  Comments (6)  
  • Currently 2.25 / 5
  You rated: 1 / 5 (8 votes cast)
 
[7,976 views]  View Printable Version
10.3: Easily install and remove custom Preference panes Install
You can now install (and remove) custom System Preference panes, ie; Diablotin, MenuMeters, etc., by dragging them into (and using a contextual menu to remove) of the open System Preferences window. To install, simply drag the new Preference pane to the System Preferences window. You will be asked whether you wish to install the pane for all users or just the current user; make your choice and click Install. To remove, simply control-click on the pane and select "Remove..." from the pop-up menu.

Note: This does not work with PreferencePanes installed with the system.

[robg adds: It also only works for "simple" preference panes that don't install any extra bits. For example, USB Overdrive installs a kernel extension. Removing the pane in this manner will not remove the kernel extension -- it just removes the pane itself. To remove all the bits of more complex panes, you'll want to run the uninstaller that (hopefully) came on the installation disk.]
  Post a comment  •  Comments (1)  
  • Currently 1.67 / 5
  You rated: 3 / 5 (6 votes cast)
 
[14,863 views]  View Printable Version
Qualify your G5 System for Panther upgrade purchase Install
I was very confused when using Apple's online tool to qualify my G5 for the Panther $19.95 up-to-date program. I entered my serial number correctly, but the trick is the "place of purchase" box. I tried "Apple Store," but it didn't work. You have to use "store.apple.com" insteaed.

I have no idea why they just can't go by the serial number, but for whatever reason, you have to have all info correct. I had to look at my order status to get the exact order date. I also had to put my billing state and city for it to work.

[robg adds: I had a bit of trouble with this form, too. I don't think I ever got the ship date correct, and I just used "Apple online" as the place of purchase. I'm not sure what the magical combination is, but after a few tries, mine took ... and according to FedEx, my Panther arrives tomorrow, one day early!]
  Post a comment  •  Comments (2)  
  • Currently 1.50 / 5
  You rated: 1 / 5 (4 votes cast)
 
[3,428 views]  View Printable Version
Force Apple's Bluetooth firmware upgrade to install Install
Apple's Bluetooth Firmware Update tool refuses to update my firmware. And I'm not alone from what I read in the discussion forums. Perhaps I'm already on the latest edition, but I've been having real problems when recovering from sleep (the DBT-120 USB bluetooth module won't come on in most cases, and the blued daemon has to be kill'd) so I suspect I don't have the latest version.

Someone going by the ID of mactechconsulting of Hampton Bays, NY, posted a way around this problem which forces the updater to update your firmware: simply hold the Option key down while starting the update! The full thread can be found here.

Thanks Mac Tech Consulting! :-)
  Post a comment  •  Comments (1)  
  • Currently 3.67 / 5
  You rated: 5 / 5 (6 votes cast)
 
[7,433 views]  View Printable Version
Creating and restoring OS X disk images Install
Here are some easy step-by-step instructions I wrote to create OS X images and how to use those images on other Macs. Some may question the need for two partitions on the target. In our scenario, the users authenticate via LDAP, have a disk quota of 100MB, and I need to give them an alternate location to temporarily store large files for video editing. Feel free to utilize, alter, and plagiarize to fit your situation.

[robg adds: Of course, if you're cloning OS X images, make sure you have licenses for all the machines on which it's being installed. For our use, Apple's five-user family package seems perfect, and it's a great excuse to say "but we need two more Macs to use up our quota!"]
read more (421 words)   Post a comment  •  Comments (15)  
  • Currently 3.25 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[124,905 views]  View Printable Version
Install the Belkin IrDA FSU230 USB Adapter Install
Apple currently sell the Belkin Infrared adapter on their web Apple Store sites, but loads of people have had trouble using it with Mac OS X as it includes a floppy disk with PC drivers on it. After reading loads of sites, and seeing everyone having the same problem, I thought I'd better post the answer I have found...

First, plug the SmartBeam into USB port one on your PowerBook G4 (that's the one closest to the power socket). Turn on your infrared device, and activate its infrared dectection and place it in range of the smartbeam. Now load the Apple System profiler by clicking "About This Mac" in the Apple menu and then the "More Info" button (or via the Applications -> Utilities folder). Click on the "Volumes & Devices" tab and wait for it to load then select "Window" and then the "Refresh" option. The IrDA adapter should now show up as a USB connection.

Load the System Prefs and select Networking, and this should force Mac OS X to find a new Comms Port and it will load IrDA USB Modem into the available options!

Hope this helps all the lost people out there took me a week to crack it -- it worked on PB 12" G4 Superdrive running 10.2.6.

  Post a comment  •  Comments (11)  
  • Currently 2.50 / 5
  You rated: 3 / 5 (4 votes cast)
 
[33,629 views]  View Printable Version