Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

10.3: A possible fix for a black screen during install Install
Many people have run into an issue during Panther install that causes a black screen. I have found that the problem may be caused by certain third-party memory. I removed my third-party RAM and the install went off without any further problems. When I put my third-party RAM back in, it prevented me from changing resolution (I get the black screen again), dragging windows around the screen (they blur), and using the scroll arrows (windows contents blur).

It irritates me that I'm going to have to buy new RAM just because of an OS upgrade, but my Mac being in good health is worth a great deal more to me. Hope this helps anybody who reads it.
  Post a comment  •  Comments (13)  
  • Currently 1.88 / 5
  You rated: 4 / 5 (8 votes cast)
 
[14,709 views]  View Printable Version
10.3: Create a system install DVD Install
I had to install Panther on my wife's iBook and was thinking how my TiBook install DVD (Jaguar) was better than 3 CDs and that maybe it was possible to create a DVD from the CDs. I didn't find anything on the Internet so, from bits and pieces I had read before, I tried to get one DVD from the three CDs. It worked!!

Read the rest of the hint for the how-to...
read more (391 words)   Post a comment  •  Comments (74)  
  • Currently 2.86 / 5
  You rated: 1 / 5 (14 votes cast)
 
[125,194 views]  View Printable Version
Restoring printers after Archive and Install upgrades Install
When you do an Archive & Install of either Jaguar or Panther, even if you select Restore User and Network Settings, printers that you had set up are no longer there. It is pretty easy to get your printers back without having to reinstall them. In the /Previous Systems -> Previous System # -> private -> etc -> cups folder is the CUPS configuration data for printers you had set up prior to doing the Archive & Install. The important files are:
classes.conf   client.conf     cupsd.conf
ppds.dat       printers.conf   certs/*
interfaces/*   ppd/*
As root (or using sudo), copy or move those files from their current home to the /private/etc/cups folder. I recommend that you first rename the files in /private/etc/cups that would be overwritten by the files you're about to move in, just in case.

After copying or moving the files, you need to restart CUPS so that it will re-read its configuration files. Since I end up doing most things under OS X as I am accustomed to doing them on *BSD/Linux boxes, I do that by running the following as root:
/System/Library/StartupItems/PrintingServices/PrintingServices restart
Alternatively, you could run the following, again, as root:
SystemStarter restart PrintingServices
Your old printers should now work again...
  Post a comment  •  Comments (1)  
  • Currently 3.40 / 5
  You rated: 5 / 5 (5 votes cast)
 
[5,964 views]  View Printable Version
10.3: Repair Java after 10.3.1 and Java 1.4.1 installs Install
I waited for Apple's updated Java 1.4.1 for Panther after an upgrade left mine in the dysfunctional state described in an earlier hint. After installing the update today, I decided to check to make sure it was working, and I got the same error. I went to Apple's Developer page and read the originally proposed solutions. I then removed the preference file from Terminal:
 % sudo rm /System/Library/Frameworks/JavaVM.framework/Resources/version.plist 
Then I ran the updater again. Upon restart, the error message was gone. Of note, I downloaded the updater to disk from Software Update, but you should also be able to run it from /Library/Receipts.
  Post a comment  •  Comments (1)  
  • Currently 2.57 / 5
  You rated: 3 / 5 (7 votes cast)
 
[9,477 views]  View Printable Version
10.3: Install screen savers with a double-click Install
I recently downloaded a screen saver module. When I mounted the image file, the screen saver had the standard .saver extension, but the icon wasn't generic. Could it be that Panther recognizes the .saver filetype? I double-clicked the file and was immediately shown a dialog box explaining that the file needed to be installed first, and would like to install it for one user or for all?

This new installation method certainly beats the old method of digging through the Library folder!
  Post a comment  •  Comments (3)  
  • Currently 2.00 / 5
  You rated: 1 / 5 (7 votes cast)
 
[8,108 views]  View Printable Version
A workaround for an Acrobat 6.0 Pro reinstall problem Install
This hint is for those who are attempting to reinstall Acrobat 6.0 Pro.

If you have, for some reason, deleted the Adobe PDF 6.0 folder in the /Users/Shared folder, Acrobat 6.0 Pro will present a dialog box saying that it cannot continue installation when the application icon is double-clicked.

All you need to do is to created an empty folder named Adobe PDF 6.0 in the Shared folder. Then, try launching Acrobat 6.0 Pro again. The installation will proceed and it will install all necessary components in the Adobe PDF 6.0 folder.
  Post a comment  •  Comments (2)  
  • Currently 3.25 / 5
  You rated: 3 / 5 (4 votes cast)
 
[3,950 views]  View Printable Version
10.3: Fix broken Panther with Jaguar Install
Excitedly my employer and I waited for Panther to arrive from Apple. Before I undertook to install it on her "mission critical" TiBook 500 (first generation), I played guinea pig and began the upgrade on my Pismo 400. Oddly the trackpad disappeared until a full shutdown and reboot, but after that all seemed well.

Next came the TiBook. I chose to follow the "Upgrade" path rather than "archive and install" mainly because of the several third-party enhancements (ASM, Default Folder X, Window Shade) we'd installed to fill some gaps in Jaguar. After watching the new blue candy cane spin for about two hours, the install was finally over. To my horror after reboot, the Setup Application crashed, followed by the Finder and every other thing I tried to launch. Even a "safe boot" by holding the shift key produced the same results. I suspected some deviant startup app, but without being able to so much as open a Terminal, I was lost. I re-installed, this time selecting "archive and install," but to no avail, the same thing happened.

Out of desperation, I resorted to installing 10.2, opting to archive. Happily after install I was greeted with a fully functional system, with all third party "enhancements" absent from the control panel. Another two hours and she was updated to Panther and all was well. Previous user files were safely archived and easily dragged to her newly created Home directory. So the moral is -- don't throw out your 10.2 CD-ROMs yet, especially if you suspect unruly startup or system enhancements are crashing your Panther fun.

[robg adds: I'll use this hint for a quick comment on my install preferences: If possible, I do an "erase and install" any time I can for a major upgrade like this. Yes, it's substantially more work, and yes, you need to be very careful that you have a complete and functional backup available before proceeding. But in the end, you wind up with a system that's devoid of any carryovers that might cause problems in the new OS. If you have a partitioned drive, this is also substantially easier -- I keep 95% of my apps on an Applications partition, so a major upgrade doesn't mean I also have to reinstall all my apps, too. I just copy over key prefernce folders and reinstall those apps that just insist on living in /Applications, and I'm good to go.]
  Post a comment  •  Comments (11)  
  • Currently 1.86 / 5
  You rated: 2 / 5 (7 votes cast)
 
[9,951 views]  View Printable Version
10.3: Repair Java after an upgrade install of 10.3 Install
If you upgrade to 10.3 from an earlier version of OS X instead of doing a full install, chances are that Java is broken. To see if you are affected type java -version in the Terminal. If you see the following line, you are affected:

HotSpot not at correct virtual address. Sharing disabled.
Apple has a Knowledge Base article (#120242) about this. You can also find some workarounds at this Readerware page. The second suggested workaround looks the most promising:
After installing my copy of Panther, I encountered the very same error as you. However, I was not about to perform an "archive and install." Instead, I renamed:
    /System/Library/Frameworks/JavaVM.framework
to
    /System/Library/Frameworks/JavaVM.framework.off
effectively removing it from the installer's path. Next, I loaded the Panther installer, and I performed a "Custom" install of ONLY the "Essential System Software" (which includes Java).

Long story short: this works. Panther does not find an existing JavaVM.framework, and thus it does not get confused. When it finishes, you will find a brand new JavaVM.framework directory, and "java -version" reports "builder 1.4.1_01-99", as it should. Once I was certain everything worked, I then deleted the JavaVM.framework.off directory that I had moved aside.

[robg adds: I reformatted the quote a bit, but changed none of the content.]
  Post a comment  •  Comments (8)  
  • Currently 1.50 / 5
  You rated: 2 / 5 (8 votes cast)
 
[19,025 views]  View Printable Version
10.3: Use custom install options to conserve disk space Install
I'm surprised this wasn't submitted sooner. With today's 40+ GB hard drives, this doesn't matter to everyone, but this hint is useful if you like a clean system, with as few unnecessary files as possible, and want to conserve space on smaller hard drives.

Upon installation, the installer declares you need 3 GB to install when you click on a hard drive. 3 GB is what will be needed for a new clean install. However, if you click on the "Customize" button, you'll find options for the applications, language support, print drivers, etc. By de-selecting foreign language support files, and all the printer drivers, I was able to nearly cut the install size nearly in half, to 1.6 GB, also making it install faster!

This is true of every installer, but I was surprised at how much space was saved, and its a good reminder at every new major upgrade.
  Post a comment  •  Comments (9)  
  • Currently 2.33 / 5
  You rated: 5 / 5 (6 votes cast)
 
[12,735 views]  View Printable Version
10.3: Upgrade CDs require existing 10.2 installation Install
I just received the Panther CDs from Apple for the Software Up-to-Date program. Disk 1 from the update set actually has the words "Upgrade Disk" printed on it. None of the other disks, 2 or 3, have the words "Upgrade Disc" on them. I make a point of this because I was doing some testing on a modified cube with a Sonnet Encore/ST 1.2 GHz processor and I wiped the hard drive before doing a clean install to see if the Panther OS would function properly. Disk 1 of the upgrade CD set will not do an install if there is no previous OS X installation on the hard drive.

I compared the Disk 1 CDs, and the serial or version numbers listed under "Version 10.3" are different:
  • Retail CD: 2Z691-4585-A
  • Update CD: 2Z691-4633-A
All the rest of the CD's, 2 and 3, in both Retail and Upgrade versions, list the same serial or version numbers on them, 2Z691-4586-A and 2Z691-4587-A respectively. I took a cursory look at the "Mac OS X Panther Installation and Setup Guide" and there isn't anything mentioning that a previous OS X system has to be installed when using the Update CD's. I hope this spares someone extra time and grief.

[robg adds: This is the same thing that Apple did with the 10.2 upgrades. While I ordered the $19.95 upgrade (to have something as early on Friday as possible), I also purchased the five-user family pack for our posse of machines ("But really, honey, we need to buy two more Macs -- I have these two extra licenses for Panther!"). I prefer having a full install CD available, just in case. I'm disappointed that Apple doesn't think recent machine purchasers are deserving of a full copy of the OS...]
  Post a comment  •  Comments (13)  
  • Currently 1.33 / 5
  You rated: 3 / 5 (6 votes cast)
 
[18,767 views]  View Printable Version