Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

A workaround for the 8gb partition limit on Beige G3s Install
I have around eight Beige G3's and really would like to upgrade them to Panther. So from a previous hint, I checked out XPostFacto. To get Panther to install and run on the Beige G3's, I had to buy a bunch of Radeon 7000 video cards, but Xpostfacto is awesome; I had to use version 3.0a15. Everything works like a charm! Firewire, USB, all iApps (except iDVD), Office, everything!

But there has always been one little annoyance. The OS X installers (including Panther) will only install on the first partition, which has to be 8GB or less on Beige G3s. There's a solution...

I have a bunch of 120GB drives, so I made two partitions with the OS 9 boot disk. First partition was ~119GB, second partition was 1024MB. Then I installed OS 9 onto the 1GB partition. Booted into OS 9 and installed all updates, drivers, and XPostFacto. Then I removed drive from the Beige G3 and put it into a newer Mac, and installed Panther onto the first partition including all updates.

Next, I moved the drive back to the beige G3, booted into OS 9, ran XPostFacto, set the NVram input to "keyboard," and output to the new video card. Finally clicked Restart to OS 10.3.3 and Yahooooo! It all came up just fine. StarWar's Pod Racing even works great under Classic. BTW, I packed these machines with 768mb of ram, 120GB drives, ATI radeon 7000 video cards, and overclocked from 300mhz to 350mhz or so.

Hope this helps those who want a little more life out of their Beige G3's.

[robg adds: I (obviously?) haven't tested this hint, but if it really does provide a workaround for the 8gb limit on Beige G3s, then I know a few folks who will be quite interested, so here it is. If someone does try this, please post if you are successful or not...]
  Post a comment  •  Comments (13)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[15,286 views] Email Article To a Friend View Printable Version
Fix a broken iPod mini Updater Install
When I connected my iPod mini and ran the Updater that comes with the CD, a Mac OS error code 268435459 appeared, and Force-Quitting was the only way out. The solution is to delete the iPodDriver kernel extension located here:

/System/Library/Extensions/iPodDriver.kext

and replace it by running the iPodDriver.pkg installer on the CD. To find it, Control-click and select "Show package contents" on the iTunes4.mkpg file in the iTunes 4.2 folder, and navigate to Contents -> Resources.

Thanks to Walt Griffin on the Apple Discussions boards for this one.
  Post a comment  •  Comments (0)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[6,932 views] Email Article To a Friend View Printable Version
Installing a PCI FireWire card in a G5 Install
I recently bought a Belkin PCI FireWire card for my G5. It is the Dual 2 GHz G5, so I have two PCI-X slots that run at 100 MHz and one that runs at 133 MHz. Initially I installed the card in the 133 MHz slot (slot 4), but when I powered my computer back up, OS X would not recognize the card. It carried power to any connected FireWire devices, but System Profiler did not show any card connected to the PCI slot. I went back and changed it to a 100 MHz slot (slot 3), and now it works flawlessly.
  Post a comment  •  Comments (4)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (3 votes cast)
 
[14,808 views] Email Article To a Friend View Printable Version
Use a non-Wacom tablet in Mac OS X Install
Double-whammy; who can guess what I just bought ...

Part 1:
Unfortunately, Apple doesn't officially support any brand except Wacom for use with Ink. Luckily however, you can force Ink to start and then stay on between reboots. Go to /System -> Library -> Components -> Ink.component -> Contents -> SharedSupport/ and you'll find InkServer.app. Double-click it to start it, and the InkPad should appear on your screen. Once InkPad is open, choose "Open Ink Preferences" and you'll see the Ink prefpane. In the preferences, turn handwriting recognition on. From now on, Ink will appear in System Preferences until you turn handwriting recognition off. Feel free to close the InkPad, you can open it again through the preferences or the menu item without having to dig through /System again.

Part 2:
One of the best apps for using a tablet to draw with is Flash, especially with it's pencil smoothing features. But as luck would have it, use a non-Wacom tablet, and Flash MX crashes as soon as you touch pen to tablet. Not to worry! Those lunatics at Macromedia decided no-one other than Wacom would ever make tablets, so we just have to humour them. Download the Wacom tablet drivers and install them; they don't do anything (they won't even recognise your tablet), but they will stop Flash from crashing and let you use the full feature set (e.g. pressure sensitivity with the brush tool). Enjoy!
  Post a comment  •  Comments (12)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[33,480 views] Email Article To a Friend View Printable Version
Repartition using networked disk images Install
This is about how I installed Linux on a second partition on my Mac, which originally had just one partition containing Panther. It assumes you have access to a second machine on your network, and have installed and know how to use CarbonCopyCloner.
  1. Mount a remote share using SMB. Mounting my Samba shares on my Linux box turned out to be extremely slow (1 MB/s over a gigabit network), so use a Windows server instead. You can also use an NFS share, but see below first.
  2. Start the Disk Utility and create a new read/write (not compressed -- see below) image on the remote share. Don't be cheap! It's better not having to redo everything because you're out of disk space on the image, even if it takes ages to create the image. I think you need twice the amount of space that you will back up in order to make an Apple Software Restore image.
  3. Now make sure there are no mounts in /private/var/automount or CarbonCopyCloner (CCC) will try to backup your entire network! Simply killing the automount process will not work, since it's required by CCC. I shut down the NFS server on my Linux box instead.
  4. Start CCC. In preferences, make sure "Create a disk image on target", "Prepare for Apple Software Restore" and "Read-only" (not compressed!) are checked.
  5. Select source disk and the newly created (and mounted) disk image from step two as target, supply the administrator password and press "Clone." Wait forever while all your data is transferred over the network.
  6. In case you managed to create too small a partition in step two, so that the final step (converting for ASR) fails, you can do it manually using Disk Utility now.
  7. Boot using your OS X CD, repartition and install a basic system. Then log in and transfer the image you created in the previous steps to an empty partition.
  8. Again, boot using the OS X CD. Restore the image that you transferred in the previous step.
  9. Reboot and rejoice for a while.
  10. Install Linux.
NOTE: Something is very wrong in OS X. I don't know what it is, but my machine must have crashed like ten times during the time I tried this. In the end, I had quit using NFS and switched to SMB, created all images using non-journaling filesystems and stopped using sparse disk images. Only then could I complete the backup.

[robg adds: I have not tested this one, and clearly, a FireWire hard drive will make the job much faster -- unless you're lucky enough to have a Gigabit Ethernet network, it's going to take a long time to copy multiple gigabytes of data across the network.]
  Post a comment  •  Comments (1)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[9,416 views] Email Article To a Friend View Printable Version
Try a different CD drive to install OS X on Beige G3 Install
Like many I have endured the frustrations of attempting to install OS X on a Beige G3. Recently I needed to do a fresh install of OS X Jaguar on a beige tower (Rev C) that I knew to be receptive to OS X. I had successfully, if somewhat time consumingly, installed it on this machine in the past.

This time round it was proving to be very unreceptive. I checked the usual suspects: Removed all non essential PCI devices, stuck to a single 128mb stick of RAM, unplugged a SCSI zip drive for the heck of it, made sure the drive and CD were on separate IDE busses, and both set as master, ensured I was installing on a less than 8gb 'first' partition. It just didn't want to go. I tried every combination of zapping the pram, booting into open firmware and resetting it, pressing the CUDA switch again. Still nothing. I then moved to my final 'bright' idea - X Post Facto. I used the 'latest stable release' 2.2.5.... and that wouldn't work either.

Finally something told me that the system might not be liking my Sony DVD-ROM (even though I had used this in the past to install OS X on the same machine). Fortunately I had my original, if somewhat flakey Apple-branded Sony CD-ROM lying around. I put that in, and it booted into the installer first time. Since I'm partial to 'look a gift horse in the mouth' disease, I immediately turned the machine off and switched back to the Sony DVD-ROM to try that again. I wanted to be sure it was the change in hardware that was making the difference. Sure enough -- black screen of death. I switched back to the original CD-ROM, and it booted again first time. Success!
  Post a comment  •  Comments (8)  
  • Currently 1.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (1 vote cast)
 
[6,248 views] Email Article To a Friend View Printable Version
Install 10.3 after using ext3-formatted Yellow Dog Linux Install
I've been trying Yellow Dog Linux 3.0.1 on my iBook, and it's been great. I've put it on my secondary hardisk on my PowerMac. But now my iBook wants to get back to Panther, so I'll restore the image I made of her HD. What I discovered:
  1. A simple "erase" in Disk Utility didn't work.
  2. A simple partition on disk utilities didn't work.
What would happen? Well I'd erase and then partition the drive as HFS+journaled (same as the backed up disk image) and restore it. I tried Carbon Copy Cloner, Disk Utility's restore function, ASR from the command line and NetRestore. All of them left me with a circle with "/" through it. And running Tech Tool pro 4 resulted in a failure of repairing volume structure. Same with DiskWarrior 3. From TTP4's output:
Precheck Structures This test checks the readability of the various volume structures. Precheck Structures
The only thing that worked -- the only method that allowed me to boot into my backup image -- was using Disk Utility's "Zero all data" and "8-way random write format". Then I used Carbon Copy Cloner to copy from the mounted backup image to my super clean ibook. Now Lynn (the iBook) is now enjoying Aqua goodness!
  Post a comment  •  Comments (7)  
  • Currently 2.50 / 5
  You rated: 2 / 5 (4 votes cast)
 
[10,702 views] Email Article To a Friend View Printable Version
A how-to guide to transcode DVD to Divx Install
The purpose of this post is to explain how to take a DVD and transcode it to Divx. A DVD has 4.7 GB of data. The equivalent movie in Divx is about 1.3 GB. This allows you to take a number of movies in your hard drive on your laptop to view on a long plane trip. Thus you avoid carrying your valuable DVDs and thus prevent demage to them.

What drove me to do the solution presented here? I tried finding comercial software for the Mac to do this and I could not find any. There are a number of comercial packages for Windows and some Open source options for Linux, however.

The solution that I found for the Mac is a combination of packages. Some are freeware (DVDBackup, Divx), some are open source (mencode, MPlayer) and some are shareware (ffmpeg GUI front end). The solution works well, but it was a lot of work to find the right software and putting all together.
read more (398 words)   Post a comment  •  Comments (32)  
  • Currently 1.57 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (7 votes cast)
 
[130,666 views] Email Article To a Friend View Printable Version
Install GarageBand on a Mac without a DVD drive Install
GarageBand can be copied over from a successful install to a Mac without a DVD drive. Just copy the main GarageBand application in the Applications folder, then the GarageBand support files that can be found in /Library -> Application Support to the same locations on the other Mac. Since these are huge files, FireWire target disk mode provides for a much faster transfer (or perhaps, IP over FireWire).
  Post a comment  •  Comments (1)  
  • Currently 3.25 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[19,620 views] Email Article To a Friend View Printable Version
10.3: Run multiple package installs simultaneously Install
The 10.3 version of the Installer application can handle multiple simultaneous installs at the same time. Simply open mutiple .pkg files (you don't even have to do it at the same time), and Installer will properly handle things so that core system components aren't updated by two different things at the same time. If you install things this way, you don't have to sit through "Optimising System Performance" more than once.
  Post a comment  •  Comments (1)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (4 votes cast)
 
[6,766 views] Email Article To a Friend View Printable Version