Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Print to a Samsung CLP-500 via alternate drivers Install
I couldn't get this printer to print using the Samsung drivers. So I then used the Xerox Phaser 6100 drivers, which is the same printer, and they worked fine.
  Post a comment  •  Comments (8)  
  • Currently 1.71 / 5
  You rated: 3 / 5 (7 votes cast)
 
[19,751 views] Email Article To a Friend View Printable Version
Use Mac OS X Setup Assistant with cloned drives Install
When installing the copy of Mac OS X that is shipped with newer machines, the "Mac OS X Setup Assistant" lets you copy your user accounts and installed applications from your old Mac to the new one. Though Apple does not advertise it, this feature also works with cloned systems on external hard disks. This can be useful if you don't own an old Mac and want to install from scratch -- just clone your installation, then re-run the installer on your Mac.

Another cool thing is that it works with both FireWire and USB devices, which Apple doesn't promote either.
  Post a comment  •  Comments (12)  
  • Currently 2.14 / 5
  You rated: 4 / 5 (7 votes cast)
 
[11,413 views] Email Article To a Friend View Printable Version
Another possible fix for dead-screen G3 iMacs Install
I think that most of you know the situation: You want to install OS X on an old iMac G3. If you don't update its firmware before the installation, your iMac won't display anything on the screen any more. I had this issue in the past when I didn't know about that requirement. On some models, you get at least a very(!) dark screen, but most will just stay completeley black. Once I even had one which was dark pink. In the past, I used different tricks to revive the dead iMac:
  • Putting the firmware updater into Startup Items and control it blind
  • Removing the HD and installing a bootable OS 9 with a VNC Server (for remote access) on it
  • Attaching an external VGA display (not all models support that, though)
All of the above just to get to the point of running the Firmware Updater. After the update, the iMac still starts with a blank screen. However, after turning it off and on again, it finally works, and you can begin to install OS X. The biggest annoyance is that after you've booted once with the Installer CD, it's already too late. If you have an older firmware, the installer will not be able to continue at the point where you select the destination drive, and after a reboot, your screen is dead.
read more (237 words)   Post a comment  •  Comments (6)  
  • Currently 2.63 / 5
  You rated: 3 / 5 (8 votes cast)
 
[24,329 views] Email Article To a Friend View Printable Version
Reinstalling OS X on a G5 with an nVidia 6800 Ultra Install
I had a faulty internal SATA hard disk (thanks S.M.A.R.T. for alerting me on time!) in my G5, so I decided to add a second internal hard disk and install MacOS X 10.3 anew -- not choosing to use Carbon Copy Cloner because I wanted a 'clean' slate, and at the same time, copy some important data from the source disk. When I booted from the Install disc (Panther), I got the dreaded multilingual message stating I should restart the Mac. Even when I hooked up my trusted rescue 20GB Firewire hard disk, I got the same error!

Luckily, I remembered I had installed the nVidia GeForce 6800 Ultra video card, so I decided to put the G5 in target disk mode (boot holding the T key down) and attach it to my portable with a Firewire cable. Install MacOS X 10.3 on the portable, but select the hard disk that resides in the G5 as the target. Don't forget to update this new Panther volume to 10.3.7, or upon booting the G5, it will still halt.

Of course, you could also fabricate your own "MacOS X 10.3.7" install disk, but this was faster.
  Post a comment  •  Comments (12)  
  • Currently 2.17 / 5
  You rated: 4 / 5 (6 votes cast)
 
[11,616 views] Email Article To a Friend View Printable Version
10.2, Samsung SCX-4100 and D-Link printer setup Install
I was trying to get Mac OSX.2 printing via a wireless network to a D-Link wireless print server (DP-311P) that's connected to a Samsung SCX-4100 multifunction printer. I tried using ghostscript and cups with miscellaneous Samsung foomatic filters (none matching the 4100) with no luck. I was trying to do all configuration via CUPS and not via Print Center. I was finally able to get this to work via the following steps:
  1. Discovered OSX drivers on the Samsung.com support section. Downloaded and ran installation package.
  2. In Print Center (NOT CUPS), you will now see the SCX 4100 as an option. Interestingly (at least for newbie me), you don't get this as an option during the new printer add in CUPS. Using the advanced option in Print Center (hold down the Option key as you click Add New Printer), configured the printer as an "IP Printing" setup using the print server's IP address and the queue name from the print server.
  3. Selected the model of Samsung, then SCX-4100 from the picklist.
Strangely, if you go back to CUPS, you can see the setup as the SCX-4100 and you can now manage the queue from CUPS. The trick seems to be during the initial setup when you have to use Print Center and not CUPS to make the first configuration. This must have something to do with how CUPS sees and doesn't see drivers. Maybe a CUPS guru can explain this or share how to get the subsystem to see the SCX-4100 driver.

BTW, this only works for printing. If you want to set up the scanner functions, I think you have to be cabled via USB. I don't need that function, so I didn't mess with it.
  Post a comment  •  Comments (4)  
  • Currently 1.44 / 5
  You rated: 1 / 5 (9 votes cast)
 
[28,337 views] Email Article To a Friend View Printable Version
Use the Sierra Wireless AirCard 580 (10.3.5+) Install
I would imagine that most people know that Apple introduced support for the Verizon Wireless 3G card in Mac OS X 10.3.5. What most people don't know is that the Sierra Wireless AirCard 580 used by Telecom in New Zealand (and by Sprint in the USA) is the same card. The only reason that Mac OS X does not recognise it is because the Vendor ID is different than the Verizon card.

To fix this, all we have to do is edit the XML text file inside the appropriate kernel extension. Once this is done, your PowerBook will recognise the card and you will be enjoying 3G speeds (415kps from the NZ test site) in no time at all -- as long as you are in Auckland, Wellington or Christchurch at the moment.

Read the rest for the how-to...
read more (308 words)   Post a comment  •  Comments (14)  
  • Currently 1.00 / 5
  You rated: 1 / 5 (6 votes cast)
 
[19,417 views] Email Article To a Friend View Printable Version
Remotely kill the QuickTime pop-up registration window Install
If you administer several Mac OS X 10.3 machines, then like me, you probably ssh in and use the command line to get OS updates like such:
$ sudo softwareupdate -i -a; sudo diskutil repairPermissions /
Briefly, that enters sudo (superuser do) mode, runs softwareupdate (the Apple Software Update Tool) with the -i (Install) and -a (all available active updates) options. It then uses the ; to run another command as soon as the previous command is done. In this case, that command executes Repair Permissions on the boot volume.

But if you're updating QuickTime on a computer that has a user logged in, the QuickTime registration window pops-up and stops the updating process while it waits for user input (from your command line, the install process just stops at about 50%). If you are not at the computer being updated, and you don't have ARD/VNC (graphical remote control) installed on that computer (or you just don't want to bother with it), don't panic. Just open another ssh terminal window to that same machine and then type:
$ sudo killall QT6Install
That should kill only the registration window, and the updating should continue as regularly scheduled. Some notes, to consider...
  1. I believe its called QT6Install, but I don't remember exactly. You can find it by doing top and finding the a command with a higher pid than softwareupdate that looks something like the one I think it is.
  2. My educated guess is that this won't work for any version of Quicktime other than 6.x. :-)
  3. The softwareupdate command for 10.0.x through 10.2.x is different, and it does not use the i and a flags.
[robg adds: I haven't tested this one.]
  Post a comment  •  Comments (14)  
  • Currently 2.29 / 5
  You rated: 5 / 5 (7 votes cast)
 
[12,855 views] Email Article To a Friend View Printable Version
A solution for trouble with an iLife '04 install Install
When I tried to install iLife 04 this morning, it kept complaining about one of the iApps running, but I made sure none were ... and yet, still the same error. So I restarted and tried installing without opening anything. Yup, same error. So I open Activity Monitor and search for iTunes. Voila! Sizzlingkeys4iTunes, which is a program for globally controlling iTunes (website), showed up in the list. Killing the process made the iLife installer run.

It seems that Apple's installer is just searching for "iTunes" in the process list and then making its install/no install decision based on those results. So if you're having trouble getting it to install, use Activity Monitor to look for "iLife-like-named" processes and kill them off, too.

[robg adds: I tested SizzlingKeys, and it adds only that one process to the list, so it certainly seems that this is another example of a semi-brain-dead Apple installer. They're probably just grepping on "iTunes" and running with the results.]
  Post a comment  •  Comments (6)  
  • Currently 2.44 / 5
  You rated: 5 / 5 (9 votes cast)
 
[5,000 views] Email Article To a Friend View Printable Version
Install Final Cut Pro 4 on G3 Macs Install
patoX is an 'enabler' that allows to install your Final Cut Pro applications on your PowerPC G3! patoX won't install without the Final Cut Pro applications; it's just an enabler. You must to have Final Cut Pro, or you will need to buy it, in order to use patoX.

I made an installer for patoX, and you can download it [904KB] if you'd like to try it out.

[robg adds: I haven't tested this one, but I have been asked about FCP apps on G3s before, so maybe this will help a couple folks out...]
  Post a comment  •  Comments (11)  
  • Currently 2.40 / 5
  You rated: 2 / 5 (10 votes cast)
 
[14,384 views] Email Article To a Friend View Printable Version
Install a parallel printer on a Base Station Install
Perhaps because it turns out to be so simple, I have not found simple instructions for installing a parallel printer on an Airport Base Station, and web searches kept turning up pages that made it look much more complicated than it turned out to be. So, here are instructions. I'm using a LaserJet 5MP on an Airport Extreme "Snow" Base Station with OS X 10.2 and 10.3.
  1. Obtain a USB -> Parallel cable. I found one for $19 plus change including shipping on the web.
  2. Connect printer to Base Station.
  3. Restart Base Station.
  4. Open Print Center application (or Printer Setup Utility) on OS X machines that are networked to the Base Station.
  5. Select 'Add new printer.' The LaserJet 5MP showed up automatically as a Rendezvous printer. If you have something different that does not show up, you probably need to install a printer driver.
That's it! No special software required, just the Parallel to USB cable. Everything just seems to work!
  Post a comment  •  Comments (7)  
  • Currently 1.50 / 5
  You rated: 1 / 5 (6 votes cast)
 
[9,856 views] Email Article To a Friend View Printable Version