Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Disable Keyboard Setup Assistant when using a KVM switch Other Hardware
A previous hint suggested a hack for disabling the Keyboard Setup Assistant which has an annoying habit of popping up when using a KVM switch (whether a hardware switch such as the excellent Belkin Flip, or a software one such as teleport with a headless Mac). However, there is a less drastic solution that takes just one click and works with both 10.4 and 10.5 (it may also work on 10.6, but I can't test that myself).

Just click the red close button on the Keyboard Setup Assistant window, as per this Apple Support Document, and it shouldn't pop up again for that (virtual) keyboard. If you do need the Setup Assistant again, you can summon it using the Keyboard System Preferences pane.

Note that you may need to plug a mouse directly into the machine in question if your KVM switch is directing mouse input to another machine.
  Post a comment  •  Comments (1)  
  • Currently 1.94 / 5
  You rated: 2 / 5 (16 votes cast)
 
[9,103 views]  View Printable Version
10.6: Add RAW support for some unsupported cameras Other Hardware
Snow Leopard only hintMy new Olympus E-620 is not (yet) directly supported by Snow Leopard. Since I only shoot in RAW, I searched the web and found that there is a Raw.plist file that can be tweaked. However, that didn't work. I then found out that you need to tweak the RawCamera binary, too (that's a shame Apple, hiding ID Strings in a binary).
read more (417 words)   Post a comment  •  Comments (10)  
  • Currently 2.48 / 5
  You rated: 1 / 5 (21 votes cast)
 
[11,555 views]  View Printable Version
Use a GE Universal Remote as an Apple Remote Other Hardware
My father-in-law gave us his old TV after buying a new set. With it came a very cheap GE Universal Remote (silver and blue, no visible model number) which, knowing him, was the cheapest available option among remotes at the store.

After my dog chewed up the remote to the stereo (Aiwa) that drives audio for my home theater, I decided to look up the programming codes (via this PDF) for the remote.

While punching in the various Aiwa codes, looking for the one that worked, I saw Apple iPod beneath the Aiwa section. After getting my stereo to work, I decided to punch in the Apple code (the iPod code is 0885) and assign it to the VCR button on the remote, which wasn't being used. It worked!

For this specific remote, you just hold down the Setup button until the red light stays on, press the button corresponding to the device you'd like to program (i.e. TV, CABLE/SAT, VCR, DVD, etc), and then punch in the code you want. Some people don't realize it, but you can punch in any code for any button -- the remote doesn't care; they're just arbitrarily-labeled memory locations.

After programming, the remote works to control an iPod in a compatible dock, or any Mac with an IR sensor. I don't know about an AppleTV, but I have to assume it works there, too.

The button layout is a little awkward, and it doesn't work perfectly for some things (third party apps that require that you hold a button down, like Lockdown), but it's pretty nifty nonetheless. On a Mac, you can control system volume, iTunes, sleep/wake, etc.

I'm sure several other universal remotes can be programmed similarly as well.
  Post a comment  •  Comments (6)  
  • Currently 2.42 / 5
  You rated: 2 / 5 (19 votes cast)
 
[17,577 views]  View Printable Version
One fix for a non-working onboard iSight camera Other Hardware
It looks like many people are complaining about a disappearing onboard iSight when upgrading to Snow Leopard, whether it's a fresh install or not. I personally experienced that under Tiger and Leopard. It took me days to figure out where it came from, but I suspected that some software I eventually added was responsible for the problem.

The last time I got the iSight working again, I can't even remember how it happened. Since I'm not very careful when playing with fragile things on Mac OS X, it happens that I break something then get it fixed but don't know how.

Here is a link that saved a bunch of time in troubleshooting such problems, though: Kext Utility x64 v2.3.2

This app simply fixes permissions -- specifically on .kext folder -- so that kernel extensions can be used properly. Moreover, it accepts a .kext file as an argument when drag/dropping a .kext icon on its own icon. So I simply dropped an AppleUSBVideoSupport.kext file icon on it, and that fixed my camera.

I was quite sure this .kext was present, but the program said it wasn't. Don't ask how/why. I'm not sure this hint is very valuable, since I can't add any added value of my own, but the app did work.

[robg adds: I haven't tested this app, and it seems (from reading the associated comment threads) that it's really for those who muck about with system extensions fairly regularly. Still, if you're having an issue with an onboard piece of hardware not working, it might be worth a shot as a fixit tool.]
  Post a comment  •  Comments (0)  
  • Currently 2.43 / 5
  You rated: 5 / 5 (14 votes cast)
 
[8,960 views]  View Printable Version
An IR command for exiting Front Row via EyeTV remote Other Hardware
I am using a Harmony One to control my Mac mini as a media centre. I have eyeTV running constantly, and when Front Row comes up, EyeTV just pauses. After playing with the pyeTV plugin -- I found it was not really reliable for some reason or another (great app tho and kudos to the devs; keep working on it) -- I went in search of another solution.

So I have an EyeTV Diversity tuner setup, and have programmed all of my Apple remote and eyeTV remote control commands into my Harmony One. The only thing that was causing me grief was exiting from Front Row, as there is no one single command on the Apple remote control (you have to click the Menu button some number of times).

Well it seems that the EyeTV Diversity remote control does have an IR command that exits Front Row immediately -- it's the Fast Backward button! The Fast Backward button on the EyeTV remote control sends the correct command to exit FrontrRow immediately (equivalent to pressing Command-Q on a keyboard).

Hopefully this will help some other people out there with a similar problem. For me, it was that last piece of the puzzle.
  Post a comment  •  Comments (9)  
  • Currently 2.36 / 5
  You rated: 2 / 5 (11 votes cast)
 
[7,166 views]  View Printable Version
Proof-of-concept code to add pinch gestures to Magic Mouse Other Hardware
I wrote some proof-of-concept code that allows you to use the Apple Magic Mouse to zoom in/out in the frontmost application with pinch gestures. I've detailed the process of how I got this working in this entry on my blog, including some compilable source code that implements pinch for zoom in/out (in Preview, for instance).

[robg adds: The referenced blog post walks is quite technical, and the end result is some source code that can be compiled to add pinch gesture functionality to the Magic Mouse (you'll need Xcode installed to compile it). As this is a very technical hint, I've chosen to simply link to the blog post instead of recreating it here in full. However, in case the blog ever vanishes, I have recreated the source code in the body of this hint -- but check the blog post first for updated versions.]
read more (636 words)   Post a comment  •  Comments (3)  
  • Currently 3.05 / 5
  You rated: 3 / 5 (19 votes cast)
 
[8,863 views]  View Printable Version
Move forward and back in iCal with the Magic Mouse Other Hardware
The Magic Mouse lets you navigate forward and backward between web pages in Safari or Firefox with a two-finger swipe.

The same two-finger swipe also moves you forward and back in iCal. It works just the same as clicking the forward and back arrows around the day/week/month view control at the top of the iCal window.
  Post a comment  •  Comments (4)  
  • Currently 2.38 / 5
  You rated: 5 / 5 (13 votes cast)
 
[4,829 views]  View Printable Version
10.5: Enable momentum scrolling for Magic Mouse in 10.5 Other Hardware
Leopard only hintThe Mouse System Preferences pane on Leopard does not include an option to enable momentum scrolling like Snow Leopard does. However, by setting a hidden preference, you can get this feature without updating to Snow Leopard.

To enable momentum scrolling, first run the following command in Terminal:
defaults write com.apple.driver.AppleBluetoothMultitouch.mouse MouseMomentumScroll -bool yes
Next, go to the Mouse System Preferences panel, and uncheck and then check the Scroll option. You should now have momentum scrolling enabled.

[robg adds: I don't have a Magic Mouse, so I can't test this one.]
  Post a comment  •  Comments (31)  
  • Currently 3.79 / 5
  You rated: 5 / 5 (62 votes cast)
 
[83,670 views]  View Printable Version
Control volume of attached digital Dolby surround device Other Hardware
Some people are speaking from the "living room of the future:" A television where you can read your emails and surf the web, listen to your music everywhere in your house, and also control everything everywhere. For me, all solutions I've seen until today are not very user friendly. Surfing the internet with the television remote control, problems with all the different video codecs when playing media files on the TV screen, etc.

I've had my own solution for the last three years: A Mac mini (small, quiet, powerful enough) attached to a big LCD TV, a Dolby Surround system, Bluetooth keyboard and mouse, some AirportExpress Base Stations for iTunes access in other rooms and an iPod touch to control them, eyeTV, etc.

There was one small problem with my setup, though: With the Mac connected to an audio device using the digital fibre connector, there's no way to control the system output volume. Pressing the volume keys results in this bezel. From that, I presume that the digital output only transports the signal information and no volume information.

So I had to control the sound volume with an additional remote for the digital surround device. I also had to control the power for the surround device and the LCD TV via that remote. This was very annoying, as I had more than enough remotes on my couch table already.

Finally I found a low-cost solution some weeks ago, and maybe it's worth sharing -- I don't think I'm the only one who's using a Mac as a real digital hub.

read more (707 words)   Post a comment  •  Comments (5)  
  • Currently 3.00 / 5
  You rated: 5 / 5 (11 votes cast)
 
[8,725 views]  View Printable Version
Avoid a bug that makes AirPort-connected drives unusable Other Hardware
We are hearing reports of a bug in the Airport software version 7.4.2 -- access to hard disks attached to the AirPort via USB become unusable after a few hours. You can't even access them through the Finder until the AirPort reboots. It's discussed in this thread on the Apple Forums, but there's been no official comment from Apple.

The solution is to revert to software version 7.4.1. To revert, run the AirPort Utility, click on the Summary tab (once you're in Manual Setup mode), and then click on the word Version -- this brings up a list of previous software versions, making it easy to move back one version.

[robg adds: I was having this problem myself, which was really bad as my Time Machine backups are on the attached disk. Every few hours, I'd have to reboot the AirPort to get Time Machine working again. Downgrading to 7.4.1 has solved the problem (going on two weeks now without a single failure). Note you can also reach the firmware options screen by selecting Base Station -> Upload Firmware.]
  Post a comment  •  Comments (14)  
  • Currently 3.00 / 5
  You rated: 4 / 5 (10 votes cast)
 
[9,438 views]  View Printable Version