Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Make a Home Page button for Safari on iPad Other Hardware
Safari on iPad does not have a Home button. You can save a page link icon on the Home Screen but that does not help when you are already in Safari. The answer is to create a link to your home page in the Safari Bookmarks Bar.
read more (155 words)   Post a comment  •  Comments (4)  
  • Currently 1.75 / 5
  You rated: 2 / 5 (24 votes cast)
 
[44,741 views] Email Article To a Friend View Printable Version
Make some unsupported devices work with the iPad Other Hardware
Some supposedly unsupported devices may still work with the iPad, for example some USB sticks and SD cards never before used with a camera. It is possible to then copy image/video files directly from a Mac or PC to the iPad using the storage media, and not just via a connected camera.

I got an Apple iPad Camera Connection Kit for my iPad to transfer photos and movies directly to the device. Unless you have actually used a camera with your SD card, the iPad will complain that the device is not designed to work with it.

The easy workaround is to manually create a folder named 'DCIM' at the root level of the memory card or USB stick in the Finder on your Mac and you are set. Then put all your movies and pics in that folder. The reason this works is because that's the same folder a camera would make and store on the SD card in the first place. Note that this only works with images and video files supported by the Camera Connection Kit.

[crarko adds: I haven't tested this one, but it seems there are caveats.]
  Post a comment  •  Comments (3)  
  • Currently 2.53 / 5
  You rated: 3 / 5 (15 votes cast)
 
[18,582 views] Email Article To a Friend View Printable Version
Fix an iPad/MobileMe problem with subscribed calendars Other Hardware
If you have subscribed in iCal on the Mac to a password-protected calendar hosted on a WebDAV server and sync with your iPad using MobileMe, chances are that you’re unable to authenticate to the WebDAV-based calendar on the iPad.

After turning on calendar synchronization on the iPad an authorization dialog might appear. Tapping Cancel in this dialog has the effect that no calendar data is being synchronized, not even for the non-WebDAV calendars. Depending on when the authentication dialog appears in the synchronization procedure, your Calendar application on the iPad may either stay empty or any new information will not sync.

The only available solution is to unsubscribe from the calendars in iCal.

[crarko adds: I haven't tested this one. Presumably this is a bug in iPhoneOS 3.2 that will be addressed in some future release.]
  Post a comment  •  Comments (1)  
  • Currently 2.31 / 5
  You rated: 4 / 5 (13 votes cast)
 
[5,695 views] Email Article To a Friend View Printable Version
Fix for poorly performing Magic Mouse on some Mac Pros Other Hardware
When the Magic Mouse came out, I was first in line at the Apple Store to try (and then buy) the heroic rodent that would spare me the aggravation of the Mighty Mouse. It worked fine at the store, but when I got home and tried it on my Mac Pro 1,1 machine, my unit was jumpy and stuttery -- essentially unusable. I read some reports on the Internet about how to make it work better using a USB Bluetooth module. I was just about to buy one when I found the suggestion below.

It turns out that the Magic Mouse is fine, it's the Mac Pro that has problems. This issue is not, as is commonly reported, that the metal case of the Mac Pro impedes the signal. In fact, the antennae are hooked up incorrectly in many of the units.
read more (246 words)   Post a comment  •  Comments (12)  
  • Currently 2.95 / 5
  You rated: 4 / 5 (21 votes cast)
 
[17,201 views] Email Article To a Friend View Printable Version
10.6: One possible fix for 3G ZTE modems in Snow Leopard Other Hardware
Snow Leopard only hintI support quite a few people who use USB 3G dongles; many have moved to Snow Leopard, where some have been having problems. None of these people are having problems with Vodaphone, as they support the Mac very well, and have up-to-date 64-bit drivers.

We were having some troubles with ZTE 622 3G dongles on Snow Leopard, and here's one possible fix. I had a brain wave for these modems, though, as I support other clients on mobile broadband. I noticed that Vodaphone has a driver for ZTE products as part of their mobile connect suite (64-bit as well).

So I downloaded and installed those drivers as a test.

Rather than using the troublesome ZTE Connect, I used the Network System Preferences panel, added the ZTE modem port, and used *99# as number. Presto, a stable connection on 3G with no annoying pop-up saying the driver extension is incompatible or not installed correctly, etc.

Always make sure you disconnect from 3G before unplugging the modem, as you can otherwise cause a kernel panic.
  Post a comment  •  Comments (2)  
  • Currently 2.18 / 5
  You rated: 3 / 5 (11 votes cast)
 
[18,029 views] Email Article To a Friend View Printable Version
Make certain USB webcams work with iChat 4.0.7 in 10.5 Other Hardware
Recently I wanted to switch from Adium back to iChat to take advantage of the video chat feature. To my disappointment, iChat AV 4.0.x in 10.5.8 did not work with my USB webcam, even after installing iUSBCam (formerly iChatUSBCam). For some reason, iChat was not detecting my USB webcam.

I searched in vain for a workaround and hacks. Eventually, I read a related suggestion on another message board about looking at the Console log for processing history. I searched there: nothing; but it did lead me to learning how to find out what processes were in action, in greater detail than Activity Monitor.app provides.

I used sudo lsof in Terminal to scan through a list of the processes in action. I used this command both before and just after starting iChat. Much of the screen text was too complicated and irrelevant to my current plight, but I did notice that QuickTimeUSBVDCDigitizer.component is used for the built-in iSight, and it's located in /System/Library/QuickTime.

This led me to wondering about another USB webcam plug-in that I've used before, maccam. Sure enough, the maccam plug-in component was in the /Library/QuickTime folder. Then I thought, wait a minute. What about installing a copy of this maccam component in the System folder's QuickTime folder?. So I placed the maccam component into the /System/Library/QuickTime folder.

Success! iChat AV 4.0.7 recognized my USB webcam and my PhotoBooth worked as well.
  Post a comment  •  Comments (2)  
  • Currently 2.10 / 5
  You rated: 3 / 5 (10 votes cast)
 
[6,067 views] Email Article To a Friend View Printable Version
10.6: Fix issues with latest version of Logitech Control Center Other Hardware
The Logitech Control Center (LCC) is the name of the driver software for Logitech mice and keyboards. The latest versions still have issues with Snow Leopard; here are a couple of semi-workarounds for some of those issues:

LCC version 3.1:

This version creates weird tabs in Safari if you have a few Safari plug-ins installed. The solution is to remove the /Library » ScriptingAdditions » LCC Scroll Enhancer Loader.osax package and reboot.

LCC version 3.2:

Your mouse pointer may suddenly jump to some other part of the screen, every other minute, making it almost unusable! A lot of people are complaining about it, but still no fix from Logitech. The Logitech 'solution' is to downgrade to version 3.1: uninstall 3.2, reboot, download 3.1 from the Logitech FTP site, install it, reboot again.
  Post a comment  •  Comments (20)  
  • Currently 2.90 / 5
  You rated: 5 / 5 (21 votes cast)
 
[13,582 views] Email Article To a Friend View Printable Version
Some tips on using Tascam USB audio/MIDI interfaces Other Hardware
So, this is a bit of an obscure hint, as it's pretty limited, but if anyone uses a Tascam interface, like the US-122 series or the US-144, for recording or output, here are some usability tips.
  1. Make sure the unit firmware and OS X drivers are up to date.
  2. Sometimes it seems like the unit won't receive enough power. There is a very simple fix for this: Unplug your unit from the USB port and switch Phantom power to Off. Plug the unit back into your Mac, and once it's powered up, then turn on Phantom power. Everything should stay fine.

    It seems that on more recent Macs (Unibody, and some pre-Unibodies) that Apple's power manager doesn't like to give too much power to a single USB port. By keeping the Phantom power off when plugging it in, the computer doesn't know the full power required, and is more than willing to give the unit all the power it needs when the switch is on. Others online have suggested a powered USB hub, and indeed this works, but for my purposes, I want to use the unit away from an outlet.
I've tested this with a Tascam US-122mkII. However, the US-122L, US-122, US-144mkII, US-144L and US-144 are all similar. The US-100 should follow for the same rules, but also doesn't require as much power to begin with.

I've had no driver issues running 10.6.2 and using driver version 2, with device firmware version 2.01. All the updates are available at the Tascam site. I'm currently using a Unibody 13" MacBook Pro (Jun 09 introduction), and have confirmed this with the front and back USB port. Testing on my iMac, the same rules apply.
  Post a comment  •  Comments (4)  
  • Currently 2.15 / 5
  You rated: 1 / 5 (13 votes cast)
 
[10,591 views] Email Article To a Friend View Printable Version
10.6: Fix a file copy issue with SMB, XBMC, and Xbox Other Hardware
Snow Leopard only hintSnow Leopard works pretty well for Windows File Sharing (aka SMB), but sometimes, clients can't copy files larger than 2GB. My setup is Mac OS X 10.6.2 (desktop) with a bunch of EyeTV recordings, and an Xbox modified to run XBMC. OS X shares the recordings using Windows Sharing (SMB). Large recordings will abruptly stop playing at the 2GB mark. Oddly, these same recordings can be copied entirely to Linux clients, so it's definitely the combination of XBMC and Xbox and OS X.

The problem is due to 64-bit locks on 32-bit filesystems. Take a look at /var/log/samba/log.smbd for messages like this:

posix_fcntl_getlock: WARNING: lock request at offset 49543704, length 65534 returned an Invalid argument error. This can happen when using 64 bit lock offsets on 32 bit NFS mounted file systems.

The easy fix is to edit /etc/smb.conf (or /private/etc/smb.conf; they're the same thing) and at the bottom change these lines:
; Site-specific parameters can be added below this comment.
; END required configuration.
Into these lines:
; Site-specific parameters can be added below this comment.
[MyShareName]
    strict locking = no
; END required configuration.
Now turn File Sharing off and back on in the Sharing System Preferences panel. If you don't know your MyShareName, take a look at /var/db/samba/smb.shares, because your entry must match what's listed there.
  Post a comment  •  Comments (5)  
  • Currently 2.61 / 5
  You rated: 1 / 5 (28 votes cast)
 
[14,190 views] Email Article To a Friend View Printable Version
10.6: Make DVD Player work with external DVD drives Other Hardware
My internal DVD drive broke on my MacBook, so I replaced it with an external SATA Sony Optiarc AD-7240S connected to a USB port using a cheap ESATA-to-USB dongle. Everything works great, burns are fast, etc. However, DVD Player in OS X 10.6.2 errored out when trying to play a DVD (VLC played it just fine). The message from DVD Player was "a valid drive could not be found error -70012."

After some net searching, I found the solution here and here. Important note! If you have an internal DVD burner, that drive will no longer be supported by DVD Player after this modification!

You'll need Administrator access priviledges. Navigate into /System » Library » Frameworks » DVDPlayback.framework » Versions » A. Make a backup and a copy (i.e two different copies) of DVDPlayback on your Desktop.

Open the copy with a hex editor such as 0xED. Find the word Internal and replace with External by searching for (hex) 496E7465726E616C and replacing with 45787465726E616C. There will be about four to six matches that need replacing. Save the file and replace the original with your edited version. Make sure you keep your backup file, in case you need to revert your changes.

Repair permissions and unplug your external DVD burner, then restart. DVD Player will now work with the external drive.

[robg adds: I haven't tested this one, for somewhat obvious reasons. If you're going to try it, definitely keep a backup, and proceed at your own risk.]
  Post a comment  •  Comments (15)  
  • Currently 3.33 / 5
  You rated: 5 / 5 (27 votes cast)
 
[52,362 views] Email Article To a Friend View Printable Version