Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

The TripleHead2Go, dual monitors, and the MacBook Laptop Macs
When upgrading to my current Unibody macbook, I was replacing a dual-monitor setup using two computers and Synergy. While there was lots of speculation, I couldn't find any concrete info on how to achieve the same setup with my new Macbook. As such, I decided to share that info here.

I have two 20" LCDs that run at 1600x1200 each. After reading up on the Matrox TripleHead2Go Digital edition, I decided to buy one. After having some initial problems, I was dismayed to find out that the MacBook uses an unsupported chipset, and so their support department was of no help. If you want to take the jump, don't worry, it works, but with a few caveats...
read more (480 words)   Post a comment  •  Comments (4)  
  • Currently 2.64 / 5
  You rated: 4 / 5 (11 votes cast)
 
[31,115 views] Email Article To a Friend View Printable Version
Avoid Kernel Panics upon waking MacBook Laptop Macs
I have a 13" MacBook that I love more than my dog. So far I've had absolutely no problems with it, save for one.

When I'm at home, I operate it with its lid closed and connected to an external Dell monitor. This situation works great until I have to take my laptop into the office. I've found that if I put the laptop to sleep with the external monitor connected, and then wake the laptop later without the external monitor, I receive a friendly Kernel Panic a few seconds after opening the lid.

The solution to avoiding this situation, for me at least, is to open the lid before putting the laptop to sleep, disconnect the monitor, wait for the laptop to recognize that it needs to switch to the internal display, then shut the lid and head off to wherever it is that I'm going.

This kludge helps out a lot in avoiding the problem of spending 10 minutes telling someone how awesome Mac OS X is compared to (insert your operating system here), only to open the lid and watch in horror as your computer crashes.

[robg adds: I don't have a MacBook here to test this with, but my MacBook Pro doesn't exhibit the same problem.]
  Post a comment  •  Comments (17)  
  • Currently 2.00 / 5
  You rated: 4 / 5 (6 votes cast)
 
[13,175 views] Email Article To a Friend View Printable Version
Enable two-finger trackpad taps for 'remote' right-click Laptop Macs
I regularly use Chicken of the VNC (CotV) and Apple Remote Desktop (v2.2) to access a number of various Macs and Windows machines on both LAN and WAN connections. I also have seven other OSs installed with Parallels on my MacBook. Each of these scenarios respond differently to Command-clicking as a substitute for a genuine right-click. Sometimes it works. Sometimes it only respects the Command key. Sometimes I don't have a mouse with me, so I get different results. (The Command-click in CotV is not recognized, for instance.).

Since they all work beautifully with a real right-click, I enabled a feature in the Keyboard & Mouse system preference to use two fingers on the track pad to simulate a right click to see how it might work. Much to my pleasure, it works like a charm! System Preferences » Keyboard & Mouse » Trackpad > [x] Tap trackpad using two fingers for secondary click.

Only rarely do I accidently 'right-click' when I don't mean to, so it's pretty effective and I'm getting better at it after only a couple weeks. It's fantastic. Now, whether I'm in ARD, Screen Sharing, CotV, or Parallels (or *gasp*, OS X!), using a two-finger tap does the right-clicking for me -- consistently.
  Post a comment  •  Comments (6)  
  • Currently 1.83 / 5
  You rated: 2 / 5 (6 votes cast)
 
[11,603 views] Email Article To a Friend View Printable Version
Fix chirping/static in headphones on the MacBook Pro Laptop Macs
Ever since I got my early 2008 MacBook Pro, I have noticed electronic noises in the headphones whenever the Mac went silenct (for example, when a song would finish in iTunes). When I recently got Bose's over-the-ear headphones, I also started hearing static that I didn't notice before. I did some research and found this thread in the Apple Discussions.

The thread is currently 171 replies long, but the solution, found in the middle of the page, is to purchase a Volume Control Headphone Extension Cord from Radio Shack (their part number is 42-2559), or some other inline volume control. Plug in the inline volume control cable, then turn down the volume on the inline volume control and use the computer's volume to compensate. The key is that the control raises the impedance.

Note that this problem is entirely hardware related. Posters in the thread claim that this also affects late 2008 models as well. If you use headphones that already have an inline volume control, already have high impedance, or do not block outside sound very well, you might not have noticed this problem.
  Post a comment  •  Comments (11)  
  • Currently 2.45 / 5
  You rated: 3 / 5 (11 votes cast)
 
[28,592 views] Email Article To a Friend View Printable Version
Possibly fix sleep problems associated with AirPort Laptop Macs
Some Macs will wake up abruptly, shortly after being put to sleep -- apparently due to a bug in the system that's associated with the AirPort wireless card. Specifically if the computer was put to sleep while connected to a wireless network, it may suffer from this problem.

I wrote a free program called Wireless Sleeper that fixes the issue. It runs quietly in the background and will make sure that the AirPort is turned off before the computer goes to sleep. It will also turn AirPort back on when the computer wakes up.

[robg adds: I've never heard of this issue before, and none of our wireless Macs have had the problem, despite leaving AirPort on and connected all the time. Nonetheless, if you are having the problem, this freebie offers a potential solution.]
  Post a comment  •  Comments (9)  
  • Currently 2.14 / 5
  You rated: 1 / 5 (7 votes cast)
 
[15,766 views] Email Article To a Friend View Printable Version
A fix for unrecognized trackpad clicks on new laptops Laptop Macs
My mom recently upgraded to a new MacBook, which has one of them shiny new trackpads. I'm not exactly sure why, but the "Ignore accidental trackpad input" checkbox is not shown in the trackpad preferences on her computer, but the option was somehow enabled. The result was that she would often find that clicking on the trackpad didn't do anything if she'd just been typing, because apparently clicking (even the physical button click) is considered accidental trackpad input, and was ignored.

If you're having this problem, there's an easy solution. Open a Terminal window, and type defaults write -g com.apple.mouse.ignoreTypingFilter -bool NO (then press Return) to disable the ignore accidental trackpad input setting.
  Post a comment  •  Comments (4)  
  • Currently 3.00 / 5
  You rated: 5 / 5 (5 votes cast)
 
[9,357 views] Email Article To a Friend View Printable Version
Reduce loud trackpad click on Unibody portables Laptop Macs
Lots of the new 2008 MacBook and MacBook Pros exhibit a much louder trackpad click that the older models. There have been numerous posts suggesting solutions like stuffing Kleenex between the battery and underside of the trackpad. Probably not the best idea to place a combustible item like tissue next to the battery.

However, if you turn the notebook over and pop out the battery, you will reveal the underside of the trackpad. There you will find a tri-blade screw (it's got a Y-shaped head) that adjusts the travel of the trackpad button and the force needed to register a click successfully. This screw is actually quite easy to turn using a small flat bladed screwdriver, so no special tools are required.

Turning the screw clockwise will reduce the required travel, and also dampen the sound of the click itself. Turning the screw counterclockwise increases the travel, and provides a much more audible click.

Note: I would advise turning the screw an 1/8th of a turn, test, then repeat until the desired effect is achieved. Tightening the screw too far will result in the inability to register a click at all, and may result in damage to the trackpad mechanism itself. You are, of course, responsible for any damage you do to your Mac if you try out this hint!
  Post a comment  •  Comments (5)  
  • Currently 3.50 / 5
  You rated: 5 / 5 (6 votes cast)
 
[15,995 views] Email Article To a Friend View Printable Version
Control iTunes with iPhone headset Laptop Macs
This might be obvious, but I just discovered that if I plug my iPhone headphones (the Apple-supplied set) into my late-2008 MacBook Pro, I can control iTunes just as I control music playback on my iPhone -- the button on the cord lets me play, pause and skip a song.

[robg adds: I imagine you can also jump back a song, too, using a triple-click as described in this hint. I'm not sure what other portable Macs this may work on.]
  Post a comment  •  Comments (8)  
  • Currently 2.67 / 5
  You rated: 3 / 5 (6 votes cast)
 
[15,989 views] Email Article To a Friend View Printable Version
A tip for a faster change-app gestures on touchpads Laptop Macs
It is now well-known the four finger gesture to change apps. You swipe four fingers, right or left, and a bezel with open apps appears, as with Command-Tab. Then if you swipe with two fingers, you will select a different app, which can be switched to by tapping with four fingers.

One thing I saw today is that you don't have to release all your fingers after the four-finger swipe and the two-finger swipe. Simply make the first swipe and only release two fingers; the system will recognize correctly the new gesture, and you save a bit of time.

A similar thing happens with the zoom gesture in some applications such as Preview: you can zoom-in and zoom-out without release your fingers. Safari behaves a bit differenlyt: you can zoom-in/out without releasing your fingers, but it will only increase/decrease the page size once (Preview performs a continuous zoom). For larger zooms in Safari, you need to release your fingers.

On the other hand, a change between zoom and scroll is not possible, at least not in Preview or Safari.
  Post a comment  •  Comments (3)  
  • Currently 2.00 / 5
  You rated: 5 / 5 (8 votes cast)
 
[8,902 views] Email Article To a Friend View Printable Version
How to possibly fix an 'ALLOC-MEM too big!' error Laptop Macs
Over the weekend, my 12" PowerBook G4 was involved in an incident that, I thought, spelled certain doom for my all-time-favorite Apple laptop. I was using the machine with it perched on my knees, and happened to be applying the Safari software update when disaster struck. The update was at that point where the OS has shut down and the progress bar is marching across the screen. Just then, our youngest child came sneaking up on me and applied a running hug-tackle (I was on the sofa at the time, but hug-tackles can happen anywhere). At impact, the PowerBook flew off my knee and landed on the back right corner on the (thankfully) carpeted floor. When the machine hit the floor, it instantly kernel panicked, and I thought "well, that couldn't have happened at a worse time."

When I tried to boot it, I got a chime, but nothing else. Every trick I tried, including booting from a CD and setting it up in FireWire target disk mode, failed. Then I tried resetting PRAM, which also didn't work...but it did boot the machine into Open Firmware, so I knew the machine was functional at the lowest level. Typing mac-boot at that point, however, resulted in a scary-sounding error: ALLOC-MEM request too big!. From the sound of it, I thought maybe it was something with the RAM, but I wasn't sure. A quick trip to Google on another Mac found the answer to my problem in this blog post.

It turns out that (at least on this PowerBook, and probably others) the ALLOC-MEM too big! error is caused by a loose AirPort card. You can find instructions on reseating AirPort cards for various PowerBooks in this article on Apple's support site, and the linked blog post contains photos of the process.

After pulling and reseating the AirPort card, my PowerBook G4 started right up just as if nothing had happened -- hooray!
  Post a comment  •  Comments (6)  
  • Currently 3.71 / 5
  You rated: 2 / 5 (7 votes cast)
 
[11,587 views] Email Article To a Friend View Printable Version