Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Pause Classic when not in use Classic
Occasionally, I still need to run some apps in Classic. When I do, it's annoying that Classic uses a good chunk of my CPU (30%-60%) even when it's in the background doing nothing. One fix for this is to pause Classic by sending the TruBlueEnvironment process a stop signal, like so:
killall -STOP TruBlueEnvironment
This will pause Classic so that it doesn't eat your CPU. When you're ready to use Classic again, unpause it by doing this:
sudo killall -CONT TruBlueEnvironment
You have to use sudo because attempting to restart the process as a regular user will result in an "Operation not permitted" error. I haven't yet been able to figure out why this is.

[robg adds: You can use this technique to pause any process, as explained in this hint.]
  Post a comment  •  Comments (6)  
  • Currently 3.17 / 5
  You rated: 4 / 5 (6 votes cast)
 
[6,781 views]  View Printable Version
10.4: Use older Sherlock to search by filename Classic
Tiger only hintSometimes one needs to just search for a certain filename (like it was possible in 10.3 and before) without indexing the volume first. People have tried the strangest setups to achieve this, but there is actually a much easier way -- without installing any third party utilities: Sherlock 2!

Never used before (at least by the submitter), suddenly it now seems like a great app. Select the "find file" mode, enter the filename and search away, super fast. Beware: Needs Classic!

[robg adds: I no longer have any Classic apps installed, so I can't easily test this one...]
  Post a comment  •  Comments (13)  
  • Currently 2.80 / 5
  You rated: 5 / 5 (5 votes cast)
 
[9,073 views]  View Printable Version
10.4: A fix for certain Classic apps not starting Classic
Tiger only hintI had a couple of Classic applications that had been refusing to open since an Archive & Install upgrade to Tiger. They would show up as only an "application" in the Get Info window, and would also say that they were set to Open with Script Editor. Double clicking on them would result in Script Editor launching and complaining about being unable to load the dictionary.

I did a search on the Apple discussions areas a couple of weeks ago with no luck -- the same search tonight turned up this thread in which the suggested fix was to add a ".app" extension to the offending program(s). This did work, but it got me thinking that maybe the problem was related to file extension interpretation.

When I looked at the names of all the programs affected, I saw that they all ended with a single numeral "extension," which was part of the version number of the app. That is, any app with a single numeral from 1-9 following a full stop was exhibiting the problem, while those with a ".0" or double digit "extension" were OK. I changed a working copy of "Adobe PageMaker 6.52" to "Adobe PageMaker 6.5.2," and it changed its status in the Get Info window and made it fail like the other apps. Then I changed a non-working "Disk Copy v6.4" to "Disk Copy v6.40," and it fixed the problem.

It doesn't explain why someone else on the discussions area is having problems with .sea files, but it probably solves most of the problems people are having with this.
  Post a comment  •  Comments (3)  
  • Currently 1.80 / 5
  You rated: 2 / 5 (5 votes cast)
 
[7,821 views]  View Printable Version
Remove Classic cleanly Classic
When I updated to 10.4, I realized I hadn't used Classic for a very long time. I wanted to remove it, and prevent the Classic System Preferences pane from appearing. Lots of hints describe messing with the system parts to do this, but it felt pretty untidy to me, so here's what I did.

You can't simply trash the System Folder that is used for OS 9, as a booted OS X won't let you -- it says it's in use. I rebooted in single user mode (hold Command-S at startup), mounted the drive writable and removed it that way. Once at the singleuser prompt, do
$ mount -uw /
$ cd /
$ rm -rf 'System Folder'
Be very careful with your spaces and escapes, or it's bye-bye to the /System folder (the actual OS X folder!), which would be very bad.

That's the system taken care of.
read more (204 words)   Post a comment  •  Comments (29)  
  • Currently 2.78 / 5
  You rated: 3 / 5 (9 votes cast)
 
[89,763 views]  View Printable Version
Print from Classic using native OS X printer drivers Classic
There have been a few other hints posted describing how to send jobs directly to CUPS via the command line. At the school where I work (with over 500 Macs), we've been using our own version of this idea since September, with great results.

Since most of our printers are on our network, rather than being connected locally, handing off print jobs from Classic to OS X allows us to:
  1. Eliminate all Classic printer drivers except for LaserWriter 8
  2. Print from Classic via TCP/IP easily
  3. Make clear to our users which printer they're printing to
This helps keep our administrative overhead down by letting us ignore Classic printing specifics, eliminate the Chooser, and keep AppleTalk (which never worked very well in OS X) turned off. The big difference between our method and those that have already been published is that we get feedback about our printing jobs through the regular Panther interface (i.e., the Printer Setup Utility and the printer proxy apps).
read more (327 words)   Post a comment  •  Comments (13)  
  • Currently 2.50 / 5
  You rated: 4 / 5 (4 votes cast)
 
[24,106 views]  View Printable Version
Printing to any printer from Classic Classic
I still use WordPerfect and Freehand 9** on a regular basis; both are non-Carbonized applications, and run under Classic. This is all well and good until it's time to print. For Freehand, since I'm usually printing weird paper sizes, I have to plug my USB DeskJet printer into my laptop and print directly. But if I'm printing standard letter size, I really wanted to be able to print to the old PCL laser printer connected to the house server. But printer sharing only works from OS X. What to do?

Simple. Set up a Folder Action. It works like this: in Classic, I choose the LaserWriter8 (or some other PostScript printer driver) in the Chooser. Then I "print" to a file, not the printer, and save the resulting file to a folder (that I've already bookmarked for convenience) that I call "Printing Box." I usually save it as PDF, but that might be an option I have just because I have full Adobe Acrobat installed. I modified my script so that you don't need Acrobat to make this hint work.

** Yes, I know there's Freehand MX. But even though Freehand 9's AppleScript support is grotesque and pathetic, I do use it. Freehand MX has the same tragically incomplete dictionary; however some of those AppleScript commands that at least work in 9 are broken in MX. I'm hoping, probably foolishly, that they'll at least get FH12 back to the minimum level of utility that 9 has (which, by the way, is the same dictionary as FH5).

Read the rest of the hint for the script...
read more (269 words)   Post a comment  •  Comments (8)  
  • Currently 3.50 / 5
  You rated: 4 / 5 (4 votes cast)
 
[10,425 views]  View Printable Version
Consistent app launching from 9 to X Classic
This one is for users, like me, who need access to OS 9 applications (WordPerfect and games) now and then. It's actally kind of lame, but I haven't seen it anywhere else -- maybe it will help someone.

Apple did a fantastic job with Classic, but there's kind of a culture shock associated with going back and forth between Classic and OS X. One of my biggest problems was the inconsistency between applications available from OS 9 and OS X. I've come up with the following configuration that seems to cover all the bases.

The main consideration is whether or not you have Classic configured to use preferences from the global Classic environment or from your Home account (this is in the Advanced tab of the Classic preferences panel). If you are running preferences from home, make sure you have the folder ~/Library -> Classic -> Launcher Items. If you don't, you may have to do a little finagling -- this might include launching Launcher (from Control Panels) and/or copying /System Folder -> Launcher Items to your user Classic directory. If I remember correctly, this was taken care of for me.
read more (359 words)   Post a comment  •  Comments (2)  
  • Currently 1.67 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (3 votes cast)
 
[6,374 views]  View Printable Version
Print from Classic and OS X with an HP Laserjet 1012 Classic
After my trusty Personal LaserWriter 300 finally died, I bought an HP LaserJet 1012, in no small part because of the heavily-advertised Apple compatibility. Let's just say I found HP's Apple support leaving me with something to be desired (*cough* like support *cough*). I finally got the printer to work under OS X, but could never get it to work with applications running in the Classic environment. As a workaround, I would save documents as Postscript files and then use Preview to convert to PDF before printing. A relatively simple workaround, but not an optimal solution.

After searching everywhere (including HP's website) for a solution, I decided to check MacUpdate for updated printer drivers. I didn't find one for the LaserJet 1012, but I did find this one for the color LaserJet (version 1.52). I decided to try it despite poor reviews on MacUpdate.

The installer said it was installing files for both Classic and OS X. After I selected the printer from the Chooser under Classic, and set it up from the Print & Fax preference pane in Panther (10.3.5), I was able to print directly from Classic apps and OS X.

  Post a comment  •  Comments (25)  
  • Currently 3.00 / 5
  You rated: 5 / 5 (5 votes cast)
 
[28,742 views]  View Printable Version
An OS 9 / Classic fix for unmountable FireWire drives Classic
I have had a ongoing problem with miscellaneous FireWire drives that won't mount. Clicking on the grayed-out drive in the Disk Utility only creates an endless beachball. After trying DiskWarrior, Data Rescue, and other various tools that were no help, I tried booting into OS 9 (sorry newer Mac owners) and the drive immediately showed up on the desktop. When I booted back to OS X, all was well and the disk just worked.

Next time it happened, I just started Classic and the drive came right up. I don't know how or why it happens, but it has worked with other clients' computers, as well.
  Post a comment  •  Comments (5)  
  • Currently 2.75 / 5
  You rated: 5 / 5 (4 votes cast)
 
[10,091 views]  View Printable Version
Access recent Classic documents from the dock Classic
As someone who still used a bunch of Classic apps -- sometimes with no choice, like QuarkXpress, sometime just becuase I like to use fast old apps when appropriate (Photoshop 3.0 is FAST for simple things), I am often frustrated that my recent documents don't show up in the OSX 'recent item' option in the apple menu. I used to keep the Chooser, or some other control panel (the Classic Calculator works, too) in the dock, just to have a lightweight application launch to give me the Classic Apple menu, with its Recent Docs and Recent Apps options.

But then I remembered that those Classic menu options reference a directory on the hard drive, so I just put that folder in the dock. To find it, just go to the Classic Apple menu, choose Recent Documents and let go without choosing a document. You'll see the folder opened in the Finder. Use Command-3 to see column view and drag the Recent Documents folder to the dock. I love having the click-and-hold access to the list of documents so handy. This would also, obviously, work with Recent Applications, but I already have the "Applications (Mac OS 9)" directory in the dock. Long live slim and speedy old apps!!
  Post a comment  •  Comments (5)  
  • Currently 2.50 / 5
  You rated: 5 / 5 (4 votes cast)
 
[4,966 views]  View Printable Version