Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!

Use Acrobat to print PDFs that fail in Preview Apps
We have a Brother 1270N ethernet printer which works in OS X quite nicely most of the time. It will, however, occasionally fail to print PDF's in Preview. The printer spits out a page, but it just says "ERROR NAME: limitcheck ... COMMAND: Type42BuildGlyph ... OPERAND STACK". Not exactly what I was expecting to see. I just assumed it was a fault of the printer driver or maybe a graphic in the PDF file.

Not sure why I hadn't tried it before, but tonight I discovered that the bundled Acrobat Reader printed every one of my troublesome PDF files perfectly. Needless to say, I've now switched my default app for PDF's to Acrobat Reader!
  Post a comment  •  Comments (0)  
  • Currently 4.00 / 5
  You rated: 3 / 5 (2 votes cast)
 
[3,156 views] Email Article To a Friend View Printable Version
Recover from Eudora Beta crashes Apps
Steve Harley sent the following around to Omni's OS X Talk list, and gave permission to republish it here. If you're using the (now fairly old) Eudora OS X beta, here's his tip to recover from a particularly type of crash:
although it's probably my most used app, i've had only about one crash per month since late summer from Eudora, and this is the first that caused any kind of harm -- when i attempted to restart Eudora, it drew some but not all of the windows i had open, then immediately quit. i did a little bit of juggling of settings and preferences files and found that my Eudora Settings file was the problem.

my backups are a little stale, so as an experiment, i set out to explore and possibly repair the resources in the corrupt file in ResEdit. but as soon as i opened the corrupt settings file, ResEdit informed me it had made "minor repairs". i just saved it and tried it out --
success!

so if Eudora X gets in a state where it won't fully start up, try opening (a copy of) "Eudora Settings" in ResEdit.
In a follow-on email, Ben H. recommends not using command-W to close windows while Eudora is doing anything else. He's found that this almost always guarantees Eudora will crash.

Anyone have any word on when (if?) Eudora Final for OS X will be out?
  Post a comment  •  Comments (0)  
  • Currently 2.50 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[2,590 views] Email Article To a Friend View Printable Version
Utilize pop-open folders in Mail.app Apps
Not sure if this is a new functionality, but users of Mail.app might be pleased to know that it supports pop-up windows, sort of. You can drag a message(s) from the main window to either side, the mailbox drawer will slide out. Continue holding the message(s) over an account title - the arrow will flash and open down (like list view). Continue holding/opening folders/mailboxes within that account until you've found the place you'd like to put your email...

Now if they'd just put that into the Finder!

[Editor's note: I also don't remember if it worked in 10.1 or not - anyone out there who has NOT upgraded yet who could test this?]
  Post a comment  •  Comments (6)  
  • Currently 3.67 / 5
  You rated: 3 / 5 (3 votes cast)
 
[2,241 views] Email Article To a Friend View Printable Version
Use PropertyList Editor for plists Apps
[Editor's note: I can't believe I never published anything about this before, but it appears that it's only been mentioned in comments. So now it's a full-fledged hint, thanks to Dan M, who submitted the following.]

After reading over some hints on this site, I've noticed that many direct you to open the XML plists (property lists) in a text editor and work from there. I very recently discovered that this is not necessary in many cases.

If you install the Developer Tools, one application that is included is called "PropertyListEditor". If you simply double click on the property list you wish to edit, it should open in ProperyListEditor, and it provides a very simple means for editing your plists. (If it doesn't open, the editor is in /Developer/Applications)

One help article I read on this site described how to go through the complex (painful) process of removing the preview from the column view of the Finder windows. I managed to do the same thing, without all the complexities (i.e. I opened the Finder's plist, went down to the column view prefs, and changed the 'Preview' boolean from 'yes' to 'no'. Logged out then in, and VOILA! no preview), and I did it in UNDER 30 SECONDS.

I think that this will have a drastic impact on the way I customize my system, and I hope it makes your world a little easier, too.
  Post a comment  •  Comments (4)  
  • Currently 3.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[9,430 views] Email Article To a Friend View Printable Version
Use HOBLink to connect to Windows servers Apps
I don't remember seeing this app mentioned here and I think many might find it really useful. It is a java based application for connecting to a Windows Terminal server. Make sure you download the "for unix" version without Java VM, it contains only one file install.bin, execute it from the shell as
./install.bin
This will bring up a java based installer and after that it is easy. I didn't test it very extensively but managed to connect to Win machine in a first attempt and it looked fine and relatively fast (faster than VNC) on my Lombard. For more info visit the HOB web site.

[Editor's note: I'm unable to test this app, as I have no access to a Win2K server. It's a commercial package with a try-before-you buy eval that has no functional (only time) limitations -- which I applaud. If you need this connectivity, HOBLink may be a solution for you.]
  Post a comment  •  Comments (5)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[4,020 views] Email Article To a Friend View Printable Version
Remove Timbuktu's floating icon menu Apps
If you're annoyed with the Timbuktu floating-icon-menu thing (like i was), you can kill it with this command, in the terminal:
   kill `cat /var/run/TimbuktuHost.pid`
(the apostrophes are done with the lower-case tilde (~) key). Note that this will also prevent your computer from being accessed through Timbuktu remotely.

The menu should come back next time you restart the Timbuktu application.

You can also create an Applescript application and put it in Timbuktu's "Startup Items" folder:
   tell application "Terminal"
run
do script with command "kill `cat /var/run/TimbuktuHost.pid`"
end tell
[Editor's note: I don't have Timbuktu, so I can't vouch for what this tip may or may not do...]
  Post a comment  •  Comments (2)  
  • Currently 2.00 / 5
  • 1
  • 2
  • 3
  • 4
  • 5
  (2 votes cast)
 
[5,799 views] Email Article To a Friend View Printable Version
DVD movies, Ti books, and external monitors Apps
People with Titanium Powerbooks have been trying to figure out how to watch a DVD movie only on an external monitor, instead of in "mirrored" mode which runs both screens and leads to slow and jerky movie playback. Dave P. mailed the following to the Titanium G4 mailing list, hosted by www.themacintoshguy.com:
To watch a DVD on an external monitor only, you need to start the TiBook in "clamshell mode". The steps to do that are:
  1. Shut down the PowerBook as well as the TV (or VCR if that's what you connect the video to).
  2. Hook up the cord from the S-Video port to the TV (I use my VCR's VIDEO IN port). Use the adaptor from S-Video to RCA jack, if necessary (which is what I have to use). That adaptor came with my TiBook.
  3. Turn on the TV and/or VCR
  4. Start the TiBook
  5. As soon as the screen lights up (before you get the Happy Mac face), close the lid entirely
  6. Watch the Apple on the lid (which usually lights up)
  7. When that light goes out, open the lid back up
  8. Your video will be on the TV, but not on the Mac's screen
  9. Enjoy your DVD!
I don't own a Ti, but readers on the list report that this process works. For more Ti news, subscribe to the list...
  Post a comment  •  Comments (12)  
  • Currently 2.00 / 5
  You rated: 2 / 5 (2 votes cast)
 
[5,129 views] Email Article To a Friend View Printable Version
Use iDVD2 movies in any theme Apps
iDVD2 ships with a number of pre-made themes, many of which have impressive full-motion background video. If you elect to use the custom theme, you also get a pre-defined set of buttons and layout positions. Although you can change the look of the buttons, you cannot change their positions without switching to free-form placement. Free-form placement solves the problem (you can rearrange any of the preset themes to look like any of the others), but it's quite hard to make the movie clips align perfectly when using free-form placement.

I was trying to use the "Sky" theme, but with full-movie buttons instead of text-only (the theme's default). But if I simply used a new button shape which included the video, the buttons overlapped, since the theme was defined based on text-only buttons. And with six videos to place, I did not want to do them each by hand in free-form mode. With a bit of digging, I found an easy solution.

To use a custom theme movie as a background in any other theme, control-click on the iDVD2 application and select "Show Package Contents." Then browse to Contents/Resources and notice all the .theme files. Control-click on the one you're interested in, and again navigate to Contents/Resources. You should see two .mov files, one in NTSC format and one in PAL format. Simply drag the movie into the Image/Movie well in iDVD2 and you're done - a background movie from one theme used in another. One you're done, save the custom theme as a favorite to make it easy to re-use.
  Post a comment  •  Comments (0)  
  • Currently 2.33 / 5
  You rated: 1 / 5 (3 votes cast)
 
[2,353 views] Email Article To a Friend View Printable Version
Easily create Filesharing shares Apps
[Editor's note: This article has been updated with information about a newer version of SharePoints...]

Earlier this week, a published hint explained how to use NetInfo Manager to create shares that are visible via Apple's Filesharing. Tonight I received a submission from Michael Horn concerning a quick application he created to handle one piece of this process. The name of the new application is SharePoints, and it handles the creation of the required NetInfo entries.

It's a basic application, but it does greatly simplify the process of managing shares. Basically, you run SharePoints to add or remove the NetInfo entries, and then manually set the privileges on the folder and stop and restart filesharing. Given less than two days work and at a cost of $0, SharePoints is a great little application! If you're interested, click the above link and give it a look.

For the paranoid (myself included): If you're interested in the steps I took to protect my machine before running a program from an unknown source that requires the Admin password, read the rest of the article. My point in providing the information in the remainder of this article is not to make accusations about SharePoints, but rather to explain how I handle any program which could potentially damage my machine.
read more (323 words)   Post a comment  •  Comments (2)  
  • Currently 2.33 / 5
  You rated: 1 / 5 (3 votes cast)
 
[5,975 views] Email Article To a Friend View Printable Version
Recover from a crashing Mail.app Apps
Yesterday, after the Aqua window server unexpectedly quit (due to some combinaton of Classihack, XDarwin 1.0.4.1, xchat, and the GIMP, I think) -- which drops you instantly back to the login screen (ouch!) -- I couldn't get Mail.app to run anymore. I'd start it up, the window would start displaying, and then it would quit. I've been using Mail for over a year, and this was the first real problem I'd had with it.

I tried all the 'usual' stuff. Trashed the prefs. Emptied my POP email via another program. Moved all my mailboxes out of the path. Booted in OS 9 and ran Disk First Aid. Booted single user and ran 'fsck -y'. Even copied a Mail.app from a known working system. Nothing worked. So I went looking for help, and found this thread on the MacFixIt forums. Turns out that three of us had the exact same problem yesterday!

On someone's suggestion, I tried logging in as another user, and was quite surprised to find that Mail.app ran perfectly. About the same time, I received a response from the X4U mailing list with the solution to the problem. Somehow, my ~/Library/Addresses folder had been damaged (probably by the Aqua crash). By moving this folder out to the desktop, I was able to run Mail as my normal user again. All three of us in the forum stumbled onto the solution at about the same time last night :-).

Now the only remaining question is if there's any way to recover some of the address book information. Probably not, but I'm going to investigate a bit more today.

-rob.
  Post a comment  •  Comments (1)  
  • Currently 5.00 / 5
  You rated: 5 / 5 (2 votes cast)
 
[3,988 views] Email Article To a Friend View Printable Version