Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Move PC Outlook email to Mail.app' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Move PC Outlook email to Mail.app
Authored by: pediger on Jul 13, '07 06:00:56PM

I couldn't get this to work. I've been struggling for a while to move some business email over to my own server with little luck. Here's what I've tried:

1) Dragging to an IMAP server within Outlook - Creates those dreaded winmail.dat attachments. I think it was creating them on all messages whether they had attachments or not.

2) Bought O2M - This is where Outlook/Exchange is biting me, I think. A few issues. The display part of addresses there contain a comma (Last, First (Dept) <addr@corp.com>), which O2M does not put quotes around. So once I get these to my server, Mail.app treats them as multiple addresses. Second, all addresses in To: and CC: only contain the display name, not the email address, for internal Exchange people. Third, all messages come over as unread. (I have written to littlemachines about all of these.)

3) libpst - Compiled with a number of warnings. When run, I get the following and the file that I think should be the mbox is empty and the other contains VCARD headers around email messages! Any clues? (Oh, and I did have to build a new '97 pst file. It really choked on the Outlook 2003 file.)

Opening PST file and indexes...
debug_fp is NULL
ERROR: Unknown block constant - 0X2 for id 0x262
About to start processing first record...
Processing items...
Processing Folder "Deleted Items"
No items to process in folder "Deleted Items", should have been 0
Processing Folder "test"
"test" - 3 items done, skipped 0, should have been 3
"test" - 0 items done, skipped 0, should have been 0
Finished.

4) Outlook in Parallels/VMware via pst - Even this doesn't work well. While most of the To: and CC: address do contain actual email addresses, the From: address again only contains the display name. I guess it's just a link to the Exchange GAL.

Anyway, I haven't given up. I can at least move messages. They're just messed up in one way or the other.

Any thoughts or additional recommendations? Especially nice would be forcing Outlook to embed all addresses in the pst, but that's not really for this board to help with. Although for those who are getting libpst to work, I'd be interested to know if you are having similar issues with an Exchange account.

Can Thunderbird import mail from both the pst and the INBOX?

Cheers



[ Reply to This | # ]