Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Take iSight snapshots during invalid login attempts' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Take iSight snapshots during invalid login attempts
Authored by: unforeseen:X11 on Jul 01, '07 12:39:39PM

Stopped working for me with OS X 10.4.10. Any solutions in sight?

---
this is not the sig you`re looking for.



[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: tehrob on Jul 01, '07 05:26:32PM

I have had the same problem, and the app does work if run from the command line.

If you just type in:

$: /usr/libexec/authdightd

and leave the terminal window open, the picture is captured upon invalid login attempts. (through fast user switching for test purposes)

Unfortunately, the plist file stored in the /Library/LaunchDaemons folder does not seem to actually be loading at boot.

If anyone has an alternate way to run at boot, it would be very much appreciated. I have tried to contact the developer twice via email and have gotten nothing in response.

Thanks!



[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: rosshettel on Jul 02, '07 10:58:36AM

Yeah, it stopped working for me too. I uninstalled it and tried reinstalling the package again, but now the package keeps telling me that there's an error and it can't continue. Wish I knew what exactly that error is though. I emailed the author just now, so if I hear anything I'll post here.



[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: tehrob on Jul 02, '07 01:39:30PM
The author has de-install instructions on his sight.

http://www.zdziarski.com/projects/authsight/

plus I think that package is a bit more updated than the one here. it includes email support that I haven't gotten to work even when propperly installed yet.

the only other thing I would do is look in your recipts foder and delete the install recipt for authsight. It is at:
/Library/recipts/AuthSight.pkg

If I delete that I get install as an option again, rather than update.

Also, if you try and install an earlier version on top of the newer 1.4 version you get a error saying there is nothing to install.

Still trying to get it to load at boot some other way, including via the StartupItems folder, which has been a learning experience, nothing working so far.

[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: rosshettel on Jul 03, '07 07:00:07AM

Thanks for that receipt tip. I thought I had deleted it, I followed those instructions, but it turns out I just must've missed it.

So anyways, I dot it installed again, and I'm at the same place you are; it'll work if I leave it running in the terminal.

However, it returned "FATAL: graphics exporter failed" and there's no picture saved. Now, I have MacLoJack installed too, and I just noticed that the iSightCapture isn't working either. Is there something in 10.4.10 that broke iSightCapture too?



[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: tehrob on Jul 03, '07 03:20:36PM

i believe that error comes up if it doesn't have permission to, or there is no directory to put the captured file in. I have seen it before myself.



[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: rosshettel on Jul 04, '07 02:18:46PM

Yeah, I just needed to fix permissions and that did it. Thanks. Still didn't fix isightcapture in maclojack though. it seems that permissions arent whats wrong



[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: rblok on Jul 03, '07 10:24:39AM

1. isightcapture is working only with sudo, was it the same way in 10.4.9?
2. authsightd says not able to authenticate user
Think they changed something in com.apple.SecurityServer, can't be in SecurityUpdates, i think i installed all of them before 10.4.10

Who knows how to downgrade to back to 10.4.9?



[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: rosshettel on Jul 04, '07 01:48:22PM

ive gotten isightcapture to work without sudo. i think they did change something in 10.4.10. havent heard anything from the programmer though.

hopefully theres a way to fix it, id prefer not to go back down to 10.4.9, i just got insomnia working with .10



[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: rosshettel on Jul 04, '07 02:02:41PM
I was poking around the logs and found this in asl.log:
[Facility launchd] [Sender launchd] [PID -1] [Message com.zdziarski.authsight: exited: Terminated] [Level 5] [UID -2] [GID -2] [Host Lucy]
and I found the part you were talking about not authentcaiting user in authsight.log:
CAPTURE ON [Time 2007.07.03 13:55:32 UTC] [Facility authpriv] [Sender com.apple.SecurityServer] [PID -1] [Message authinternal failed to authenticate user rosshettel.] [Level 3] [UID -2] [GID -2] [Host Lucy]
Hopefully this helps.

[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: rblok on Jul 04, '07 02:11:10PM

thats the point where i stuck to: is the problem a changed security server or an other isight-usb-id?? in fact: isightcapture stopped working in 10.4.10 thats why authsight don't work anymore.
Today i tried to downgrade and installed 10.4.9 with pacifist - very very bad idea, aqua stopped from starting and it ends in fullscreen terminal



[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: kme on Jul 08, '07 08:49:57PM
I'm also in the same boat. Reading from STDERR when `authsightd' calls `isightcapture' I see this error:
FATAL: setting data channel failed - cam busy/not connected ?
Haven't quite figured out why yet though...

[ Reply to This | # ]
Take iSight snapshots during invalid login attempts
Authored by: tehrob on Jul 09, '07 02:12:06AM

I encountered this when the program was already running, and then running it again.

Might be something else for you, but try quiting the program, and then attempting to incorrectly login again.



[ Reply to This | # ]