Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Xerox Phaser 8560 and Quark 6.5 PDF incompatibility' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Xerox Phaser 8560 and Quark 6.5 PDF incompatibility
Authored by: geordie on Mar 08, '07 10:07:27AM

I have seen some issues in the past with the XEROX PPDs and how they refer to the cups filter and PDEs.

There were a few revisions of the PPDs that used relative paths which made some apps somewhat confused. Then there would be stuff from the Postscript that the backend was looking for that did not exist. If the backend tried to use those values which had not been assigned to, then bad things would happen.

I don't have a problem PPD here, but a line like:
*cupsFilter: "application/vnd.cups-postscript 0 /Library/Printers/Xerox/PDEs/pstoxeroxps"

might be written as
*cupsFilter: "application/vnd.cups-postscript 0 ../../PDEs/pstoxeroxps"

Normal CUPS lpr worked fine with that, but some custom print streams did not. The solution was to hand modify the PPDs or to get newer drivers (or older ones for that matter) from Xerox.



[ Reply to This | # ]