Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Got networking working...' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Got networking working...
Authored by: huntercr on Jun 15, '06 06:40:34AM
OK here's how to get the virtual ethernet device to work with the Vista Public Beta under Virtual PC for OS X 7.0.2
  1. Install Vista public beta via the methods previously described in this thread
  2. login and install the Virtual Machine Additions ( and reboot )
  3. Copy the file \Windows\System32\drivers\dc21x4.sys from a Virtual PC session of Windows XP ( with Virtual Machine additions installed ) to the vista machine
  4. Copy the INF file net21x4.inf from Win XP ( or at an online repository like this: INF dump to the vista machine
  5. put both files in a folder in a location of your choice ( desktop is fine )
  6. open up the control panel -> device manager. If your ethernet card shows up with a driver ( it will say something like 21140 emulated ), click on the card and click on "update driver", or it may say "unknown device". If your card does not show up at all, use the Add hardware object instead of device manager.
  7. Select "browse my computer for driver software" and specify the path to the files we obtained in steps 3-5.
  8. you should be good to go! ( you may need to reboot )


PLEASE don't ask me any questions about how you can get a copy of these files without Windows XP. I will not respond to any requests for these files.
ALSO, Please don't ask me to help with further network configuration. This is vista specific and is out of scope!
Now you should be able to activate Windows Good luck everyone!

Charles

[ Reply to This | # ]