Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Socket error' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Socket error
Authored by: robg on Apr 04, '01 02:28:02PM
Is the safe_mysqld demon running? Type ps- aux | grep "mysql" and see if you get anything back other than the "grep" command you just ran. If you only get one line (the grep command), then you need to make sure you start the mysqld demon before trying to use mysql -- do this by typing (as root) safe_mysqld in the bin directory of mysql.

Not sure this is your problem, but the "ps" command will tell you (at least) if the demon is running.

[ Reply to This | # ]
Socket error
Authored by: wusamah on Apr 04, '01 11:31:04PM

hi
thanks for the response.
i actually do have mysqld running. i tried launching safe_mysql and it tells me that it can't find mysql at the libexec lib even though i've cd to the mysql directory as instructed. I get the same error socket error when i try msyqladmin anything.

when i tried your suggestion it did only gave a one line response:

254 0.0 0.1 1384 304 std S+ 0:00.03 grep mysql

but i have no clue what that means. the frustrating thing is that the first mysql install ran very well (i downloaded tenon's version.) it wasn't until i ran mysql_install_db that things got screwy. now i'm depressed, i've lost my appetite and even thinking about jumping off the brooklyn bridge. help.

thanks



[ Reply to This | # ]
safe_mysqld isn't running
Authored by: robg on Apr 05, '01 02:02:31AM
Your 'ps' output should look more like this:
root   437   0.0  0.1     1720    644  p2- S      0:00.05 sh ./safe_mysqld
root 450 0.0 0.2 11320 1112 p2- S 0:00.17 /usr/local/mysql/libexec/mysqld
robg 452 0.0 0.0 5724 168 std RV+ 0:00.02 grep mysql
So for some reason, the safe_mysqld program isn't starting up. Do you see any errors, or can you find an error file named "localhost.err" in /usr/local/mysql/var? If so, 'cat' it to see what it says... -rob.

[ Reply to This | # ]
safe_mysqld isn't running
Authored by: wusamah on Apr 05, '01 10:58:08PM

hi
well right after i posted my last message i thought of doing something unorthodox and run mysql_intall_db again. suddenly the socket works, mysql works and i have no idea why it did.

again thanks for your time and effort.



[ Reply to This | # ]