Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


easy fix | 56 comments | Create New Account
Click here to return to the 'easy fix' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
easy fix
Authored by: iroiro on Jan 09, '06 11:40:45AM

I've found a fix that works for my iBook running 10.4.2.

I noticed this bug a while ago (about 10.4.1) and found that whenever it occured it loaded up the 'generic RGB profile.icc' which is found at /System/Library/ColorSync/Profiles/Generic RGB Profile.icc

I normally use the default 'color LCD proile' (/Library/ColorSync/Profiles/Displays/Color LCD-4270A80.icc) which disappeared from finder whenever the bug occured. Anyway, all I did was to copy the Color LCD profile (or the one you normally use) and rename it to 'Generic RGB Profile.icc' and replace the one in /System/Library/ColorSync/Profiles/

This worked great as whenever the bug occurs it just loads the same coloursync (notice the correct spelling :-) properties and I don't notice a thing (in fact I forgot about the bug entirely until I read this post).

Note: the normally used profile won't be in /Library/ColorSync/Profiles/Displays/ if the bug has already happened - a reboot will bring it back and then you can copy and rename, replace easily. Also you should probably make a backup of the default Generic RGB profile as well.

Let me know if there is anything that is not easily understandable in my post and if this doesn't work for other people.


Iroiro



[ Reply to This | # ]
easy fix
Authored by: WilksRendai on May 09, '06 09:23:31PM

Thanks Iroiro,

This same bug occurs under 10.3.9 on my G3 iBook Dual USB 900Mhz, but i noticed it was exclusive to when Noone was currently logged in. When you use the "switch user" command, the profile doesnt refresh, and it's fine, but if everyone logs out, bouya, its screwy.

But Iroiros' fix seems to be holding. Now if only i could lock down the display profile for my Nextbase SDV17-A, whose timing goes out, and X.3.9 thinks it's the VGA adapter, when its Video.... jeez, the difference 10Hz can make.....



[ Reply to This | # ]
easy fix
Authored by: VirtualWolf on Sep 06, '06 02:28:12AM

Ack, don't do that!

I was mucking around in the /System/Library/ColorSync/Profiles folder a while back, and ended up with iPhoto screwing up its thumbnails (newly imported photos appeared black). I had to use this hint to solve it.



[ Reply to This | # ]