Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the '10.4: Configure Spotlight to index excluded directories' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.4: Configure Spotlight to index excluded directories
Authored by: sdunlapa on May 11, '05 08:00:15PM

I have changed my _rules.plist to this:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs$
<plist version="1.0">
<dict>
<key>EXCLUDE</key>
<array/>
<key>INCLUDE</key>
<array>
<string>/private</string>
<string>/var</string>
<string>/usr</string>
<string>/System</string>
<string>/Library</string>
</array>
<array/>
<key>NOTE</key>
<string>Specify paths to include or exclude, preceeding rules which target user-$
</dict>
</plist>

I have re indexed and still Spotlight will not find the folders or anything in them. What have I done wrong?

BTW I used pico under root to change this file.



[ Reply to This | # ]
10.4: Configure Spotlight to index excluded directories
Authored by: blgrace on Jun 13, '05 11:06:24PM

I used pico too and it doesn't work - unless you remove the extra <array/> after the </array> - - if that makes sense.
If you don't - the _rules.plist just gets over-written back to default.
The following worked for me:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/Propert$
<plist version="1.0">
<dict>
<key>EXCLUDE</key>
<array/>
<key>INCLUDE</key>
<array>
<string>/usr</string>
<string>/System</string>
<string>/Library</string>
<string>/private</string>
<string>/var</string>
</array>
<key>NOTE</key>
<string>Specify paths to include or exclude, preceeding rules which target user-homes wi$
</dict>
</plist>



[ Reply to This | # ]
10.4: Configure Spotlight to index excluded directories
Authored by: valexa on Jul 31, '09 08:50:44AM

the hint does not work anymore , i tested on Leopard
1 - cleaned cache and created a fresh one with sh-3.2# sudo mdutil -E /
2 - sh-3.2# du -h -d 1 /.Spotlight-V100
259M /.Spotlight-V100/Store-V1
309M /.Spotlight-V100
3 - added to _rules.plist in INCLUDE
<array>
<string>/private</string>
<string>/var</string>
<string>/usr</string>
<string>/System</string>
<string>/Library</string>
</array>
4 - rebuilt cache
5 - sh-3.2# du -h -d 1 /.Spotlight-V100
259M /.Spotlight-V100/Store-V1
308M /.Spotlight-V100

as you can see the database has the same size as before



[ Reply to This | # ]