Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Strange events while installing' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Strange events while installing
Authored by: nider on Feb 20, '02 12:01:53AM

When Software update was installing and optimising 10.1.3 i was unable to launch any applications. They would unexpect edly quit and the console would display some info. I believe this is what it said but i am unsure of the correct log to retreive it from.

------------Excerpt from log file-----------

Feb 20 11:31:29 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayBounds (display 0)
Feb 20 11:31:29 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayDepth
Feb 20 11:31:29 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayBaseAddress
Feb 20 11:31:29 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayRowBytes
-----DNS QUERY WAS HERE-----
Feb 20 11:31:29 MacAdminX WindowServer[905]: CGSNewRegionWithData
Feb 20 11:31:32 MacAdminX last message repeated 22 times
Feb 20 11:31:32 MacAdminX lookupd[208]: DNSAgent: dns_send_query_server - timeout for 10.225.0.10
Feb 20 11:31:32 MacAdminX lookupd[208]: DNSAgent: dns_fqdn_query_server - query failed for 10.225.0.10
Feb 20 11:31:33 MacAdminX WindowServer[905]: CGSNewRegionWithData
Feb 20 11:31:34 MacAdminX WindowServer[905]: CGSNewRegionWithData
Feb 20 11:31:34 MacAdminX WindowServer[905]: CGXSetWindowTransforms: Invalid array ptrs
-----DNS QUERY WAS HERE-----
Feb 20 11:31:50 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayBounds (display 0)
Feb 20 11:31:50 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayDepth
Feb 20 11:31:50 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayBaseAddress
Feb 20 11:31:50 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayRowBytes
Feb 20 11:31:50 MacAdminX WindowServer[905]: CGSNewRegionWithData
-----DNS QUERY WAS HERE-----
Feb 20 11:33:49 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayBounds (display 0)
Feb 20 11:33:49 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayDepth
Feb 20 11:33:49 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayBaseAddress
Feb 20 11:33:49 MacAdminX /Applications/Microsoft Office X/Microsoft Word: kCGErrorIllegalArgument : CGSGetDisplayRowBytes
Feb 20 11:33:50 MacAdminX WindowServer[905]: CGSNewRegionWithData
Feb 20 11:33:50 MacAdminX last message repeated 26 times
Feb 20 11:33:50 MacAdminX WindowServer[905]: CGXSetWindowTransforms: Invalid array ptrs
Feb 20 11:34:55 MacAdminX /Applications/Fire/Fire.app/Contents/MacOS/Fire: kCGErrorIllegalArgument : CGSGetDisplayBounds (display 0)
Feb 20 11:34:55 MacAdminX last message repeated 31 times
Feb 20 11:34:55 MacAdminX /Applications/Fire/Fire.app/Contents/MacOS/Fire: kCGErrorIllegalArgument : CGSGetDisplayDepth
Feb 20 11:34:56 MacAdminX /Applications/Fire/Fire.app/Contents/MacOS/Fire: kCGErrorIllegalArgument : CGSGetDisplayDepth
Feb 20 11:34:56 MacAdminX WindowServer[905]: CGXAddTrackingArea: Invalid window 1148346727



[ Reply to This | # ]
Strange events while installing
Authored by: jokke on Feb 20, '02 03:46:31AM

After reading your post, I tried launching Preview while the installer was optimizing and had the same result: Preview would not launch and I got all sorts of error messages in my system.log [of the kind kCGErrorIllegalArgument: some-sort-of-command]. Furthermore, my Explorer failed to display popup-menus [among others giving the error WindowServer[74]: CGXOrderWindow: Invalid window 0].
Then my Dock suddenly died and trying to open a new window in the Terminal failed as well. I guess the update is messing with a lot of system stuff, including the WindowServer. Those one-click-one-reboot updaters a giving Apple some trouble it seems.
Now I'm just hoping to post this reply and that my system will boot properly.



[ Reply to This | # ]
Strange events while installing
Authored by: jokke on Feb 20, '02 04:01:15AM

More things happened after I posted the previous article. I guess I should have waited for the installer to finish...
When the installer was done, Explorer exited abruptly, then when I clicked Restart, the installer died. Choosing Restart from the Apple menu didn't work. Again lots of errors in the log. The only way I got back was by typing 'sudo reboot' from the Terminal, which - thank god - was stille alive.
Luckily everything seems to be working again.



[ Reply to This | # ]
More strangeness
Authored by: nider on Feb 20, '02 06:38:47PM

As you can see from my log the last thing i launched was fire. When i did this the system gave me the spinning cursor and nothing responded so i had to reboot



[ Reply to This | # ]
Strange events while installing
Authored by: meancode on Feb 20, '02 05:05:42AM

all OS X updates, at least recent ones, dont let you run spacific apps when you are doing an update. this usualy is the base OS X apps, i have seen this include IE in on update or another.



[ Reply to This | # ]
Strange events while installing
Authored by: Fritz on Feb 20, '02 11:29:21AM

I am wondering how many of you folks that have been experiencing trouble have installed things like Fink, Xfree86, Open SSH etc... I have none of those things yet installed but have been real close to doing that this week.

I have a little iMac DV SE graphite G3 400 that I have been using with the ram bumped up to a gig. I had no problems with the 10.1.3 upgrade at all. This thing is impressive in its handling OSX so far.

Anyhow just curious



[ Reply to This | # ]
Strange events while installing
Authored by: charlietuna on Feb 20, '02 05:01:03PM

I had no problem installing 10.1.3, and I am a total fink junkie. I'd be concerned with peoples' installations of GNU-Darwin material, though, since it replaces Apple-installed components like OpenSSH. (Fink installs these items in another directory and then changes system settings to prefer those components over the Apple ones.)



[ Reply to This | # ]
Strange events while installing
Authored by: clmensch on Feb 20, '02 10:44:15PM

I too encountered something odd. During "optimization", my TiBook 550 completely froze. The mouse cursor still worked, but there was no response from anything else. I had IE, Terminal, X3, Launchbar, and BBEdit running...probably not too smart. I let it sit for a couple of minutes just to see if it would come back from its catatonic state, but it never did. So, I took a deep breath and ctrl-apple-powered it. The machine seemed to reboot fine with the exception of some invalid leaf nodes in what appeared to be some temp files during the filesystem check. But, it brought me back to the login panel and the system now reports 10.1.3 is installed.

I'm curious about what happens during "optimization". Am I missing out that this process didn't complete? Is there a way to optimize again? What's the best way to verify that the installation was actually complete? Perhaps I should download the update and try again...but I'm afraid that might be dangerous.



[ Reply to This | # ]
Strange events while installing
Authored by: clmensch on Feb 20, '02 11:04:20PM

I looked at some logs, and found some interesting entries:

/Library/Logs/AppleFileService/AppleFileServiceError.log:
!!Log File Created On: 2/20/2002 0:16:55 50:3:0 GMT
20/Feb/2002:00:16:55 -0500: Appletalk service couldn't be enabled.
20/Feb/2002:22:06:18 -0500: Appletalk service couldn't be enabled.
20/Feb/2002:22:23:59 -0500: Appletalk service couldn't be enabled.

/Library/Logs/DirectoryService/DirectoryService.error.log:
2002-02-20 00:16:46 EST - Reference error = -14071
2002-02-20 22:06:09 EST - Reference error = -14071
2002-02-20 22:23:51 EST - Reference error = -14071

I don't know what these services do exactly, but these seemed to occur during installation and optimization of 10.1.3. Also, these lines were in console.log:

Mac OS X Version 10.1.3 (Build 5Q45)
2002-02-20 22:25:17.702 SystemUIServer[308] Lookup in pbs of server "services" failed.
2002-02-20 22:25:19.657 X3[314] Lookup in pbs of server "RulebookServer" failed.
2002-02-20 22:25:19.658 X3[314] Can't connect to pbs object "RulebookServer"
2002-02-20 22:25:25.559 LaunchBar[309] Lookup in pbs of server "RulebookServer" failed.
2002-02-20 22:25:25.559 LaunchBar[309] Can't connect to pbs object "RulebookServer"
2002-02-20 22:25:31.712 SystemUIServer[308] Thread 0x800013b8: tossing reply message sequence 1
2002-02-20 22:25:31.715 X3[314] Thread 0x800013b8: tossing reply message sequence 1
2002-02-20 22:25:31.718 LaunchBar[309] Thread 0x800013b8: tossing reply message sequence 1
Feb 20 22:26:11 localhost WindowServer[294]: CGXDisableUpdate: Updates disabled by connection 0x5403 for over 1.000000 seconds

Looks like maybe launchbar was causing problems, but maybe something else was responsible? Feel free to add any thoughts...



[ Reply to This | # ]
Strange events while installing
Authored by: mcon on Feb 27, '02 09:48:31AM

Got very similar messages myself. Been trying to track it down for the last few days. No luck yet, and no mention anywhere i can find regarding 'RulebookServers'. The applications listed are both complaining, then throwing the complaint after a timeout, so some link or pipe isn't being made.

Any help appreciated.

mc

Mac OS X Version 10.1.3 (Build 5Q45)
2002-02-27 14:10:15.632 Console[359] Exception raised during posting of notification. Ignored. exception: connection timeout: did not receive reply
2002-02-27 14:10:24.080 OmniWeb[360] Lookup in pbs of server "RulebookServer" failed.
2002-02-27 14:10:24.080 OmniWeb[360] Can't connect to pbs object "RulebookServer"
2002-02-27 14:10:24.178 Terminal[358] Exception raised during posting of notification. Ignored. exception: connection timeout: did not receive reply
2002-02-27 14:10:24.566 Stickies[363] Lookup in pbs of server "RulebookServer" failed.
2002-02-27 14:10:24.567 Stickies[363] Can't connect to pbs object "RulebookServer"
2002-02-27 14:10:27.743 SystemUIServer[354] connection timeout: did not receive reply
2002-02-27 14:10:35.217 Mail[361] Lookup in pbs of server "RulebookServer" failed.
2002-02-27 14:10:35.218 Mail[361] Can't connect to pbs object "RulebookServer"
2002-02-27 14:10:37.895 Console[359] Thread 0x800013b8: tossing reply message sequence 10
2002-02-27 14:10:37.897 Terminal[358] Thread 0x800013b8: tossing reply message sequence 10
2002-02-27 14:10:37.901 Stickies[363] Thread 0x800013b8: tossing reply message sequence 1
2002-02-27 14:10:37.903 SystemUIServer[354] Thread 0x800013b8: tossing reply message sequence 10
2002-02-27 14:10:37.906 Mail[361] Thread 0x800013b8: tossing reply message sequence 1
2002-02-27 14:29:23.966 Mail[361] Font WoodtypeOrnaments-One: descent is 0.



[ Reply to This | # ]