Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Changes in autodiskmount for 10.1.2 as regards to moving mount points' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Changes in autodiskmount for 10.1.2 as regards to moving mount points
Authored by: bjd14 on Jan 29, '02 02:41:15PM

Thanks nrich123 for your invaluable help in setting this up!

There seems to have been some changes made in where the automounter is activated in 10.1.2 (build 5P48). Here is what I had to do differently:

in /etc/hostconfig there was no variable called AUTODISKMOUNT, so i skipped the step of setting this variable to -NO-, of course.

instead the autodiskmount seems to be turned on in the /System/Library/StartupItems/Disks/Disks file at the top in the following lines:

---snip---
##
# Mount any remaining filesystems
##

if [ ! -f /var/db/volinfo.database ]; then Uninitialized_VSDB=-YES-; fi

ConsoleMessage "Mounting media"

/sbin/autodiskmount -va

if [ "${Uninitialized_VSDB:=-NO-}" = "-YES-" ]; then vsdbutil -i; fi

---snip---

If you add your custom mounting scheme to the end of this file,as nrich123 suggests, the system will still automount your disks onto /Volumes before it gets to your mount commands. So, in order to avoid this, add your mount commands before this section of the Disks file.

After doing this things have been working beautifully for me. Again, thanks for this invaluable advice nrich123.

Best,
Ben Dubin-Thaler



[ Reply to This | # ]