Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Working on Panther now - if CUPS denies login...' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Working on Panther now - if CUPS denies login...
Authored by: globedesign on Oct 09, '04 06:48:30AM

I recently had an issue after upgrading my iMac 233 [original Bondi running 512Mb Ram, 40Gig HD] from Jaguar to Panther, plus all the Security Updates. This was also however a HD upgrade [from the original 4Gig to 40Gig taken from my G4], so the Panther install was a fresh install. Having configured the printer via CUPs as mentioned above on Jaguar i thought i could just repeat the process on Panther! But at stage 7 i was stuck. CUPs would not allow me to login - even as root. I tried several other ways, even configuring the printers.conf file with Terminal.
Cut to the chase, here's how i worked it:
01- Follow Hoosier_1701 instructions above until step 7.
01a- I had to install gimp-print-4.2.7 [found here: http://prdownloads.sourceforge.net/gimp-print/gimp-print-4.2.7-0.ppc.dmg?download ] to get the driver for my printer but YOU MAY NOT NEED TO DO THIS
02- Open Printer Setup Utility
03a- Alt-Click Add [to allow access to the Advanced menu]
03b- Select Advanced at the bottom of the drop down
03c- Select your USB printer from the Device list, should be named and at the very bottom of the drop down [to get the URI only]
03d- Copy the Device URI which looks like - usb://Canon/i250?serial=xxxxxx [this will be your printer]
04a- Then reselect from the Device list USB Printer [as it says: USB Printer]
03b- enter an alternate name for your printer in Device Name, like i250pc
04c- then paste the URI into Device URI
04d- then select your Printer Model from the drop down menu! [mine was the gimp-print driver version, if your regular driver doesn't work try installing gimp-print as in step 01a]
05- then, if you haven't already set up the PC, follow Hoosier_1701 instructions for this
That should be it! Works fine for me now... Good Luck!

PS If this forum didn't exist where would we all be?



[ Reply to This | # ]