Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'Update the ServerLogistics 'Complete' packages' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
Update the ServerLogistics 'Complete' packages
Authored by: seanhussey on Sep 29, '04 04:14:05PM

So do I, but in a different place (and this is with both Apache 2.0.51 and 2.0.52):

checking for Apache 2.0 filter-module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS...

Sorry, I cannot run apxs. Possible reasons follow:

1. Perl is not installed
2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
3. Apache was not built using --enable-so (the apxs usage page is displayed)

The output of /Library/Apache2/bin/apxs follows:
dyld: /Library/Apache2/bin/httpd version mismatch for library: /Library/Apache2/lib/libexpat.0.dylib (compatibility version of user: 6.0.0 greater than library's version: 2.0.0)
apxs:Error: Sorry, no shared object support for Apache.
apxs:Error: available under your platform. Make sure.
apxs:Error: the Apache module mod_so is compiled into.
apxs:Error: your server binary `/Library/Apache2/bin/httpd'..
configure: error: Aborting



[ Reply to This | # ]
Update the ServerLogistics 'Complete' packages
Authored by: dietermay on Sep 30, '04 07:10:17PM

I had the same error. After removing fink (/sw/bin) from my $PATH,
everything functioned. Apache-2.052 and PHP-4.3.9.



[ Reply to This | # ]
$PATH problem
Authored by: BjarneDM on Oct 01, '04 05:36:01AM

OK - if the problem seems to be related to the $PATH then - have you executed the commands under the 'Complete' tabs on my site ?
They add Apache, PHP4 and MySQL to your path *before* fink, so these directories get searched for the required libraries before fink is searced.

Sometimes, it seems as if the [dir] parameter to a directive gets ignored. This is eg a problem when enabling curl in PHP5 - the configure process finds the version in /usr/bin even though the [dir] path has explicitly been set to /darwinports



[ Reply to This | # ]