Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the '10.3: Using WU-IMAP with SSL and xinetd revisited' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.3: Using WU-IMAP with SSL and xinetd revisited
Authored by: preterosso on Feb 22, '04 05:45:00PM

I'm trying to get imap going and squirrelmail. But squirrelmail says:

<i>Unable to connect to IMAP server!
TLS is enabled, but this version of PHP does not support TLS sockets, or is missing the openssl extension.</i>

I have used postfix enabler to start imap. It says its started. Many of the paths that these hints use don't seem to be there. I see in the imap configuration that the owner is root. Should it be set to my user name?

You said in your hint that Makefile needs to be edited in the source. Where is that? I know that openssl is running because I utilized the command to create a certificate, as instructed in the previous hint that you referred to.

As you can probably see, I'm pretty bewildered by this. I'm running Panther 10.3.2.


Also in the last command that you did: make osx, isn't the directory SSLCERTS=/System/Library/Openssl/certs
rather than
SSLCERTS=/System/Library/openssl/certs



[ Reply to This | # ]
10.3: Using WU-IMAP with SSL and xinetd revisited
Authored by: lnzdingo on Mar 23, '04 12:31:20PM

Did you get this figured out? You did answer your own question in a way.

the error says that PHP is missing something.
not squirrelmail and not imap, PHP.

you can try to turn TLS off or you can recompile PHP with TLS and OpenSSL support.



[ Reply to This | # ]