Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the '10.3: Install missing Perl headers' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
10.3: Install missing Perl headers
Authored by: schwern on Nov 27, '03 03:57:13AM

You can't install *any* Perl modules without the CORE headers, even those that don't include XS. You have to upgrade ExtUtils::MakeMaker from CPAN to 6.18 or higher to be able to install pure Perl modules without the Perl CORE headers.

In order to get the Perl CORE headers in 10.3 you need to install the optional BSD SDK bit of Dev Tools. Its unfortunate that you need to install this rather large package just to get at a handful of C header files.

Apple made a somewhat unfortunate decision to move the Perl CORE headers from the DevSDK in 10.2, which always gets installed when you install DevTools, to the BSDSDK in 10.3, which is optional. This move was noticed too late to convince Apple to move it back. :(



[ Reply to This | # ]