Submit Hint Search The Forums LinksStatsPollsHeadlinesRSS
14,000 hints and counting!


Click here to return to the 'X11 Forwarding from Jaguar no longer works right' hint
The following comments are owned by whoever posted them. This site is not responsible for what they say.
X11 Forwarding from Jaguar no longer works right
Authored by: Ross Beveridge on Nov 26, '03 05:05:39PM

I have a similar experience. Through all versions of OS 10.2 ssh with X11 forwarding worked fine. I now consistently get:

Warning: No xauth data; using fake authentication data for X11 forwarding.

messages when making ssh -X connections to either Linux or Solaris machines. Notably, exactly the same machines to which such connections worked properly before installing panther with the install archive option. I have reinstalled the most recent verion of X11 from the apple site, and also edited ssh_config and sshd_config to include

ForwardX11 yes

I am running out of ideas. Anyone out there found the fix?



[ Reply to This | # ]
X11 Forwarding from Jaguar no longer works right
Authored by: Ross Beveridge on Dec 03, '03 04:20:22PM

For others having the above problem, I have found a weak work around that is simple. Under X11 preferences, under security, disable (uncheck) both 'Authenticate connections' and 'Allow connections from network clients'. This is not ideal, since it represents a less secure mode of operation, but it at least fixes the immediate problem and allows remote connections through 'ssh -X'.



[ Reply to This | # ]
X11 Forwarding from Jaguar no longer works right
Authored by: chriswf on Mar 11, '04 03:19:00PM

I'm having the same problem. I know it was a while ago, but did you find a solution?


Thanks,
chris



[ Reply to This | # ]